Gigabyte XM300 Mouse - Page 44 - Overclock.net

Forum Jump: 
Reply
 
Thread Tools
post #431 of 650 Old 06-10-2016, 03:43 PM
pez
Apple flavored Oreos
 
pez's Avatar
 
Join Date: May 2008
Location: North Carolina
Posts: 15,417
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 517
Send a message via AIM to pez Send a message via MSN to pez
This must be the reason they bundled it with the G1 1080. It looks to fix all of my gripes with the DeathAdder smile.gif.
pez is offline  
Sponsored Links
Advertisement
 
post #432 of 650 Old 06-10-2016, 04:04 PM
 
haefen's Avatar
 
Join Date: Feb 2016
Posts: 62
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 4
Seems promising on F21 firmware, haven't encountered double click or stuck button issue so far, but longer Overwatch or CSGO session is yet to come.
Even with some previous issues I still couldn't help loving this mouse.
I can live with scroll as long as it works at all and no more issues so far on F21, maybe except lower DPI, than set in app, but this can be easily adjusted with in-game sens.

I use consistent lighting, but I also use 500hz, which is unaffected.
Haven't really tested on 1000hz, as I'm not that curious. tongue.gif
haefen is offline  
post #433 of 650 Old 06-10-2016, 04:07 PM
 
lerrk's Avatar
 
Join Date: Jun 2016
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 1
Quote:
Originally Posted by haefen View Post

Seems promising on F21 firmware, haven't encountered double click or stuck button issue so far, but longer Overwatch or CSGO session is yet to come.
Even with some previous issues I still couldn't help loving this mouse.
I can live with scroll as long as it works at all and no more issues so far on F21, maybe except lower DPI, than set in app, but this can be easily adjusted with in-game sens.

I use consistent lighting, but I also use 500hz, which is unaffected.
Haven't really tested on 1000hz, as I'm not that curious. tongue.gif
Yep, no double clicks or stuck here, but mousewheel is...
lerrk is offline  
Sponsored Links
Advertisement
 
post #434 of 650 Old 06-10-2016, 04:34 PM
 
delledonne's Avatar
 
Join Date: Jun 2014
Posts: 127
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I decided to chance one when amazon got some new ones in stock a couple of weeks ago, so far so good thumb.gif
delledonne is offline  
post #435 of 650 Old 06-11-2016, 12:16 AM
 
lerrk's Avatar
 
Join Date: Jun 2016
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 1
No wheel rattle?
lerrk is offline  
post #436 of 650 Old 06-11-2016, 05:16 AM
 
Dr Strangelove's Avatar
 
Join Date: Jul 2014
Posts: 108
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
Mine arrived yesterday.
The shape is great and immediately fitted my hand. LMB and RMB are ok but the front side button does not appear to be propperly attached. At least there is a little bit of clearance where the button just rattles around. The click itself is a bit hard to actuate after this clearance. Rear button is fine though.
Furthermore the scroll wheel just feels flimsy and cheap. Its feedback is not that punctured, rather squishy. And the sensor does rattle a lot, such as some of the buttons in the vertical line.

I am currently weaving between the XM300 and the DA Chroma which has by far the crispier buttons. Both shapes feel fine but the Gigabyte gives a little bit more grip.
Would it be worth to ask for a replacement at this point? Or is it unlikely to receive another sample that is in better condition (especially in terms of buttons)?
Just got them yesterday so I got the right of withdrawal for both of them.
Dr Strangelove is offline  
post #437 of 650 Old 06-11-2016, 06:07 AM
 
danieldnl's Avatar
 
Join Date: May 2016
Posts: 23
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 1
I'm on my 2nd xm300 at the moment, my first was perfect except for the button stuck issue. my new one has mwheel rattle and rattle insider the mouse, maybe sensor? idk..
thinking about an rma.

dpi is really off on mine, 400 is always between 327 and 334 with mousetester 1.2, 500 and 1000 hz
danieldnl is offline  
post #438 of 650 Old 06-11-2016, 08:33 AM
Commodore 64
 
Ubsidion's Avatar
 
Join Date: Jan 2011
Posts: 18
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 0
I have had my XM300 for over two months now. I read prior to buying it that alot of people were having issues whith the scroll wheel. I have been putting in several ours a day of game time, and the build still feels solid. I feel lucky because my copy feels flawless. Mouse clicks are without falt, and the mouse wheel is firm and sound. I just love this mouse. Glides great too
Ubsidion is offline  
post #439 of 650 Old 06-11-2016, 12:54 PM
 
lerrk's Avatar
 
Join Date: Jun 2016
Posts: 24
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 1
I fixed mouse ruttle by disassembling mouse and adding o-ring to left side of the mousewheel.
Screws are: 2 under sticker, and 1 under both small mousefeet.
SoFGR likes this.
lerrk is offline  
post #440 of 650 Old 06-11-2016, 01:14 PM
 
Dr Strangelove's Avatar
 
Join Date: Jul 2014
Posts: 108
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 18
Will modifications actually void the warranty considering such obvious "design flaws"?
Dr Strangelove is offline  
Reply

Quick Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off