WOW! X2 550W RMA for X3 1000W!! - Page 6 - Overclock.net

Forum Jump: 
Reply
 
Thread Tools
post #51 of 53 Old 04-03-2008, 01:54 PM
4.0ghz
 
tkl.hui's Avatar
 
Join Date: Oct 2007
Posts: 1,025
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 63
That thing is a monster. You're so lucky you got that. When my coolermaster 550w made fan noises, i just got the same PSU back. Luck you, you go from an X2 550w to an X3 1000w.

tkl.hui is offline  
Sponsored Links
Advertisement
 
post #52 of 53 Old 04-03-2008, 02:12 PM - Thread Starter
Slow To Upgrade
 
Join Date: Jun 2006
Location: South Carolina Now!
Posts: 4,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 362
Quote:
Originally Posted by tkl.hui View Post
That thing is a monster. You're so lucky you got that. When my coolermaster 550w made fan noises, i just got the same PSU back. Luck you, you go from an X2 550w to an X3 1000w.
There's only one reason they did it! They didn't have ANY other modular PSU's in stock and I had already torn apart my PC. The X2 was discontinued so I got the X3

Chimp Challenge Participant 

rsfkevski is offline  
post #53 of 53 Old 04-14-2008, 09:34 PM - Thread Starter
Slow To Upgrade
 
Join Date: Jun 2006
Location: South Carolina Now!
Posts: 4,360
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 362
rsfkevski is offline  
Reply

Quick Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off