EK Club - Page 1667 - Overclock.net

Forum Jump: 
 1Likes
Reply
 
Thread Tools
post #16661 of 21284 Old 07-30-2016, 02:05 AM
 
Lays's Avatar
 
Join Date: Feb 2014
Posts: 537
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 20
Quote:
Originally Posted by 0ldChicken View Post

I wouldn't think it would happen that fast but using silver and nickel together is asking for corrosion issues. I believe it's supposed to eat the plating, or at least pit/flake it
edit: this must be the ltt page tongue.gif


So the only solution would be to re-fill the loop, get anti corrosive of some sort and a biocide and get rid of the kill coil?


Is there any way I can clean the block out without taking it apart? I wouldn't be surprised if that voids the 1080's warranty as well, since it's a factory installed block.



EDIT:

So my old nickel acetal universal GPU block is fine on the inside.. And I'm using the SAME loop.

Last edited by mark_e; 06-30-2014 at 05:50 PM.
Lays is offline  
Sponsored Links
Advertisement
 
post #16662 of 21284 Old 07-30-2016, 02:14 AM
 
Vindicare's Avatar
 
Join Date: Dec 2014
Posts: 97
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 1
use a good premix like EK-Ekoolant EVO CLEAR
Vindicare is offline  
post #16663 of 21284 Old 07-30-2016, 03:05 AM
 
Join Date: Jul 2012
Location: France
Posts: 1,313
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 17
Waterblock Monoblock for Rampage V Edition 10 avalaible this monday

Waiting for Full Board


Sorry for my english biggrin.gif
tistou77 is offline  
Sponsored Links
Advertisement
 
post #16664 of 21284 Old 07-30-2016, 07:07 AM
Ladies, Please, One at a Time
 
TheCautiousOne's Avatar
 
Join Date: Jul 2014
Location: Maurice, Louisiana
Posts: 9,471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 318
TheCautiousOne is offline  
post #16665 of 21284 Old 07-30-2016, 07:25 AM
New to Overclock.net
 
Join Date: Apr 2012
Posts: 4,837
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Liked: 675
IT Diva is offline  
post #16666 of 21284 Old 07-30-2016, 07:26 AM
Retired Staff
 
DarthBaggins's Avatar
 
Join Date: Aug 2013
Location: Kennesaw, GA/Nantucket, MA
Posts: 9,477
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Liked: 90
DarthBaggins is online now  
post #16667 of 21284 Old 07-30-2016, 07:50 AM
nVidia Enthusiast
 
fbmowner's Avatar
 
Join Date: Sep 2007
Location: NJ
Posts: 350
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 10
I am about to put together a full EK loop, but I am seeing what some people in the forums have to say about what I chose or I am waiting to hear from someone that I forgot something! I mean the EK kit someone has suggested is a great price vs the $500 I am getting ready to spend, although my choices increase my price a good amount based on the D5 pump I picked, and the fittings. Feel free to point me in another direction if I am going down the wrong path! I envy you all! =P
fbmowner is offline  
post #16668 of 21284 Old 07-30-2016, 08:05 AM
WaterCooler
 
0ldChicken's Avatar
 
Join Date: May 2015
Posts: 951
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 44
Quote:
Originally Posted by Lays View Post

So my old nickel acetal universal GPU block is fine on the inside.. And I'm using the SAME loop.
damn, that's not good. @Benjiw who else was having issues with this? I can't find anything in seahawk club/ek club or wc club
0ldChicken is offline  
post #16669 of 21284 Old 07-30-2016, 09:05 AM
Ladies, Please, One at a Time
 
TheCautiousOne's Avatar
 
Join Date: Jul 2014
Location: Maurice, Louisiana
Posts: 9,471
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 318
TheCautiousOne is offline  
post #16670 of 21284 Old 07-30-2016, 09:22 AM
EKWB Forum Support Representative
 
Join Date: Aug 2012
Location: Quebec, Canada
Posts: 4,660
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Liked: 279
Quote:
Originally Posted by AllGamer View Post

yes, I like the clear plexi as well, but for the new kind the only have the frosted version.

I found some of the old versions with the 3 screws, instead of 1 screw, interesting they call the old type "Terminal" and the new type "Bridge"

Which brings me to the new question...


So I got 2 of these beauties, looking at the close up pictures, it shows they are using the 3 screws, which should match the old Terminal type.

Does it matter at all if I use the CSQ Bridge type with 1 mount screw, or the old Terminal type with 3 mount screws?
Warning: Spoiler! (Click to show)

First, the old type the is the "EK-FC Bridge" and the new one is the "EK-FC Terminal".

Second, you can't mix and match them. The EK-FC Bridge (the ones with all the circles on it) can ONLY be used with the blocks that have the Original CSQ look (the ones with all the circles on it). Since you're going with GPU blocks from the 10x0 series, you'll be using on the EK-FC Terminal type of connectors.
akira749 is offline  
Reply

Quick Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page


Forum Jump: 

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off