Overclock.net › Forums › Components › Sound Cards and Computer Audio › sound card or driver issue?
New Posts  All Forums:Forum Nav:

sound card or driver issue?

post #1 of 7
Thread Starter 
okay so when i play BC2 for any extended amount of time (over an hour) i get a freeze then it goes back to normal but the sound is severely distorted and has an electronic sounding echo. now is my sound card failing or is it the crap creative drivers causing this? it works flawless on my Onboard.
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
post #2 of 7
I'm going to say drivers, however it could be either to be honest. Completely uninstall the drivers, download the latest version and reinstall them (after two restarts, of course - always restart after installing/uninstalling drivers). The latest drivers work fine with my card, so if the problem persists - look around the internet. It may be an issue with BC2.

Does this happen in any other games? May be worth playing another game for a while to see if the problem repeats itself.
Project 4
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 Lynnfield @ 4.4 GHz, 1.41v EVGA P55 SLi (132-LF-E655-KR) - A72 BIOS EVGA GeForce GTX 680 4GB G.Skill Ripjaws @ 9-9-9-24, 1.51V 
Hard DriveOptical DriveOSMonitor
80GB Intel X25-M SSD + 500GB WD + 2TB Samsung F3 Samsung Super Writemaster DVD+-R Windows 7 Ultimate Edition Samsung SyncMaster 2433 24" 
KeyboardPowerCaseMouse
Logitech G15 Corsair TX750 750W Corsair Obsidian 800D + Scythe Kaze Master Ace Razer Deathadder Respawn - Black 
Mouse Pad
Steelseries QcK Medium - Black 
  hide details  
Reply
Project 4
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 Lynnfield @ 4.4 GHz, 1.41v EVGA P55 SLi (132-LF-E655-KR) - A72 BIOS EVGA GeForce GTX 680 4GB G.Skill Ripjaws @ 9-9-9-24, 1.51V 
Hard DriveOptical DriveOSMonitor
80GB Intel X25-M SSD + 500GB WD + 2TB Samsung F3 Samsung Super Writemaster DVD+-R Windows 7 Ultimate Edition Samsung SyncMaster 2433 24" 
KeyboardPowerCaseMouse
Logitech G15 Corsair TX750 750W Corsair Obsidian 800D + Scythe Kaze Master Ace Razer Deathadder Respawn - Black 
Mouse Pad
Steelseries QcK Medium - Black 
  hide details  
Reply
post #3 of 7
do you have any applications trying to upscale the sound from 16bit->24bit etc?
Do you have klite Codec pack installed.
Go to ffdshow audio decoder make sure the game is black listed in it.
do you have nero installed on your pc?
disable nero audio decoder filter (Neaudio.ax)
post #4 of 7
Thread Starter 
Quote:
Originally Posted by jNSK View Post
I'm going to say drivers, however it could be either to be honest. Completely uninstall the drivers, download the latest version and reinstall them (after two restarts, of course - always restart after installing/uninstalling drivers). The latest drivers work fine with my card, so if the problem persists - look around the internet. It may be an issue with BC2.

Does this happen in any other games? May be worth playing another game for a while to see if the problem repeats itself.
only happens in BC2 driver reinstall had no effect.


Quote:
Originally Posted by Spooony View Post
do you have any applications trying to upscale the sound from 16bit->24bit etc?
Do you have klite Codec pack installed.
Go to ffdshow audio decoder make sure the game is black listed in it.
do you have nero installed on your pc?
disable nero audio decoder filter (Neaudio.ax)
no my card is native 24 bit
never even heard of it
once again never heard of it
no i don't like nero
dont have nero
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
Tha Beast!
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K 4.4Ghz 1.25V ASUS Z87 Sabertooth EVGA GTX 1080 FTW2 iCX 2126/11GHz 16GB DDR3 2400Mhz 
Hard DriveHard DriveCoolingOS
Kingston 480GB SSD HGST 2TB Corsair H100i Windows 10 Home 64-bit 
MonitorKeyboardPowerCase
AOC I2269VW-B 22" Razer BlackWidow Ultimate 2014 Corsair HX650 Corsair Vengance C70 Gunmetal 
MouseMouse PadAudio
Razer Deathadder 2013 Razer goliathus Sound Blaster X-FI Xtreme Audio PCIe 
  hide details  
Reply
post #5 of 7
creative drivers do suck, i had a game that if on highest audio settings id get a blue screen every time i loaded, very sceptically i tried these drivers: http://www.paxyoursoundout.com/ (the website instantly put me off) but i was amazed, it fixed the blue screen, as i said i was extremely sceptical but they work, give em a try
post #6 of 7
Check this out. Discussion of exact issue with BC2.

http://forums.steampowered.com/forum....php?t=1342421
post #7 of 7
Quote:
Originally Posted by philhalo66 View Post
only happens in BC2 driver reinstall had no effect.




no my card is native 24 bit
never even heard of it
once again never heard of it
no i don't like nero
dont have nero
bc is only 16bit you doesn't matter what your card have lol. Go to the X-fi settings and select the speaker config AS IS. If its already on AS IS then try to disable it and see if it works
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › sound card or driver issue?