Overclock.net › Forums › Components › Power Supplies › Antec 520C powering problem.
New Posts  All Forums:Forum Nav:

Antec 520C powering problem.

post #1 of 9
Thread Starter 
Hi
I've found my problem of computer not powering up, the PSU

My new build:
Core i5 2500
8gb Kingston DDR3 1333 (not hyper X)
Gigabyte GTX550Ti graphics
asus P8p67 PRO motherboard
WD 500GB SATA3
NZXT Phantom Case
Antec Neo 520C PSU

After 5 days of DOA replacing parts in numerous shops where i've bought my parts... It came down to the last component which I haven't tested, the PSU

My problem is that as soon as i press the power button on the case, the cpu red led blinks and turns off very quickly ONCE. all the fans moves about 1mm, like a small jolt, and everything doesnt work anymore until i turn off the PSU, wait till the power drains out, then turn back on the PSU.
After downgrading most of my parts, (i5 2500 to 2400 because no stock), which is bad news for me but good news for my mum coz save money, it came down to the last part I didn't replace in DOA, the PSU.

So to test my psu, i used my old 430W Thermaltake OEM psu and plugged it onto my mobo (I took out the mobo from the case and laid it on some soft cover books, and then the anti static bag which came with the mobo. I pressed the power on button on that case, it turns on. ITS ALIVE!!!! POST BEEP EVERYTHING!!!!

So therefore it is the ANTEC NEO 520C's fault.
What i am a bit confused about is the 24pin connector....why is there 1 line missing in the 24pin connector...? (1 line missing out of the 24 lines = only 23 lines)the missing line is between 3 red lines and 3 black lines...

I would love to hear the lovely comments

Thanks and good day.
post #2 of 9
Hmmm..that could have very well been the problem,must of been manafacturing error.
post #3 of 9
Thread Starter 
u think so too?
Well the place i bought my PSU is such a Bi*ch. If they don't let me exchange for another brand, swap or refund, i will definitely report this company to an ombudsman.

sigh.. 5 days of trying to fix the new computer: 6 trips to the first computer shop, 3 trips to the 2nd computer shop, 2 sleepless nights, all for absolutely NOTHING. Wasted 5 days of my life for nothing =="
post #4 of 9
Thread Starter 
1 Question.. would love to hear alot of feedback...
Should I just swap for a new Antec 520C? the same PSU?

Or should i go for a um.. say Coolermaster eXtreme power 550W?
Can someone recommend me a PSU which is similar price to the ANtec 520C? up to +20 dollars difference is fine
thanks!!
post #5 of 9
I can't double check which is the missing pin on your connector right now, but it is normal for one to be missing.

Edit: I did double check after all the missing wire is indeed normal. It's for the -5V rail which has not been used in a long time.
Edited by Shub - 4/27/11 at 4:17am
post #6 of 9
The 520C is a neo eco right? That's a very respectable unit, everyone gets a DOA now and again. You can swap for another one and it's very unlikely you'll get another DOA.

I've never heard of an ombudsman which leads me to believe you're probably in the UK or somewheres in another land than mine, so I don't know what you've paid for your 520C, and I'm not great with overseas pricing, but in general you can often find a truepower new for a reasonable price, enjoy even higher quality than neo eco and modularity to boot.
The Corsair CX430 isn't a horrible unit and is usually basically free. A bit pricier but pretty neat is the FSP Aurum gold 400, good quality gold rated, should handle your rig fine as long as you don't SLI, a bit pricey. Just some options. There's a recommended power supply list here if you'd like to go price comparing yourself.
Bleeding Edge
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 5.0Ghz 24/7 ASUS P8P67PRO AMD 5870x2 8GB GSkill Ripjaw X 1600 @ CL8 
Hard DriveOSMonitorKeyboard
ADATA S599 64GB SSD + 2x 1TB Spinpoint (Raid 0) Windows 7 64Bit Dell 23" Razer Lycosa 
PowerCase
Seasonic X650 HAF X 
  hide details  
Reply
Bleeding Edge
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 5.0Ghz 24/7 ASUS P8P67PRO AMD 5870x2 8GB GSkill Ripjaw X 1600 @ CL8 
Hard DriveOSMonitorKeyboard
ADATA S599 64GB SSD + 2x 1TB Spinpoint (Raid 0) Windows 7 64Bit Dell 23" Razer Lycosa 
PowerCase
Seasonic X650 HAF X 
  hide details  
Reply
post #7 of 9
Thread Starter 
yeh its a Neo Eco 520C (520W continuous power)
So do you think im just unlucky enough to get a dud one? I should just ask them to swap for another same new one?

The coolermaster ExtremePower 550W isnt in that list from the link in the above post... better not get that xD

So I should just stick with the Neo Eco 520C?

I dont have SLI nor i am going to overclock so 520W should be enough for me
post #8 of 9
Thread Starter 
My dad has a quick question also...
Will this PSU: ANTEC NEO ECO 520C be compatible with my specs above? in OP:

My new build:
Core i5 2500
8gb Kingston DDR3 1333 (not hyper X)
Gigabyte GTX550Ti graphics
asus P8p67 PRO motherboard
WD 500GB SATA3
NZXT Phantom Case
Antec Neo 520C PSU
post #9 of 9
The 520c is a good PSU. You may have gotten a dud, which does happen on occasion.
Just exchange it for another one. If it does it again, it is not the PSU.
Also, did you try the 520 while the motherboard was out of the case? What you described could also be the mobo9 shorting out on the case (you did use the case standoff, right).

I always do a build out of the case first to make sure it works, then install in the case (and do not put the mobo on the anti-static bag, it can conduct a charge on the outside of the bag, just set the board on the cardboard box it came with).
'Pooter
(15 items)
 
Server
(15 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II 830 x4 Gigabyte GA-880GM-D2H MSI GTX 460 Hawk 12 gigs (2x2 and 2x4) Corsair DDR3 1600 
Hard DriveOptical DriveOptical DriveCooling
Samsung  Samsung DVD-RW  Samsung DVD-RW  Cooler Master Hyper 212+ 
OSMonitorKeyboardPower
Windows 7 Pro x64 ASUS VH242H 23.6" Logitech MX 3200 Wireless Antec Neo Eco 620 
CaseMouseOther
Antec P-180 Mini Logitech MX 3200 Wireless Crucial m4 128  
CPUMotherboardGraphicsRAM
AMD Athlon II X2 210e Gigiabyte MA785GMT-UDH2 ATI Radeon HD 4200 G.Skill Sniper 
Hard DriveHard DriveCoolingOS
OCZ SSD Seagate SSHD Corsair A50 WHS 2011 
PowerCase
Antec Neo Eco 400 Antec 300 
  hide details  
Reply
'Pooter
(15 items)
 
Server
(15 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II 830 x4 Gigabyte GA-880GM-D2H MSI GTX 460 Hawk 12 gigs (2x2 and 2x4) Corsair DDR3 1600 
Hard DriveOptical DriveOptical DriveCooling
Samsung  Samsung DVD-RW  Samsung DVD-RW  Cooler Master Hyper 212+ 
OSMonitorKeyboardPower
Windows 7 Pro x64 ASUS VH242H 23.6" Logitech MX 3200 Wireless Antec Neo Eco 620 
CaseMouseOther
Antec P-180 Mini Logitech MX 3200 Wireless Crucial m4 128  
CPUMotherboardGraphicsRAM
AMD Athlon II X2 210e Gigiabyte MA785GMT-UDH2 ATI Radeon HD 4200 G.Skill Sniper 
Hard DriveHard DriveCoolingOS
OCZ SSD Seagate SSHD Corsair A50 WHS 2011 
PowerCase
Antec Neo Eco 400 Antec 300 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Antec 520C powering problem.