Overclock.net › Forums › Graphics Cards › AMD/ATI › Is my 6970 bad?
New Posts  All Forums:Forum Nav:

Is my 6970 bad?

post #1 of 4
Thread Starter 
So out of no where, ive been having issues with my display. Right now im running a WC 6970 with eyefinity. The problem is that out of random times my monitors will go black or grey and i cannot do anything but restart. When i restart, my motherboard makes the beeps indicating theres no vga detected. after shutting down for a few mins, it starts to work again. I dont know what it is exactly or where to start. is it the 6970? is it the power supply? or is it the motherboard? also does anyone know if sapphire rma my card even if its been watercooled?
Sky
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-970 Asus P6X58D-E AMD Diamond 6950 3x2Gb DDR3 1600 Corsair Dominator 
Hard DriveOSMonitorKeyboard
G.SKILL Phoenix Pro 120GB Windows 7 Home 64bit 3xSamsung 2033 Razer Mechanical Keyboard 
PowerCaseMouseMouse Pad
Corsair HX850w modular Corsair Obsidian 800D Mionix Naos 3200 Razer Kabuto 
  hide details  
Reply
Sky
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7-970 Asus P6X58D-E AMD Diamond 6950 3x2Gb DDR3 1600 Corsair Dominator 
Hard DriveOSMonitorKeyboard
G.SKILL Phoenix Pro 120GB Windows 7 Home 64bit 3xSamsung 2033 Razer Mechanical Keyboard 
PowerCaseMouseMouse Pad
Corsair HX850w modular Corsair Obsidian 800D Mionix Naos 3200 Razer Kabuto 
  hide details  
Reply
post #2 of 4
How often/ when did this start happening. Sounds like overheating/ bad VRAM.
Xeno Storm V 1.2
(19 items)
 
RetroPie
(13 items)
 
 
CPUMotherboardGraphicsRAM
ARM Cortex-A7 Raspberry Pi 2 Model B Broadcom VideoCore IV 512MB 
Hard DriveHard DriveCoolingOS
64GB Corsair Voyager Go 16GB Micro SD Aluminum heat spreaders RetroPi 
MonitorKeyboardPowerCase
Samsung 23" LED Logitech Wireless Touch Keyboard K400 Anker 24W PowerPort 2 OneNineDesign RasPi Black 
Other
8Bitdo NES30 Pro Controller 
CPUMotherboardGraphicsRAM
i5 7200U Dell Intel HD 8GB LPDDR3 1866MHz 
Hard DriveOSMonitor
M.2 128GB Windows 10 13.3" FHD AG 
  hide details  
Reply
Xeno Storm V 1.2
(19 items)
 
RetroPie
(13 items)
 
 
CPUMotherboardGraphicsRAM
ARM Cortex-A7 Raspberry Pi 2 Model B Broadcom VideoCore IV 512MB 
Hard DriveHard DriveCoolingOS
64GB Corsair Voyager Go 16GB Micro SD Aluminum heat spreaders RetroPi 
MonitorKeyboardPowerCase
Samsung 23" LED Logitech Wireless Touch Keyboard K400 Anker 24W PowerPort 2 OneNineDesign RasPi Black 
Other
8Bitdo NES30 Pro Controller 
CPUMotherboardGraphicsRAM
i5 7200U Dell Intel HD 8GB LPDDR3 1866MHz 
Hard DriveOSMonitor
M.2 128GB Windows 10 13.3" FHD AG 
  hide details  
Reply
post #3 of 4
bad drivers? tried reinstalling drivers? *just a guess this is * worth a shot to be honest

Edit: What temps do you get? idle/load, is it OC'ed?
Ren - First Born
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Maximus IV GENE-Z NVIDIA GeForce Matrix GTX 580 Platinum G-Skill RipJawX 8GB 1600MHz  
Hard DriveHard DriveCoolingOS
2x 1TB Samsung F3 in Raid 0 60GB OCZ Vertex 2 Corsair H80 Windows 7 64-bit 
MonitorKeyboardPowerCase
Hanns.G 27" 1920 x 1200 Apple Aluminum Keyboard Thermaltake ToughPower XT 775w Silverstone TJ08-E 
Mouse
Razer Deathadder 
  hide details  
Reply
Ren - First Born
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500K Maximus IV GENE-Z NVIDIA GeForce Matrix GTX 580 Platinum G-Skill RipJawX 8GB 1600MHz  
Hard DriveHard DriveCoolingOS
2x 1TB Samsung F3 in Raid 0 60GB OCZ Vertex 2 Corsair H80 Windows 7 64-bit 
MonitorKeyboardPowerCase
Hanns.G 27" 1920 x 1200 Apple Aluminum Keyboard Thermaltake ToughPower XT 775w Silverstone TJ08-E 
Mouse
Razer Deathadder 
  hide details  
Reply
post #4 of 4
Try using different ports for your modular cable setup, and also separate cables of the ones you're currently using. If that doesn't work, reseat your card into a different slot. If that doesn't work, then chances are your card is the culprit.

Scenario 2: It's drivers, and you need to use something like Driver Cleaner Pro, or something of the sort to remove the unnecessary overflow from driver updates.

If, after both, nothing works, backup your information and reinstall your OS, going from there. GLWYS.
The Outrider
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 Extreme 990X P6T6 WS REVOLUTION Radeon HD 7970 G. Skill 24GB Kit 
Hard DriveHard DriveOptical DriveCooling
Western Digital 2TB Caviar Black 1TB SSD BluRay Burner Corsair H100 
OSMonitorPowerCase
Windows 7 Ultimate 24" ASUS HDMI Corsair 1200w Gold Cooler Master CSX Green Dragon XXLE (6 of 300 -... 
MouseMouse PadAudioAudio
Razer Tron Razer Goliathus Auzentech X-Fi Home Theater HD Logitech Z-5450 
AudioOther
4.1 Trash Set tuned crispy Blackmagic Intensity Pro 
  hide details  
Reply
The Outrider
(18 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 Extreme 990X P6T6 WS REVOLUTION Radeon HD 7970 G. Skill 24GB Kit 
Hard DriveHard DriveOptical DriveCooling
Western Digital 2TB Caviar Black 1TB SSD BluRay Burner Corsair H100 
OSMonitorPowerCase
Windows 7 Ultimate 24" ASUS HDMI Corsair 1200w Gold Cooler Master CSX Green Dragon XXLE (6 of 300 -... 
MouseMouse PadAudioAudio
Razer Tron Razer Goliathus Auzentech X-Fi Home Theater HD Logitech Z-5450 
AudioOther
4.1 Trash Set tuned crispy Blackmagic Intensity Pro 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Is my 6970 bad?