Overclock.net › Forums › Intel › Intel Motherboards › [Officia]l ASUS ROG Maximus IV GENE-Z68 & Z68(Gen3) Owners Club
New Posts  All Forums:Forum Nav:

[Officia]l ASUS ROG Maximus IV GENE-Z68 & Z68(Gen3) Owners Club - Page 556

post #5551 of 7108
Thread Starter 

Got  tK Fury  &  Smith Xavyez  added to our Google Owners List ... welcome thumb.gif

 

Regarding ;

 

- VIRTU ... personally I'd dissable it and forget it ... the idea didn't live up to expectations IMO, but I can understand the desire to try and get it working smile.gif and I would like to also.

- USB 3.0 ... this isn't to diss those that are having issues, we want to help you get your issues Fixed and you to be happy with your GeneZ board, but I'll just say that the Majority of time you read people having "issue's" with something NOT working on this borad it tends to come back down to USER ERROR ... as you see many people posted they have no problem with it working at all.

- SOUND ... might search WAY BACK in this thread, I do recall there being an issue if you installed the sound drivers in the wrong order, that I recall off the top of my head, the basic realtek driver had to be first, and then you could install the XFi drivers and SoundBlaster stuff after. Might be your issue, don't know ?

   
LG/Google NEXUS 5
(10 items)
 
CPUMotherboardGraphicsRAM
Q9650 Yorkfield Quad-Core Asus IPIBL-LB (HP Benicia-GL8E) Sapphire TOXIC HD6950 {UnLocked 1536 shaders} 8 GB G. Skill Pi Black DDR2 
Hard DriveOptical DriveCoolingOS
SeaGate Barracuda 1TB 32MB Cache HP - DVD/CD combo Drive Cooler Master  MS Vista Home Premium 64 bit 
MonitorKeyboardPowerCase
HP w2207h Widescreen HP Stock BFG Tech LS-680 HP Pavilion 
Mouse
HP stock 
CPUMotherboardGraphicsRAM
Quad Core Krait 400 @ 2.30GHz  Qualcomm MSM8974(Snapdragon 800) Adreno 330 2GB LPDDR3-1600 
Hard DriveOSMonitorKeyboard
32GB NAND Android 4.4 Kitkat 4.95" 1080X1920 IPS Display Swiftkey 
PowerAudio
2300 mAh Battery Stereo Speakers 
  hide details  
Reply
   
LG/Google NEXUS 5
(10 items)
 
CPUMotherboardGraphicsRAM
Q9650 Yorkfield Quad-Core Asus IPIBL-LB (HP Benicia-GL8E) Sapphire TOXIC HD6950 {UnLocked 1536 shaders} 8 GB G. Skill Pi Black DDR2 
Hard DriveOptical DriveCoolingOS
SeaGate Barracuda 1TB 32MB Cache HP - DVD/CD combo Drive Cooler Master  MS Vista Home Premium 64 bit 
MonitorKeyboardPowerCase
HP w2207h Widescreen HP Stock BFG Tech LS-680 HP Pavilion 
Mouse
HP stock 
CPUMotherboardGraphicsRAM
Quad Core Krait 400 @ 2.30GHz  Qualcomm MSM8974(Snapdragon 800) Adreno 330 2GB LPDDR3-1600 
Hard DriveOSMonitorKeyboard
32GB NAND Android 4.4 Kitkat 4.95" 1080X1920 IPS Display Swiftkey 
PowerAudio
2300 mAh Battery Stereo Speakers 
  hide details  
Reply
post #5552 of 7108
thx for the reply on the sound issue. i think im going to go ahead and order a sound card. i need something with alittle more punch anyhow. i think i'll be going with the asus dx card.
always changing
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k msi z97i-ack MSI r9 290 2x8 corsair 1600 
Hard DriveHard DriveCoolingOS
m4 128  wd 1tb black noctua u9s win7 64 
MonitorKeyboardPowerCase
benq 2420z corsair  coolermaster v650 rosewell neutron 
MouseMouse PadAudio
rival 300 razer  corsair sp2500 
  hide details  
Reply
always changing
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k msi z97i-ack MSI r9 290 2x8 corsair 1600 
Hard DriveHard DriveCoolingOS
m4 128  wd 1tb black noctua u9s win7 64 
MonitorKeyboardPowerCase
benq 2420z corsair  coolermaster v650 rosewell neutron 
MouseMouse PadAudio
rival 300 razer  corsair sp2500 
  hide details  
Reply
post #5553 of 7108

1ceTr0n here, *NightFire* is still going strong with long sessions of SWTOR the past few months on the Gene-Z but im getting really tempted to retire my beloved Antec Mini P-180 for Silverstones TJ08-E case.

 

If I do end up going to the dark side, I have a small favor to ask of the OC Gene -Z club. Does anyone who is not using the case sticker that came with the Gene-Z mobo be willing to part with it for a new mod project on the TJ08-E case?

 

 

doneinside2.jpg

 

 

 

 

 

 

 

 

"Night Fire"
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.6ghz ASUS Maximus IV Gene-Z eVGA GTX 570 Superclocked @ 850/1700/1990 G.SKILL Ripjaws 8GB DDR3 
Hard DriveHard DriveOptical DriveOS
WD Caviar Black 640 AALS Intel 520 Cherryville SSD 120gig *Thanks OCN!* Asus DRW-2014L1T Win 7 Home Premium 64 bit 
MonitorKeyboardPowerCase
Dell U2412M Viewsonic VX2025WM Saitek II Antec TruePower New 550w Antec mini P-180 
MouseMouse PadAudio
Logitech Mx518 IceMat X-Fi Titanium w/PAX drivers 
  hide details  
Reply
"Night Fire"
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5 2500k @ 4.6ghz ASUS Maximus IV Gene-Z eVGA GTX 570 Superclocked @ 850/1700/1990 G.SKILL Ripjaws 8GB DDR3 
Hard DriveHard DriveOptical DriveOS
WD Caviar Black 640 AALS Intel 520 Cherryville SSD 120gig *Thanks OCN!* Asus DRW-2014L1T Win 7 Home Premium 64 bit 
MonitorKeyboardPowerCase
Dell U2412M Viewsonic VX2025WM Saitek II Antec TruePower New 550w Antec mini P-180 
MouseMouse PadAudio
Logitech Mx518 IceMat X-Fi Titanium w/PAX drivers 
  hide details  
Reply
post #5554 of 7108
Hello! On my way to become a member of this club here. But I got stymied while trying to make the new system boot.

1. I can't get to Windows with a preloaded HDD. I set everything on stock settings in the BIOS, yet the system does not boot wth.gif. POST screen says overclock error, asks to press F1 to fix my settings in the BIOS. So I went back to BIOS.

2. Now, I am using my TV via HDMI for lack of a proper display atm. Whenever I am at BIOS to fix settings about a third of the screen is always cropped on the right and bottom side on my TV. Is there a way to fix the cropping in UEFI BIOS? I can't see/change every single setting (even after scrolling). The video card is a XFX GeForce 9600 GSO from another system.

Reading the manual and online research haven't helped yet. Nor did tinkering with various zoom mode and overscan settings in my TV.

Can you folks help me with this?

Thanks.
    
CPUMotherboardGraphicsRAM
i7-2600K Maximus IV Gene-z eVGA GTX 580 G.SKILL 2x2GB DDR3-1600 CL9 
Hard DriveCoolingOSMonitor
Crucial M4 128GiB Intel Stock Windows 7 ASUS VG236HE 
KeyboardPowerCaseMouse
Logitech Illuminated Wired Corsair TX750 HAF 932 Logitech G500 
Mouse Pad
Neatly folded Microcenter monthly ad 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7-2600K Maximus IV Gene-z eVGA GTX 580 G.SKILL 2x2GB DDR3-1600 CL9 
Hard DriveCoolingOSMonitor
Crucial M4 128GiB Intel Stock Windows 7 ASUS VG236HE 
KeyboardPowerCaseMouse
Logitech Illuminated Wired Corsair TX750 HAF 932 Logitech G500 
Mouse Pad
Neatly folded Microcenter monthly ad 
  hide details  
Reply
post #5555 of 7108
Thread Starter 

Make a 100% Fresh clean install of WINDOWS do not try and use a preloaded version off your existing HDD / SSD ... you're building a NEW system start from SCRATCH ! and then load up the programs and files off the storage HDD after you get your system up and running and stablized. wink.gif

 

Quote:
Originally Posted by metalmayhem9 View Post
But I got stymied while trying to make the new system boot.
 
1. I can't get to Windows with a preloaded HDD.
Can you folks help me with this?
Thanks.


 

   
LG/Google NEXUS 5
(10 items)
 
CPUMotherboardGraphicsRAM
Q9650 Yorkfield Quad-Core Asus IPIBL-LB (HP Benicia-GL8E) Sapphire TOXIC HD6950 {UnLocked 1536 shaders} 8 GB G. Skill Pi Black DDR2 
Hard DriveOptical DriveCoolingOS
SeaGate Barracuda 1TB 32MB Cache HP - DVD/CD combo Drive Cooler Master  MS Vista Home Premium 64 bit 
MonitorKeyboardPowerCase
HP w2207h Widescreen HP Stock BFG Tech LS-680 HP Pavilion 
Mouse
HP stock 
CPUMotherboardGraphicsRAM
Quad Core Krait 400 @ 2.30GHz  Qualcomm MSM8974(Snapdragon 800) Adreno 330 2GB LPDDR3-1600 
Hard DriveOSMonitorKeyboard
32GB NAND Android 4.4 Kitkat 4.95" 1080X1920 IPS Display Swiftkey 
PowerAudio
2300 mAh Battery Stereo Speakers 
  hide details  
Reply
   
LG/Google NEXUS 5
(10 items)
 
CPUMotherboardGraphicsRAM
Q9650 Yorkfield Quad-Core Asus IPIBL-LB (HP Benicia-GL8E) Sapphire TOXIC HD6950 {UnLocked 1536 shaders} 8 GB G. Skill Pi Black DDR2 
Hard DriveOptical DriveCoolingOS
SeaGate Barracuda 1TB 32MB Cache HP - DVD/CD combo Drive Cooler Master  MS Vista Home Premium 64 bit 
MonitorKeyboardPowerCase
HP w2207h Widescreen HP Stock BFG Tech LS-680 HP Pavilion 
Mouse
HP stock 
CPUMotherboardGraphicsRAM
Quad Core Krait 400 @ 2.30GHz  Qualcomm MSM8974(Snapdragon 800) Adreno 330 2GB LPDDR3-1600 
Hard DriveOSMonitorKeyboard
32GB NAND Android 4.4 Kitkat 4.95" 1080X1920 IPS Display Swiftkey 
PowerAudio
2300 mAh Battery Stereo Speakers 
  hide details  
Reply
post #5556 of 7108
Hi Again,

I'm having big trouble with ASUS in Australia. I wonder if someone can do a quick test for me.

On my Gene-z (not the Gen3, that works fine) with bios 0902 CHA FAN 1 and 2 will not allow variable control of 3pin or PWM fans. It only allows lower speeds on CHA FAN 3, the one near the cmos battery.

Could someone test that? I'm getting mixed signals from ASUS. I RMAd the board and it was sent back saying the fans worked fine. But now another ASUS rep is telling me it isn't working on his own board and it's probably the 0902 bios.

Those two replies from ASUS are obviously inconsistent.

If someone could do a quick test it would be greatly appreciated.

Test:

Can you get 3pin or PWM bios fan control below 100% speed on CHA 1 or CHA 2 (the ones near southbridge and the 24 pin connector). And importantly, what BIOS revision are you on.

Easiest way to test it is this:

connect two of the same fan to CHA FAN 3 (near the cmos battery) and CHA FAN 1 (below the southbridge near the two USB connectors).

Get control data:

Go into the BIOS -> Monitor -> Fan Speed Control
Disable Q-Fan control for CPU and Chassis.
Reboot.
Go into BIOS -> Monitor -> Fan Speed Monitor
Note the speeds of Chassis Fan 1 and Chassis Fan 3. They should be the same -- about the max fan speed.

Go back one, and into Fan Speed Control
Enable CPU Q-Fan Control and Chassis Q-Fan Control
Set both to Silent
Reboot

Repeat the control data test. Note the two fan speeds. If all is working correctly, they should both be running at a slower than max speed.

My results are:

Bios # 0902

control:
FAN1: 1450
FAN3: 1478

With Q-Fan enabled:

Fan1: 1458
Fan3: 930

The same happens for Fan2. They are stuck at 100% power. It should work with PWM or 3pin fans, so take your pick.

Greatly appreciated.
Edited by harlen - 2/20/12 at 1:28am
Mini
(26 items)
 
  
CPUMotherboardGraphicsGraphics
i7 3770k Asus Maximus IV Gene-Z/gen3 Gigabyte GTX 680 Gigabyte GTX 680 
RAMHard DriveOptical DriveCooling
16 GB G.Skill f3-17000CL11-4GBXL Corsair Force 3 240GB SSDx2 LG Super Multi Blue EK-FC Link GeForce x2 
CoolingCoolingCoolingCooling
Bitspower Matte Black D5/MCP655 Dress Kit EK-FC680 GTX - Acetal+EN x2 EK-FC680 GTX Backplate - Black x2 EK-FC Bridge DUAL Parallel 
CoolingCoolingCoolingCooling
EK-MOSFET Max IV Gene - Acetal+EN 2x XSPC EX240 Radiator XSPC EX120 Radiator Koolance PMP-450 12v Variable Speed Pump 
CoolingCoolingCoolingCooling
EK_Multioption RES X2 - 150 Advanced Bitspower D5/MCP655 Pump Replacement Top V2 7x GELID Silent 12 PWM Bitspower fittings 
OSMonitorKeyboardPower
Windows 7 Ultimate ASUS VG236 Logitech G19 Corsair AX850 
CaseMouse
Fractal Design Arc Mini Razer Naga MMOG 
  hide details  
Reply
Mini
(26 items)
 
  
CPUMotherboardGraphicsGraphics
i7 3770k Asus Maximus IV Gene-Z/gen3 Gigabyte GTX 680 Gigabyte GTX 680 
RAMHard DriveOptical DriveCooling
16 GB G.Skill f3-17000CL11-4GBXL Corsair Force 3 240GB SSDx2 LG Super Multi Blue EK-FC Link GeForce x2 
CoolingCoolingCoolingCooling
Bitspower Matte Black D5/MCP655 Dress Kit EK-FC680 GTX - Acetal+EN x2 EK-FC680 GTX Backplate - Black x2 EK-FC Bridge DUAL Parallel 
CoolingCoolingCoolingCooling
EK-MOSFET Max IV Gene - Acetal+EN 2x XSPC EX240 Radiator XSPC EX120 Radiator Koolance PMP-450 12v Variable Speed Pump 
CoolingCoolingCoolingCooling
EK_Multioption RES X2 - 150 Advanced Bitspower D5/MCP655 Pump Replacement Top V2 7x GELID Silent 12 PWM Bitspower fittings 
OSMonitorKeyboardPower
Windows 7 Ultimate ASUS VG236 Logitech G19 Corsair AX850 
CaseMouse
Fractal Design Arc Mini Razer Naga MMOG 
  hide details  
Reply
post #5557 of 7108
Quote:
Originally Posted by metalmayhem9 View Post

Hello! On my way to become a member of this club here. But I got stymied while trying to make the new system boot.
1. I can't get to Windows with a preloaded HDD. I set everything on stock settings in the BIOS, yet the system does not boot wth.gif. POST screen says overclock error, asks to press F1 to fix my settings in the BIOS. So I went back to BIOS.
2. Now, I am using my TV via HDMI for lack of a proper display atm. Whenever I am at BIOS to fix settings about a third of the screen is always cropped on the right and bottom side on my TV. Is there a way to fix the cropping in UEFI BIOS? I can't see/change every single setting (even after scrolling). The video card is a XFX GeForce 9600 GSO from another system.
Reading the manual and online research haven't helped yet. Nor did tinkering with various zoom mode and overscan settings in my TV.
Can you folks help me with this?
Thanks.

Your going to need to use a fresh install. I think there is some software from paragon that will remove drivers from old hardware setups to allow for new builds but Its not the right way to do it. Personally with amd and intel builds/upgrades I have never had luck booting to an existing windows 7 os without doing a clean install, i just try for the heck of it for personal info. Windows is attempting to use the chipsets off the old setup and if your like me it locks up.

BUT, just for the heck of it, make sure your memory voltage is set correctly, that the cpu isnt overheating/cpu fans are working, check power plugs to the mobo, etc. Just go over every connection you needed to touch. Other than that most likely its windows. If your not convinced try running a bootable linux (ubuntu or mint) cd to double check the hardware works if you like in case you have important data on your drive. If your using a live cd to boot from its a good way to access your windows drive to back anything up you have to do a clean install with. Basically in linux you will see your hard drive and just send to an external drive for backup.

Hope this helps
2014 nerd box evo
(18 items)
 
   
CPUMotherboardGraphicsRAM
AMD 1100T x6 4244mhz 3065cpu-nb (fx8150 at 4.9g... Asus Crosshair V Formula Asus gtx570 dcII- 890/1780/2200@1088mv corsair dominator gt 8GB 1866 @1886 
Hard DriveOptical DriveCoolingOS
corsair f120ssd/seagate 1TB Asus cd/dvd burner Antec Kuhler 920 semi-custom loop (2 radiators) win7 professional 64bit 
MonitorPowerCaseMouse
Gateway 23" 1920x1080 corsair ax850 Rosewill blackhawk w/hdd bay mod logitech mx518 
  hide details  
Reply
2014 nerd box evo
(18 items)
 
   
CPUMotherboardGraphicsRAM
AMD 1100T x6 4244mhz 3065cpu-nb (fx8150 at 4.9g... Asus Crosshair V Formula Asus gtx570 dcII- 890/1780/2200@1088mv corsair dominator gt 8GB 1866 @1886 
Hard DriveOptical DriveCoolingOS
corsair f120ssd/seagate 1TB Asus cd/dvd burner Antec Kuhler 920 semi-custom loop (2 radiators) win7 professional 64bit 
MonitorPowerCaseMouse
Gateway 23" 1920x1080 corsair ax850 Rosewill blackhawk w/hdd bay mod logitech mx518 
  hide details  
Reply
post #5558 of 7108
Hello Guys I wonder if I could just second harlen appeal for assistance. This problem with the fan heads is doing my head in. Could some of you guys please just spend ten minutes and help us both out here.


Quote:
Originally Posted by harlen View Post

Hi Again,
I'm having big trouble with ASUS in Australia. I wonder if someone can do a quick test for me.
Test:
Can you get 3pin or PWM bios fan control below 100% speed on CHA 1 or CHA 2 (the ones near southbridge and the 24 pin connector). And importantly, what BIOS revision are you on.
Easiest way to test it is this:
connect two of the same fan to CHA FAN 3 (near the cmos battery) and CHA FAN 1 (below the southbridge near the two USB connectors).
Get control data:
Go into the BIOS -> Monitor -> Fan Speed Control
Disable Q-Fan control for CPU and Chassis.
Reboot.
Go into BIOS -> Monitor -> Fan Speed Monitor
Note the speeds of Chassis Fan 1 and Chassis Fan 3. They should be the same -- about the max fan speed.
Go back one, and into Fan Speed Control
Enable CPU Q-Fan Control and Chassis Q-Fan Control
Set both to Silent
Reboot
Repeat the control data test. Note the two fan speeds. If all is working correctly, they should both be running at a slower than max speed.
My results are with Bios # 0902.


Please include which BIOS you are using.

Cheer and many thanks in advance
post #5559 of 7108

For Gene-Z, all 5 fan headers are 4-Pin PWM which means, you should be able to select the fan settings either by PWM or by Voltage. If you don't have the options in BIOS, try download and install SpeedFan.

 

To be able to use PWM control you must use 4-Pin PWM fans.

If 3-Pin fan, select voltage control instead of PWM.

 

Also note, most motherboard fan headers are rated 1A = 12W. If you overloaded it, might cause permanent damage.

 

 

 

Capture.JPG

 


Edited by Ken1649 - 2/20/12 at 2:20am
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
ケンジ
(16 items)
 
  
CPUCPUMotherboardGraphics
i7-3960X i7-980X GA-X79-UD7 / GA-X58A-UD9 7970 + 465 
GraphicsRAMRAMHard Drive
2x 6990 + 580 16GB 2133 MHz 24GB 2000 MHz 120GB x 2 RAID0 
Hard DriveHard DriveCoolingCooling
120GB x 4 RAID0 Raptor 300GB x 2 RAID0 CPU-370 CPU-370 
CoolingCoolingOSPower
VID-AR699 EK FB X58A-UD9 Win 7 Ultimate x64 1500W / 1250W+1200W 
  hide details  
Reply
post #5560 of 7108
Thanks Ken.

Actually the two CPU headers will only control PWM fans, not by voltage. Only the CHA fans will control by both, and they auto-detect.

The option is in the bios. It's also been tested with speedfan and Fan Xpert in AISuite.

The problem here is on my board that has stopped working, for CHA 1 and 2. We're trying to work out if that is the same for others with the board to see if it's possibly a bios issue. So some test results from another person would be great.
Mini
(26 items)
 
  
CPUMotherboardGraphicsGraphics
i7 3770k Asus Maximus IV Gene-Z/gen3 Gigabyte GTX 680 Gigabyte GTX 680 
RAMHard DriveOptical DriveCooling
16 GB G.Skill f3-17000CL11-4GBXL Corsair Force 3 240GB SSDx2 LG Super Multi Blue EK-FC Link GeForce x2 
CoolingCoolingCoolingCooling
Bitspower Matte Black D5/MCP655 Dress Kit EK-FC680 GTX - Acetal+EN x2 EK-FC680 GTX Backplate - Black x2 EK-FC Bridge DUAL Parallel 
CoolingCoolingCoolingCooling
EK-MOSFET Max IV Gene - Acetal+EN 2x XSPC EX240 Radiator XSPC EX120 Radiator Koolance PMP-450 12v Variable Speed Pump 
CoolingCoolingCoolingCooling
EK_Multioption RES X2 - 150 Advanced Bitspower D5/MCP655 Pump Replacement Top V2 7x GELID Silent 12 PWM Bitspower fittings 
OSMonitorKeyboardPower
Windows 7 Ultimate ASUS VG236 Logitech G19 Corsair AX850 
CaseMouse
Fractal Design Arc Mini Razer Naga MMOG 
  hide details  
Reply
Mini
(26 items)
 
  
CPUMotherboardGraphicsGraphics
i7 3770k Asus Maximus IV Gene-Z/gen3 Gigabyte GTX 680 Gigabyte GTX 680 
RAMHard DriveOptical DriveCooling
16 GB G.Skill f3-17000CL11-4GBXL Corsair Force 3 240GB SSDx2 LG Super Multi Blue EK-FC Link GeForce x2 
CoolingCoolingCoolingCooling
Bitspower Matte Black D5/MCP655 Dress Kit EK-FC680 GTX - Acetal+EN x2 EK-FC680 GTX Backplate - Black x2 EK-FC Bridge DUAL Parallel 
CoolingCoolingCoolingCooling
EK-MOSFET Max IV Gene - Acetal+EN 2x XSPC EX240 Radiator XSPC EX120 Radiator Koolance PMP-450 12v Variable Speed Pump 
CoolingCoolingCoolingCooling
EK_Multioption RES X2 - 150 Advanced Bitspower D5/MCP655 Pump Replacement Top V2 7x GELID Silent 12 PWM Bitspower fittings 
OSMonitorKeyboardPower
Windows 7 Ultimate ASUS VG236 Logitech G19 Corsair AX850 
CaseMouse
Fractal Design Arc Mini Razer Naga MMOG 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › [Officia]l ASUS ROG Maximus IV GENE-Z68 & Z68(Gen3) Owners Club