Overclock.net › Forums › Components › Power Supplies › Is my system killing power supplies?
New Posts  All Forums:Forum Nav:

Is my system killing power supplies?

post #1 of 19
Thread Starter 
I've had 3 power supplies die on me in the span of 14 months.
The first one lasted 3-4 years on a Q6600 build and then it died. Bought an ABS Power Supply which had good reviews at the time.

I built a new SB build and migrated the PSU over and it died within the first hour of it powering up. Of course it died 4 days after the warranty ended, so I bought a Corsair HX850. Things were great for 2 months, then I came back from class and the computer is off. I tried to turn it on and the computer turns on for a half a second then just shuts off. Took the PSU out of the case thinking it may be a grounding issue and plugged in a PSU tester and it starts for a half a second then all the voltages drop and it dies.

My system when the Corsair died is:
5x hd's
5 fans total
gtx 590
2600k
p8p67 pro
optical drive
8gb RAM

Is this an abnormal amount of load for this PSU?

I'm RMA'ing it to Corsair so hopefully that will turnout well. But I just want to make sure my computer isn't just killing PSU's.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
post #2 of 19
Could be the temps in your system slowing killing the unit or a bit of a bad wallsocket/power surge. Am clutching at straws here. sorry.
Edited by BradleyW - 5/3/11 at 6:49am
X79-GCN
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3930K 4.5GHz HT GIGABYTE GA-X79-UP4 AMD R9-290X GEil Evo Potenza DDR3 2400MHz CL10 (4x4GB) 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 120GB EK Supremacy (CPU) NF F12's P/P (360 Rad)  NF A14's (420 Rad)  
CoolingCoolingCoolingCooling
XSPC Chrome Compression Fittings EK RES X3 150 Primochill PremoFlex Advanced LRT Clear 1/2 ID EK-FC (R9 290X) 
CoolingCoolingCoolingOS
EK D5 Vario Top-X  Phobya G-Changer V2 360mm Phobya G-Changer V2 420mm Win 10 x64 Pro 
MonitorKeyboardPowerCase
BenQ XR3501 35" Curved Corsair Vengeance K90 Seasonic X-1250 Gold (v2) Corsair 900D 
MouseAudio
Logitech G400s Senn HD 598 
  hide details  
Reply
X79-GCN
(22 items)
 
  
CPUMotherboardGraphicsRAM
Intel 3930K 4.5GHz HT GIGABYTE GA-X79-UP4 AMD R9-290X GEil Evo Potenza DDR3 2400MHz CL10 (4x4GB) 
Hard DriveCoolingCoolingCooling
Samsung 840 Pro 120GB EK Supremacy (CPU) NF F12's P/P (360 Rad)  NF A14's (420 Rad)  
CoolingCoolingCoolingCooling
XSPC Chrome Compression Fittings EK RES X3 150 Primochill PremoFlex Advanced LRT Clear 1/2 ID EK-FC (R9 290X) 
CoolingCoolingCoolingOS
EK D5 Vario Top-X  Phobya G-Changer V2 360mm Phobya G-Changer V2 420mm Win 10 x64 Pro 
MonitorKeyboardPowerCase
BenQ XR3501 35" Curved Corsair Vengeance K90 Seasonic X-1250 Gold (v2) Corsair 900D 
MouseAudio
Logitech G400s Senn HD 598 
  hide details  
Reply
post #3 of 19
The wattage is more than enough for the system, I think you are just unlucky, or your home electrics are bad. Constant surges with no relays or protective sockets can do that to your PSU. I think the latter is the case.
Current System
(18 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-8350 @ 4GHz Gigabyte 990XA-UD3 AMD Radeon R9 380X Kingston 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 Pro EVO Seagate 500GB LG DVD Burner 3x Coolermaster 80mm + 2 Thermaltake 200mm 
OSMonitorMonitorKeyboard
Windows 10 x64 LG TV LG Flatron W2361V Logitech K200 
PowerCaseMouseMouse Pad
Enermax Galaxy 850W Thermaltake Element S Logitech G502 Proteus Spectrum RGB Steelseries QcK 
AudioAudio
Realtec HDA Lexicon Omega 
  hide details  
Reply
Current System
(18 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-8350 @ 4GHz Gigabyte 990XA-UD3 AMD Radeon R9 380X Kingston 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 Pro EVO Seagate 500GB LG DVD Burner 3x Coolermaster 80mm + 2 Thermaltake 200mm 
OSMonitorMonitorKeyboard
Windows 10 x64 LG TV LG Flatron W2361V Logitech K200 
PowerCaseMouseMouse Pad
Enermax Galaxy 850W Thermaltake Element S Logitech G502 Proteus Spectrum RGB Steelseries QcK 
AudioAudio
Realtec HDA Lexicon Omega 
  hide details  
Reply
post #4 of 19
You should be able to handle the 590 with a HX850. I would agree that there is a potential grounding issue somewhere. Have you checked to make sure your backplate isn't touching the mobo at all?

What kind of UPS do you have? There could be fluctuations from the wall.

It could also be a case of bad luck, too. frown.gif
Intellect v2
(9 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-6700K Processor ASUS ROG MAXIMUS VIII HERO LGA1151 DDR4 M.2 SAT... EVGA GTX 1080 SC ACX 3.0 Crucial Ballistix Sport 32GB DDR4 2400 MT/s (PC... 
CoolingKeyboardPowerCase
Noctua NH-D15 Das Keyboard 4 Professional (Brown) Corsair AX860 Fractal Design Define R5 
Mouse
MIONIX NAOS 7000 
  hide details  
Reply
Intellect v2
(9 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-6700K Processor ASUS ROG MAXIMUS VIII HERO LGA1151 DDR4 M.2 SAT... EVGA GTX 1080 SC ACX 3.0 Crucial Ballistix Sport 32GB DDR4 2400 MT/s (PC... 
CoolingKeyboardPowerCase
Noctua NH-D15 Das Keyboard 4 Professional (Brown) Corsair AX860 Fractal Design Define R5 
Mouse
MIONIX NAOS 7000 
  hide details  
Reply
post #5 of 19
Thread Starter 
It's connected to a UPS to eliminate issues like that. And I currently live in a college apartment on campus, and if the power is as good as the internet is then I feel like it shouldn't be an issue.

It just seems like it's pushing unlucky. My room is constantly in the mid 60's so I feel like the ambient temperature is good and I do have pretty good airflow. The temps for the cpu idle'd at 32 so I dunno.

Thanks for the thoughts so far.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
post #6 of 19
Thread Starter 
Quote:
Originally Posted by Plex;13364366 
You should be able to handle the 590 with a HX850. I would agree that there is a potential grounding issue somewhere. Have you checked to make sure your backplate isn't touching the mobo at all?

What kind of UPS do you have? There could be fluctuations from the wall.

It could also be a case of bad luck, too. frown.gif

Completely took the PSU out of the case and just plugged a PSU tester into the 24 pin to get it to turn on. This was done on an anti-static mat at work so there weren't any other components involved. So it is definitely an issue with the PSU.

Could it be the motherboard is putting excessive strain on the PSU for some reason, thus killing it over time? I don't know enough about this stuff so I risk sounding stupid.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
post #7 of 19
I never heard of components killing the PSU, that would be possible only if you had more than the PSU can handle. But I didn't understand something.

Rephrase to me, how many times have you had hardware get destroyed, and how many of those had the specific PSU on your PC?
Current System
(18 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-8350 @ 4GHz Gigabyte 990XA-UD3 AMD Radeon R9 380X Kingston 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 Pro EVO Seagate 500GB LG DVD Burner 3x Coolermaster 80mm + 2 Thermaltake 200mm 
OSMonitorMonitorKeyboard
Windows 10 x64 LG TV LG Flatron W2361V Logitech K200 
PowerCaseMouseMouse Pad
Enermax Galaxy 850W Thermaltake Element S Logitech G502 Proteus Spectrum RGB Steelseries QcK 
AudioAudio
Realtec HDA Lexicon Omega 
  hide details  
Reply
Current System
(18 items)
 
  
CPUMotherboardGraphicsRAM
AMD FX-8350 @ 4GHz Gigabyte 990XA-UD3 AMD Radeon R9 380X Kingston 
Hard DriveHard DriveOptical DriveCooling
Samsung 840 Pro EVO Seagate 500GB LG DVD Burner 3x Coolermaster 80mm + 2 Thermaltake 200mm 
OSMonitorMonitorKeyboard
Windows 10 x64 LG TV LG Flatron W2361V Logitech K200 
PowerCaseMouseMouse Pad
Enermax Galaxy 850W Thermaltake Element S Logitech G502 Proteus Spectrum RGB Steelseries QcK 
AudioAudio
Realtec HDA Lexicon Omega 
  hide details  
Reply
post #8 of 19
Thread Starter 
Quote:
Originally Posted by AngeloG.;13364415 
I never heard of components killing the PSU, that would be possible only if you had more than the PSU can handle. But I didn't understand something.

Rephrase to me, how many times have you had hardware get destroyed, and how many of those had the specific PSU on your PC?

Not sure I completely understand. Thus far I've had two power supplies die on my sandy bridge build.

The first PSU was going fine for a year and all of a sudden died when I plugged it into the sandy bridge build. At this point in time it was just using an 8800gt, not the 590, since it hadn't come in yet. So that seemed odd that after 1 year, I plug it into a new build and it dies.

But the corsair lasted 2 months on that build, but died.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
post #9 of 19
What are the voltages for your RAM? Had the same problem with my first P8P67. RAM voltages killed Mobo. Got another one and changed out the standoffs to larger ones (To make sure there was no grounding issues with my heatsink). My system has been running fine since.

1) Check RAM voltages
2) Check for any possible grounding issues.
Edited by importflip - 5/3/11 at 6:59am
Silent Killer
(20 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K MAXIMUS VII HERO NVIDIA GeForce GTX 1080 Ti Samsung  
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 Samsung 840 HGST Deskstar 4TB Western Digital Blue 6TB 
CoolingOSMonitorMonitor
Corsair H115i Windows 10 Pro (x64) Acer XB270HU Crossover 27Q-LED 
KeyboardPowerCaseMouse
Logitech G910 Corsair RM1000 Phanteks Enthoo Evolv TG - Satin Black Logitech G900 
AudioAudioAudioAudio
Asus Xonar Essence STX - LME49860NA x3 M-Audio BX5 Carbon Black JBL LSR310S V-Moda Crossfade M100 
  hide details  
Reply
Silent Killer
(20 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 4770K MAXIMUS VII HERO NVIDIA GeForce GTX 1080 Ti Samsung  
Hard DriveHard DriveHard DriveHard Drive
Samsung 850 Samsung 840 HGST Deskstar 4TB Western Digital Blue 6TB 
CoolingOSMonitorMonitor
Corsair H115i Windows 10 Pro (x64) Acer XB270HU Crossover 27Q-LED 
KeyboardPowerCaseMouse
Logitech G910 Corsair RM1000 Phanteks Enthoo Evolv TG - Satin Black Logitech G900 
AudioAudioAudioAudio
Asus Xonar Essence STX - LME49860NA x3 M-Audio BX5 Carbon Black JBL LSR310S V-Moda Crossfade M100 
  hide details  
Reply
post #10 of 19
Thread Starter 
This memory here:
http://www.newegg.com/Product/Product.aspx?Item=N82E16820231445

1.5V.

The computer was left at stocks.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 4.5 ASUS P8P67 Pro 980TI Classified 16GB x G.Skill 
Hard DriveOSMonitorKeyboard
8TB worth Windows 7 x64 Dell 3007WFP + BenQ 24" + Acer 22" Logitech G510 
PowerCaseMouse
Corsair 850W Antec 900 MX518 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Is my system killing power supplies?