Overclock.net › Forums › Components › Mice › Razer problems
New Posts  All Forums:Forum Nav:

Razer problems - Page 2

post #11 of 14
Ive had my deathadder for almost a year now and im having no problems at all.
My System
(13 items)
 
  
Graphics
GTX 560 Ti 
  hide details  
Reply
My System
(13 items)
 
  
Graphics
GTX 560 Ti 
  hide details  
Reply
post #12 of 14
Thread Starter 
Quote:
Originally Posted by blackbalt89 View Post
I agree. Love the QcK standard.

If this is the sort of quality I can expect from my Deathadder 3.5G then I'm going to be super pissed.
Don't get me wrong, the DeathAdder is awesome, now real problems, apart from that random "not working after boot/usb replug" thing.
Also, my mouse button would break after a year or so, the left mouse button got stuck and I was unable to unstuck it. (It did click etc. but it broke somehow, windows registered it as being clicked all the time).

Apart from that the DeathAdder is probably one of the best mice out there!
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 965BE Asus M4A89GTD Pro/USB3 HD 5870 4GB 1600 CL8 
OSMonitorKeyboardPower
Windows 7 x64 24" 1920x1080 Logitech G11 Antec TPQ-850W 
CaseMouseMouse Pad
Antec 1200 Razer Imperator Steelseries QcK 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 965BE Asus M4A89GTD Pro/USB3 HD 5870 4GB 1600 CL8 
OSMonitorKeyboardPower
Windows 7 x64 24" 1920x1080 Logitech G11 Antec TPQ-850W 
CaseMouseMouse Pad
Antec 1200 Razer Imperator Steelseries QcK 
  hide details  
Reply
post #13 of 14
Quote:
Originally Posted by naikee View Post
Don't get me wrong, the DeathAdder is awesome, now real problems, apart from that random "not working after boot/usb replug" thing.
I had a similar problem with the Lachesis occasionally disconnecting itself, incidentally. I emailed Razer's support and eventually they sent me a link to download an earlier driver that seems to fix the problem, so they might be worth a try.
post #14 of 14
Thread Starter 
I sent Razer a support ticket, explaining my problem and what I had already tried to fix it.
They sent me a copy&paste message telling me to do exactly what I just said I had already tried...
I'm checking if the Imperator has warranty, if it does I think I'm going to try to switch it to a DeathAdder.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 965BE Asus M4A89GTD Pro/USB3 HD 5870 4GB 1600 CL8 
OSMonitorKeyboardPower
Windows 7 x64 24" 1920x1080 Logitech G11 Antec TPQ-850W 
CaseMouseMouse Pad
Antec 1200 Razer Imperator Steelseries QcK 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x4 965BE Asus M4A89GTD Pro/USB3 HD 5870 4GB 1600 CL8 
OSMonitorKeyboardPower
Windows 7 x64 24" 1920x1080 Logitech G11 Antec TPQ-850W 
CaseMouseMouse Pad
Antec 1200 Razer Imperator Steelseries QcK 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Mice
Overclock.net › Forums › Components › Mice › Razer problems