Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Laptop won't turn on! :( [Solved]
New Posts  All Forums:Forum Nav:

Laptop won't turn on! :( [Solved] - Page 2

post #11 of 12
Thread Starter 
I fixed it! So, when I unscrewed the backing the first time, I accidentally took out an extra screw. It got thrown into the cup with all the other ones. When I reassembled, I grabbed a longer screw to screw back in. Apparently there is no backing behind the screw hole, so when I screwed it in, it made contact with the motherboard near the battery supply area. That was my issue. I simply replaced the screw with the shorter one, and everything works now!

I feel really dumb redface.gif but i'm hella happy:D

Moral of the story, keep track of your screws.
Dell XPS 720
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core2 Q6600 2.4Ghz Nvidia nForce 680i SLI SPP 768MB GeForce 8800 GTX Wintec 8GB DDR2 800MHz 
Hard DriveOptical DriveOSMonitor
2 320GB 7200 RPM 16X DVD+R/RW CD-RW 64-Bit Windows 7 Professional SyncMaster 931BW/906BW/931CW 
KeyboardPowerCaseMouse
Dell USB Keyboard 750w Stock Dell Optical USB Mouse 
  hide details  
Reply
Dell XPS 720
(13 items)
 
  
CPUMotherboardGraphicsRAM
Core2 Q6600 2.4Ghz Nvidia nForce 680i SLI SPP 768MB GeForce 8800 GTX Wintec 8GB DDR2 800MHz 
Hard DriveOptical DriveOSMonitor
2 320GB 7200 RPM 16X DVD+R/RW CD-RW 64-Bit Windows 7 Professional SyncMaster 931BW/906BW/931CW 
KeyboardPowerCaseMouse
Dell USB Keyboard 750w Stock Dell Optical USB Mouse 
  hide details  
Reply
post #12 of 12
You got lucky for not frying your motherboard.
SS
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8435 3.06GHz G60VX GTX 260M HE 2 x 2GB 
Hard DriveOSMouse
MC 64GB SSD G2 & SG 320 W7 Pro x64 Razer Naga 
  hide details  
Reply
SS
(13 items)
 
  
CPUMotherboardGraphicsRAM
E8435 3.06GHz G60VX GTX 260M HE 2 x 2GB 
Hard DriveOSMouse
MC 64GB SSD G2 & SG 320 W7 Pro x64 Razer Naga 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Laptops and Netbooks
Overclock.net › Forums › Mobile Computing Forum › Laptops and Netbooks › Laptop won't turn on! :( [Solved]