Overclock.net › Forums › Components › Power Supplies › PSU won't power on when connected
New Posts  All Forums:Forum Nav:

PSU won't power on when connected

post #1 of 28
Thread Starter 
HELP!!! I sleeved my Corsair HX650 and after putting my case back together my computer won't turn on.It passes the paper clip test but with the 24 pin and 8 pin cables connected to the mobo it won't power on. What can I do?

Sent from my HUAWEI-M860 using Tapatalk
post #2 of 28
take everything out and see if it works outside the case.
post #3 of 28
Thread Starter 
I've taken out the PSU. . . Do you mean I should take the mobo out, too?

Sent from my HUAWEI-M860 using Tapatalk
post #4 of 28
i want to see pic's of the sleeving. theses are flat cables, how did you go about sleeving them?
always changing
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k msi z97i-ack MSI r9 290 2x8 corsair 1600 
Hard DriveHard DriveCoolingOS
m4 128  wd 1tb black noctua u9s win7 64 
MonitorKeyboardPowerCase
benq 2420z corsair  coolermaster v650 rosewell neutron 
MouseMouse PadAudio
rival 300 razer  corsair sp2500 
  hide details  
Reply
always changing
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 4690k msi z97i-ack MSI r9 290 2x8 corsair 1600 
Hard DriveHard DriveCoolingOS
m4 128  wd 1tb black noctua u9s win7 64 
MonitorKeyboardPowerCase
benq 2420z corsair  coolermaster v650 rosewell neutron 
MouseMouse PadAudio
rival 300 razer  corsair sp2500 
  hide details  
Reply
post #5 of 28
yes everything out of the case. Try it on the mobo box.
post #6 of 28
It would be easier if you Supply us with Pictures.
post #7 of 28
I had a similar issue with my SeaSonic X650 after I sleeved the 8-pin connector. Try pushing in on the cables where they connect to the power supply. The pins may not be seating properly. Make sure the cables coming out of the connector are not bent over too much. Straighten them out if you can (so the wires are pointing straight into the PSU and not bent over).
post #8 of 28
Quote:
Originally Posted by Philistine View Post
I had a similar issue with my SeaSonic X650 after I sleeved the 8-pin connector. Try pushing in on the cables where they connect to the power supply. The pins may not be seating properly. Make sure the cables coming out of the connector are not bent over too much. Straighten them out if you can (so the wires are pointing straight into the PSU and not bent over).
Phil I have to ask... Do you play WoW? I have a Philistine in my guild...
Gemini
(26 items)
 
 
Computer/Office
(4 photos)
CPUMotherboardGraphicsRAM
Intel Core i5-2500K ASUS P8Z68 Deluxe PNY Nvidia GeForce GTX 680  CORSAIR XMS3 1333Mhz 16GB 
Hard DriveHard DriveHard DriveHard Drive
2 x Samsung Spinpoint F3R - RAID 1 (1 TB) Western Digital Green EARS (1 TB) Western Digital Green EARS (1.5 TB)  Western Digital My Passport Elite USB 2.0 (640GB) 
Hard DriveOptical DriveOptical DriveCooling
Western Digital My Book Essential USB 3.0 (2 TB) LG GBC-H20L Blu-ray Asus DRW-1814BLT CORSAIR H80 Push/Pull 
CoolingOSMonitorMonitor
Dual 200mm Fans / Dual 120mm Fans Windows 7 Ultimate x64 SP1 Dell UltraSharp U2412M (24") - Primary Dell UltraSharp U2412M (24") - Secondary 
KeyboardPowerCaseMouse
Logitech G510 CORSAIR Enthusiast Series TX750 V2 CORSAIR 650D Logitech G500 
Mouse PadAudioAudioAudio
XTRAC Ripper  Creative X-Fi Platinum Fatality Champion Series Sennheiser HD 595 Headphones  Logitech Z-2300 THX Cert 2.1 System 
OtherOther
Logitech HD Pro Webcam C910 Cyber Power CP1500AVRT 900Watt UPS 
CPUMotherboardGraphicsRAM
Intel Core i7-3610QM 2.3GHz Intel HM77 NVIDIA Geforce GTX 675M & Intel HD 4000 16GB G.Skill DDR3 1600 
Hard DriveOptical DriveOSMonitor
2x HGST 1TB 7200 RPM HD's RAID 0 MATSHITA BD-RE 6X Windows 8 Pro 64 Bit with Media Center 17.3" 1920x1080 Matte  
KeyboardPowerCaseMouse
Steelseries  180 Watt A/C and 9 Cell Battery Allant Black Carrying Case for 17.3" Notebook M... Razer Orochi 2013 
Mouse PadAudioAudioOther
Razer - Kabuto DynAudio speakers and sub with Realtek HD ALC ... Asus Xonar U3 USB DAP/Sound Card w/ Sony XBA-4 ... Intel Centrino Advanced-N 6235 
  hide details  
Reply
Gemini
(26 items)
 
 
Computer/Office
(4 photos)
CPUMotherboardGraphicsRAM
Intel Core i5-2500K ASUS P8Z68 Deluxe PNY Nvidia GeForce GTX 680  CORSAIR XMS3 1333Mhz 16GB 
Hard DriveHard DriveHard DriveHard Drive
2 x Samsung Spinpoint F3R - RAID 1 (1 TB) Western Digital Green EARS (1 TB) Western Digital Green EARS (1.5 TB)  Western Digital My Passport Elite USB 2.0 (640GB) 
Hard DriveOptical DriveOptical DriveCooling
Western Digital My Book Essential USB 3.0 (2 TB) LG GBC-H20L Blu-ray Asus DRW-1814BLT CORSAIR H80 Push/Pull 
CoolingOSMonitorMonitor
Dual 200mm Fans / Dual 120mm Fans Windows 7 Ultimate x64 SP1 Dell UltraSharp U2412M (24") - Primary Dell UltraSharp U2412M (24") - Secondary 
KeyboardPowerCaseMouse
Logitech G510 CORSAIR Enthusiast Series TX750 V2 CORSAIR 650D Logitech G500 
Mouse PadAudioAudioAudio
XTRAC Ripper  Creative X-Fi Platinum Fatality Champion Series Sennheiser HD 595 Headphones  Logitech Z-2300 THX Cert 2.1 System 
OtherOther
Logitech HD Pro Webcam C910 Cyber Power CP1500AVRT 900Watt UPS 
CPUMotherboardGraphicsRAM
Intel Core i7-3610QM 2.3GHz Intel HM77 NVIDIA Geforce GTX 675M & Intel HD 4000 16GB G.Skill DDR3 1600 
Hard DriveOptical DriveOSMonitor
2x HGST 1TB 7200 RPM HD's RAID 0 MATSHITA BD-RE 6X Windows 8 Pro 64 Bit with Media Center 17.3" 1920x1080 Matte  
KeyboardPowerCaseMouse
Steelseries  180 Watt A/C and 9 Cell Battery Allant Black Carrying Case for 17.3" Notebook M... Razer Orochi 2013 
Mouse PadAudioAudioOther
Razer - Kabuto DynAudio speakers and sub with Realtek HD ALC ... Asus Xonar U3 USB DAP/Sound Card w/ Sony XBA-4 ... Intel Centrino Advanced-N 6235 
  hide details  
Reply
post #9 of 28
some of your pins probably not all the way in or you've pulled out a cable (poor connection) with pin head/connector. if it worked fine before and all you've done is sleeve it it should work fine again lol.
Verde [WIP]
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.5gHz w/ HT ASUS P8P67 Pro Gigabyte 460GTX OC 8gB Kingston HyperX 
Hard DriveOSMonitorKeyboard
Samsung F3 1tB [RAID1] + WD Green 2tB [RAID5] Windows 7 [x64] Acer 24" [1920x1200] MX 5500 
PowerCaseMouse
Corsair HX850W CM 690 II Adv [Modded] Logitech MX Revolution 
  hide details  
Reply
Verde [WIP]
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 2600k @ 4.5gHz w/ HT ASUS P8P67 Pro Gigabyte 460GTX OC 8gB Kingston HyperX 
Hard DriveOSMonitorKeyboard
Samsung F3 1tB [RAID1] + WD Green 2tB [RAID5] Windows 7 [x64] Acer 24" [1920x1200] MX 5500 
PowerCaseMouse
Corsair HX850W CM 690 II Adv [Modded] Logitech MX Revolution 
  hide details  
Reply
post #10 of 28
Thread Starter 
It's hard to supply pictures without a PC. Possibly some of the ends of the pins on the 24 pin connector are mis shapen, so I'm going to try cutting those off and soldering on new pins/wires. In my testing it did boot once but the PCIE wasn't plugged in to the GPU so I had to reboot but I couldn't get it to boot again.

Sent from my HUAWEI-M860 using Tapatalk
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › PSU won't power on when connected