Overclock.net › Forums › Intel › Intel Motherboards › Asus P8P67 Deluxe wont turn on
New Posts  All Forums:Forum Nav:

Asus P8P67 Deluxe wont turn on

post #1 of 15
Thread Starter 
Hi guys

Today i received my new components which are:

Asus P8P67 Deluxe rev 3.0
i7 2600k
Corsair 16GB 1600
Corsair 750 PSU v2

After putting all together the computer just wont turn on. The power and reset leds are on on mobo but after pressing the power button all fans just run for like a second or so and then everything goes off and cant get any further. Its always the same no matter what I do.

I have tried another PSU which worked so far on my old computer and no success. I have also tried moving RAMs in different slots, doing mem ok, removing battery, cleared cmos and every time same thing happens.

Its stressing me out since I dont know what to do anymore, i get the new components and I event cant get the computer to turn on.

Any suggestions or shall i just return the mobo?
post #2 of 15
Stand offs for mobo?
8 pin connected?
Heat sink fan connected to CPU fan header?

double check the front panel cables to mobo. Are they oriented correctly?
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
post #3 of 15
Thread Starter 
All cables are connected ok, 8pin.. mine PSU uses 2x4.
post #4 of 15
Quote:
Originally Posted by horsovski;13434786 
All cables are connected ok, 8pin.. mine PSU uses 2x4.

fine but did you double check the on/off reset and HD to be sure the polarity is correct?
You did use standoffs in the case before mounting Mobo?

sounds like something is going to ground
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
post #5 of 15
are all the sata cables completely in the sockets? My problem was that with the asus ez ram thingy the ram would not be completely installed and would mess up the post. Make sure the ram is installed fully
Noob tube
(14 items)
 
  
CPUMotherboardGraphicsRAM
2500k p67 Revolution GTX 670 Ripjaws 4gb @ 1600hz x 4 
Hard DriveMonitorPowerCase
M4 64gb / Chronos 256 gb Dell U24 Corsair hx1000 TJ07 
Audio
Auzentech Forte 
  hide details  
Reply
Noob tube
(14 items)
 
  
CPUMotherboardGraphicsRAM
2500k p67 Revolution GTX 670 Ripjaws 4gb @ 1600hz x 4 
Hard DriveMonitorPowerCase
M4 64gb / Chronos 256 gb Dell U24 Corsair hx1000 TJ07 
Audio
Auzentech Forte 
  hide details  
Reply
post #6 of 15
What LED's are on and what color are they? I have the PRO and the LED's tell you what it is or not doing .
Build #5
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K ASUS P8P67 Pro B3 ASUS ENGTS450 SLI Vengeance 16GB PC12800 DDR3 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 1.5TB SATA 7200/64MB/6G LG Super Multi Blu-Ray/HD DVD-Rom Drive Win 7 Home Prem 64bit Sony KDL-26L5000 720p LCD Tv 
KeyboardPowerCaseMouse
Logitech 200 Ultra X4 850-Watt Modular Power Supply Azza 1000 Logitech MX1100 
  hide details  
Reply
Build #5
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7-2600K ASUS P8P67 Pro B3 ASUS ENGTS450 SLI Vengeance 16GB PC12800 DDR3 
Hard DriveOptical DriveOSMonitor
WD Caviar Black 1.5TB SATA 7200/64MB/6G LG Super Multi Blu-Ray/HD DVD-Rom Drive Win 7 Home Prem 64bit Sony KDL-26L5000 720p LCD Tv 
KeyboardPowerCaseMouse
Logitech 200 Ultra X4 850-Watt Modular Power Supply Azza 1000 Logitech MX1100 
  hide details  
Reply
post #7 of 15
Thread Starter 
Power button is green and reset is red.

The front buttons are connected correctly, tried without them aswell and same thing. All the cables and RAMs are in place.

I didnt use standoffs, never used theme before aswell.
post #8 of 15
Quote:
Originally Posted by horsovski;13435005 
Power button is green and reset is red.

The front buttons are connected correctly, tried without them aswell and same thing. All the cables and RAMs are in place.

I didnt use standoffs, never used theme before aswell.

^^^^^^ Stand offs are the little brass screw type apparatus that keep the MOBO off the Mobo tray and also make alignment for the IO plate possible.

Without them in the proper orientation the mobo will ground to the case and not work
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
post #9 of 15
Thread Starter 
Sry my mistake, stand offs are installed properly in case, I thought you were talking about something else. So stand offs are not the issue here.
post #10 of 15
Quote:
Originally Posted by horsovski;13435151 
Sry my mistake, stand offs are installed properly in case, I thought you were talking about something else. So stand offs are not the issue here.


The only other thing I would try is to take it out of the case and put it on the mobo box and see if it boots. Other than that I'm out of ideas
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
GIGABYTE GOODNESS
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500K @ 4.3GHz Asus P8Z68-V Pro EVGA GTX 550 Ti G.Skill 12Gb DDR3 1600 
Hard DriveOptical DriveCoolingOS
Crucial 64 plus 6 TB HD Lite On Dark Knight 7 Pro 64 bit 
MonitorKeyboardPowerCase
Samsung2433BW Logitech Antec TP 650 Corsair 600T SE 
Mouse
Logitech 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › Asus P8P67 Deluxe wont turn on