Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › ATI driver problem with mint 10 64bit
New Posts  All Forums:Forum Nav:

ATI driver problem with mint 10 64bit

post #1 of 14
Thread Starter 
Whenever I try to install it, I get an error shortly afterwards.

Quote:
Failed to fetch http://security.ubuntu.com/ubuntu/po...ntu8_amd64.deb 404 Not Found
So what do I need to do to install it? Is there a fancy command I can type into the terminal that will magically solve my problems?

I tried downloading the driver directly from AMD, and it says that it is an automated installer. The file is a .run file. So from the terminal I tell it to run, at least I thought I told it to run, but it opens the file up in gedit and gives me an error saying it couldn't open it.

I also typed
Quote:
sudo sh ati-driver-installer-10-9-x86_64.run
in the terminal as google suggested and it told me that sh can't open the driver.
Edited by Simple_echo - 5/10/11 at 3:10am
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
post #2 of 14
Here's the wiki I always used when I was dealing with Ubuntu:

http://wiki.cchtml.com/index.php/Ubuntu

Essentially, the .run package is coded to work with a redhat distro IIRC, and ubuntu works a little differently, and that wiki should guide you in unpacking the .run package and repackaging it into a .deb file.
post #3 of 14
Thread Starter 
Quote:
Originally Posted by Bluescreen_Of_Death View Post
Here's the wiki I always used when I was dealing with Ubuntu:

http://wiki.cchtml.com/index.php/Ubuntu

Essentially, the .run package is coded to work with a redhat distro IIRC, and ubuntu works a little differently, and that wiki should guide you in unpacking the .run package and repackaging it into a .deb file.
+rep This looks like it will solve my problems, and thank you for explaining what was going on.
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
post #4 of 14
Quote:
Originally Posted by Simple_echo View Post
+rep This looks like it will solve my problems, and thank you for explaining what was going on.
It's NP. If you still need some help, I'll be here =]
post #5 of 14
Thread Starter 
Alright, so I got it working, and than I broke it. I was trying to get my dual monitor set up working. I opened CCC, and told it not to mirror the desktop, and than restarted it like I was supposed to. Well after a restart, one monitor is pixilated and unreadable. The shapes that you can see seem to be mirroring the working monitor, and the cursor can't be moved to the none working monitor. The taskbar can't be seen on the working monitor either. So I can't get to CCC to undo whatever it is I just caused. Is there a way to at least get to the terminal from here, and what would I do in the terminal to get rid of this problem?
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
post #6 of 14
Quote:
Originally Posted by Simple_echo View Post
Alright, so I got it working, and than I broke it. I was trying to get my dual monitor set up working. I opened CCC, and told it not to mirror the desktop, and than restarted it like I was supposed to. Well after a restart, one monitor is pixilated and unreadable. The shapes that you can see seem to be mirroring the working monitor, and the cursor can't be moved to the none working monitor. The taskbar can't be seen on the working monitor either. So I can't get to CCC to undo whatever it is I just caused. Is there a way to at least get to the terminal from here, and what would I do in the terminal to get rid of this problem?
There is a way, indeed. When you're booting up and GRUB pops up to let you choose your OS, select ubuntu, but don't boot it. Press [E] to edit the boot options.

In this menu, go to the kernel line and press [E] again to edit the boot parameters. Change [or add to the end of the kernel] ro to 3, so it should look like this:

Code:
*kernel info* ro=3
That will change your runlevel to three, allowing you to start up the machine, but without the X server.

Then, login as your normal self, and edit your xorg.conf file to use the Vesa driver like so:

Code:
sudo nano /etc/X11/xorg.conf
Within that file will be a section for your video card. It will have a section that says:

Code:
driver = fglrx
Change that to say
Code:
driver = vesa
It's safe to change fglrx to vesa anywhere it appears in the file. Then save with [Ctrl][X]. Nano will ask you if you want to overwrite changes, press [Y] to say yes, and press [Enter] to keep the same filename.

Unless I'm mistaken, it's better to use the xorg.conf file to set up a miltimonitor setup.

I'm googling right now, looking for a decent guide.
post #7 of 14
I think this will be your best option for getting a proper multi-monitor setup going. I have no experience with it [as I only have one monitor], so maybe someone else can come along and help if this doesn't work.

https://help.ubuntu.com/community/XineramaHowTo
post #8 of 14
Quote:
Originally Posted by Bluescreen_Of_Death View Post
Here's the wiki I always used when I was dealing with Ubuntu:

http://wiki.cchtml.com/index.php/Ubuntu

Essentially, the .run package is coded to work with a redhat distro IIRC, and ubuntu works a little differently, and that wiki should guide you in unpacking the .run package and repackaging it into a .deb file.
huh?

the .run works fine on my debian system
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
post #9 of 14
Yeah .run works on any system. If it doesn't you don't have dependencies set up correctly.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #10 of 14
Thread Starter 
So, how would you go about setting up these dependencies? I've been playing with Linux distros the past few days, and Linux Mint seems to be the only one doing this when I first install it. Which is confusing me because from my understanding, Mint is supposed to be another newb friendly Ubuntu distro.
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2300 Gigabyte GA-H61N-USB3 Sapphire Vapor-X 5770 8GB DDR3 
Hard DriveHard DriveCoolingOS
Samsung Spinpoint F3  Intel X25-M Corsair H50 Windows 7 Pro 64bit  
MonitorMonitorMonitorKeyboard
Samsung PX2370 HP 2311x Acer A231H Microsoft Arc 
PowerCaseMouse
OCZ ModXStream Pro 500W Cosmos 1000 Microsoft Arc Touch Mouse 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › ATI driver problem with mint 10 64bit