Overclock.net › Forums › Intel › Intel Motherboards › >>The Official ASUS P8P67/P8Z68 & P8Z68/GEN3 Series Owners Club>>
New Posts  All Forums:Forum Nav:

>>The Official ASUS P8P67/P8Z68 & P8Z68/GEN3 Series Owners Club>> - Page 424

post #4231 of 9343
Quote:
Originally Posted by hmar View Post
I got this after 20 seconds,
Ok, so your VID is 1.3761V. This is useful information that allows us to know what Offset to use in order to obtain the core voltage you want - especially when using an LLC of Ultra High.

So let's say that you want to try using 1.344V under full load with this overclock (which isn't a bad starting point for 4.5 GHz as you might even be able to use a lower core voltage than 1.344V). The difference between 1.3761 and 1.344 is 0.0321V, so that means you'd need to try an Offset of either -0.03V or -0.035V (round it both down and up due to the 0.005V increments). So the Offset sign you need is the Minus sign instead of the Plus sign, so make sure you change it. If you use the Plus sign, then the voltage would become about 1.408V to 1.416V under load.

Go for it!
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #4232 of 9343
Simple term = The VID you see on a certain speed + Offset, equal to the Vcore you get. But the load Vcore will of course depend on the LLC you choose.

Example: If you had a VID of 1.3611 at 4.5GHz and typed in + 0.020 Offset, you would get about 1.3811v Vcore under load... If LLC was at Ultra High. This will also differ according to different load.
    
CPUMotherboardGraphicsRAM
Core i7 2600K@4.5GHz Asus P8P67 Pro 3.0 (B3) EVGA GTX 1070 SC Black Edition 4x4GB Corsair Vengeance 1600-9-9-9-24-2t-1.5v 
Hard DriveOptical DriveOSMonitor
M500 240GB SSD for OS, 2x256GB M4's Raid0 for ... Generic Windows 10 Pro 64 Bit Asus VK266H 
PowerCase
Corsair RM 750x Cooler Master Storm Scout 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Core i7 2600K@4.5GHz Asus P8P67 Pro 3.0 (B3) EVGA GTX 1070 SC Black Edition 4x4GB Corsair Vengeance 1600-9-9-9-24-2t-1.5v 
Hard DriveOptical DriveOSMonitor
M500 240GB SSD for OS, 2x256GB M4's Raid0 for ... Generic Windows 10 Pro 64 Bit Asus VK266H 
PowerCase
Corsair RM 750x Cooler Master Storm Scout 
  hide details  
Reply
post #4233 of 9343
I am glad we are on the topic. I think my current issue is voltage drop. I got 3.6 damn near booted last night but what I noticed under 4.5 load testing is the voltage is dropping way below where I want it.

At the moment the VID is 1.3661 and its manually set at 1.36 (this is just for 4.4 atm im folding right now). Load voltage is 1.336 to 1.344. Not bad and i cant remember wether I have the LLC to high or ultra high atm.

The thing was prime95 last night the voltage was dropping alot further. VRM frequency was at 350 to 370.

Dropping the PLL voltage has definitly been a success so far in the higher attempts.
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
post #4234 of 9343
Quote:
Originally Posted by RainMotorsports View Post
I am glad we are on the topic. I think my current issue is voltage drop. I got 3.6 damn near booted last night but what I noticed under 4.5 load testing is the voltage is dropping way below where I want it.

At the moment the VID is 1.3661 and its manually set at 1.36 (this is just for 4.4 atm im folding right now). Load voltage is 1.336 to 1.344. Not bad and i cant remember wether I have the LLC to high or ultra high atm.

The thing was prime95 last night the voltage was dropping alot further. VRM frequency was at 350 to 370.

Dropping the PLL voltage has definitly been a success so far in the higher attempts.
What was your voltage during Prime95?
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #4235 of 9343
Quote:
Originally Posted by TwoCables View Post
What was your voltage during Prime95?
If I knew I would say. It was at like 2 this morning and im waiting on a long as F2H wu to complete at the moment.

I want to say it dropped around 1.32 from a manual setting of 1.39. With the PLL voltage drop it had been my most successful 4.5 so far. That is until 4.6 and a crash and then a bunch of funny colored screens later. Once again cant remember if the LLC was High or Ultra been running High most of the time.
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
post #4236 of 9343
Quote:
Originally Posted by Break View Post
Hi folks, just got a p8z68 v-pro with my new pc.

I've got a problem with incorrect RAM frequency, wondering if anyone else has had a similar issue...

My ram is 1600mhz but with 'optimised defaults' in bios, it sets to 1333mhz. If I go into the bios and set it and 1600mhz manually (or even use the xmp setting) it changes to 1600 no problem and cpu-z confirms this but it has the bizzare effect of locking my cpu frequency to a constant 3.7Ghz.

Not sure if this is normal behaviour
Sorry to bring this up again. But I met exactly the same problem with Break.

After setting Ram frequency to 1600 in bios (or even using the xmp setting), my cpu frequency is locked at 3.7Ghz even at idle. Besides, my cpu vcore is 1.3V in this setting, which is extremely high considering my cpu is not oced yet. I was told it might be because asus board is so "intelligent" that it would increase my vcore automatically to match 1600mhz. So I have to turn down the cpu vcore in bios manually to fix it. But I wonder if this is the reason, and there is any other method to fix this problem. Thanks.
Edited by lowirve - 10/12/11 at 12:01pm
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500K 4.5G@1.33V Asus P8Z68-V Sapphire HD 6970 2GB Corsair Vengeance 16GB 
Hard DriveOptical DriveCoolingOS
Crucial M4 64G&WD Black 1T None NH-D14 Win7 pro v64 
MonitorKeyboardPowerCase
Hp ZR24W Cherry G80-3000 Brown Corsair HX850 NZXT H2 
Mouse
G500 
  hide details  
Reply
My System
(14 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 2500K 4.5G@1.33V Asus P8Z68-V Sapphire HD 6970 2GB Corsair Vengeance 16GB 
Hard DriveOptical DriveCoolingOS
Crucial M4 64G&WD Black 1T None NH-D14 Win7 pro v64 
MonitorKeyboardPowerCase
Hp ZR24W Cherry G80-3000 Brown Corsair HX850 NZXT H2 
Mouse
G500 
  hide details  
Reply
post #4237 of 9343
Quote:
Originally Posted by RainMotorsports View Post
If I knew I would say. It was at like 2 this morning and im waiting on a long as F2H wu to complete at the moment.

I want to say it dropped around 1.32 from a manual setting of 1.39. With the PLL voltage drop it had been my most successful 4.5 so far. That is until 4.6 and a crash and then a bunch of funny colored screens later. Once again cant remember if the LLC was High or Ultra been running High most of the time.
Can you run Prime95 right now with CPU-Z open?
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #4238 of 9343
Quote:
Originally Posted by TwoCables View Post
Can you run Prime95 right now with CPU-Z open?
CPU-Z open voltage is set in bios to 1.350 manual but 1.360 in Ai, CPU-Z 1.368, Ai reads the same. Real Temp not under load has a VID of 1.2560.

CPU-Z 1.336 to 1.34 with Realtemp showing VID for 1.3661 and 1.3711

This has nothing todo with my settings for 4.5/4.6 though. I am trying to finish this work unit before i do anything today.

Rebooting to grab the settings i happen to have in for 4.4: LLC is high vrm is on auto at the moment since it wasnt really needing to be touched for 4.4.

Unless there is something to be gained here pretty pointless since this has nothing todo with last nights settings. Things like jacking the CPU current capability up happen for all that work.
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
post #4239 of 9343
Ok cool. When the WU is done, can you report what core voltage you see in CPU-Z with Prime95 running?
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #4240 of 9343
Quote:
Originally Posted by TwoCables View Post
Ok cool. When the WU is done, can you report what core voltage you see in CPU-Z with Prime95 running?
Yeah should be done in an hour or so. Big ass unit lol taking forever even at 4.4ghz.

I have an hour or two to mess with it today. Don't worry it wont take that long to crash it. I just felt like (while tired as all hell) if the voltage is dropping to 1.32 under prime95 at 4.5 that right there is my problem. But the PLL voltage seemed to help out with 4.6 more than anything before.

Ill let you know soon.
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
RainONE
(13 items)
 
ASUS G50VT
(13 items)
 
 
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5Ghz ASUS P8Z68 V PRO GTX 570 MSI TF III @ 950/1900/2300 16GB Corsair Vengeance 
Hard DriveOSKeyboardPower
2TB Seagate 5900 RPM Windows 7 x64 Ultimate Ideazon Z Board Seasonic X750 
CaseMouse
Thermaltake V9 BlacX Logitech G700 
CPUGraphicsRAMOS
Intel Core 2 Duo T9600 2.8Ghz @ 3.1Ghz Nvidia 9800M GS (OC @ 640/1600/800) 4GB DDR2 800Mhz Windows 7 
Mouse
Logitech G700 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel Motherboards
Overclock.net › Forums › Intel › Intel Motherboards › >>The Official ASUS P8P67/P8Z68 & P8Z68/GEN3 Series Owners Club>>