Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Amarok doesn't love me =[
New Posts  All Forums:Forum Nav:

Amarok doesn't love me =[

post #1 of 23
Thread Starter 
So, since I've swapped to KDE from GNOME, I discovered that Banshee hates working with me, so I installed amarok through the package manager, but it won't run. Clicking on the ison in the applications menu makes it hang after a minute, and running it from terminal gives me this:

Code:
[albert@BlueBeast ~]$ amarok
amarok: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /usr/lib/libamaroklib.so.1)
[albert@BlueBeast ~]$
I decided that music was more important than an update, so I pacman'd amarok first "sudo pacman -Sy amarok" and now I'm downloading a 600MB or so update. Ideas? Should the update fix the issue?
post #2 of 23
Dare I say, if it's strictly music you could use Audacious or MPD? I personally love Audacious, strictly for music though. Although it's minimal, it has tabbed playlists which I love way more than having a music browser. I know where my songs are, I have a full playlist and misc ones. It supports searching within the playlists too by hitting J I believe. Anyways, just a suggestion. I'm gonna see if banshee works on my end for ya.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #3 of 23
It could. But I would personally recommend installing Amarok 1.4 instead, IMO it is much better than 2. In fact it is my favorite media player on any platform.
    
CPUMotherboardGraphicsRAM
i7 2600k ASRock P67 Extreme4 MSI GTX 580 Lightning 2x4GB Corsair Vengeance DDR3 1866 9-10-9-27-1T 
Hard DriveOptical DriveCoolingOS
Mushkin 60GB SSD + 2xWD Black 500GB RAID0 Sony DVD-RW Noctua NH-D14 Windows 7 
MonitorKeyboardPowerCase
LG 22" 1080p + Acer 18" Das Keyboard - MX Blue Antec TruePower New TP-650 Cooler Master HAF 922 Black 
Mouse
Logitech 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 2600k ASRock P67 Extreme4 MSI GTX 580 Lightning 2x4GB Corsair Vengeance DDR3 1866 9-10-9-27-1T 
Hard DriveOptical DriveCoolingOS
Mushkin 60GB SSD + 2xWD Black 500GB RAID0 Sony DVD-RW Noctua NH-D14 Windows 7 
MonitorKeyboardPowerCase
LG 22" 1080p + Acer 18" Das Keyboard - MX Blue Antec TruePower New TP-650 Cooler Master HAF 922 Black 
Mouse
Logitech 
  hide details  
Reply
post #4 of 23
I just use exaile. It is simple. Granted I am new to Linux music players.
XEON POWER
(17 items)
 
  
CPUMotherboardGraphicsRAM
Xeon E3-1280 V2 Asus p8h77-i EVGA GTX 570  Corsair Dominator Platinum 1866 cl9 16gb 2x8gb 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint F3 Samsung 830 Crucial C300 Samsung USB Blu-Ray 
OSMonitorMonitorKeyboard
Windows 8 Dell U2711 HP 2709m Razer Blackwidow 
PowerCaseMouseMouse Pad
Silverstone Strider Essentials ST60ES-F Bitfenix Prodigy Razer Naga Molten razer sphex 
Audio
onboard 
  hide details  
Reply
XEON POWER
(17 items)
 
  
CPUMotherboardGraphicsRAM
Xeon E3-1280 V2 Asus p8h77-i EVGA GTX 570  Corsair Dominator Platinum 1866 cl9 16gb 2x8gb 
Hard DriveHard DriveHard DriveOptical Drive
Samsung Spinpoint F3 Samsung 830 Crucial C300 Samsung USB Blu-Ray 
OSMonitorMonitorKeyboard
Windows 8 Dell U2711 HP 2709m Razer Blackwidow 
PowerCaseMouseMouse Pad
Silverstone Strider Essentials ST60ES-F Bitfenix Prodigy Razer Naga Molten razer sphex 
Audio
onboard 
  hide details  
Reply
post #5 of 23
It's loading, I didn't test beyond that but the update should fix it.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #6 of 23
update 600mb? lol you were probably missing kde libraries it wanted or something... amarok is a pretty nice music player but it is designed to run with kde, so making it run on gnome uses a bit of disk space
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
post #7 of 23
Thread Starter 
Quote:
Originally Posted by EntTheGod View Post
update 600mb? lol you were probably missing kde libraries it wanted or something... amarok is a pretty nice music player but it is designed to run with kde, so making it run on gnome uses a bit of disk space
No, it's 600MB of neglected system updates.

I'm already running KDE [in fact, today I finally removed gnome and gnome-extra], but amarok just doesn't like me. It now starts up, but won't play anything.

I'm currently grabbing 1.4 off the AUR.

On a side note, my computer decided it wanted to clock my RAM up from 880 to 1057, and Arch kept reporting segmentation faults over it...

Needless to say, my ram speed is no longer on [AUTO] =]
post #8 of 23
Quote:
Originally Posted by Bluescreen_Of_Death View Post
No, it's 600MB of neglected system updates.

I'm already running KDE [in fact, today I finally removed gnome and gnome-extra], but amarok just doesn't like me. It now starts up, but won't play anything.

I'm currently grabbing 1.4 off the AUR.

On a side note, my computer decided it wanted to clock my RAM up from 880 to 1057, and Arch kept reporting segmentation faults over it...

Needless to say, my ram speed is no longer on [AUTO] =]
your on OCN you should know auto settings are evil

and maybe it was just an out dated lib on your system that amarok wanted.... and so when you updated it passed the version that amarok wanted, so now you gotta update amarok to match the lib version dependency issues are unfun some times
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
Kinda meh now...
(13 items)
 
  
CPUMotherboardGraphicsRAM
PhII 940 BE asus M4N82 Deluxe 2x 8800gts(g92) 2x 1g ocz ddr2 1066 
Hard DriveOptical DriveOSMonitor
/dev/sd[abc] /dev/sr0 WinXP/Linux 22in acer 
PowerCaseMouseMouse Pad
950w rosewill timebomb Antec 900 (2small) Voodoo Deathadder (RED!) X-Trac Pads Ripper XL 
  hide details  
Reply
post #9 of 23
Thread Starter 
Quote:
Originally Posted by EntTheGod View Post
your on OCN you should know auto settings are evil

and maybe it was just an out dated lib on your system that amarok wanted.... and so when you updated it passed the version that amarok wanted, so now you gotta update amarok to match the lib version dependency issues are unfun some times
Amarok is already fully up to date. I synced pacman before downloading it.

Anyway, here is the latest development:

When compiling amarok1 from the aur via yaourt, this happens:

Code:
checking for Qt... configure: error: Qt (>= Qt 3.3 and < 4.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
And I can't find the config.log file... =/

Code:
[albert@BlueBeast ~]$ cd /tmp
[albert@BlueBeast tmp]$ ls
akonadi-albert.RaHm78  kde-albert      pulse-lGn7CcctT9Rw  virtuoso_hX3440.ini
cron.DVLcqC            ksocket-albert  ssh-vHhlrjuV3276    yaourt-tmp-albert
gpg-sH7YWx             orbit-albert    virt_1111
[albert@BlueBeast tmp]$ cd yaourt-tmp-albert/
[albert@BlueBeast yaourt-tmp-albert]$ ls
aur-amarok1  orphans  PKGDEST.Nhn
[albert@BlueBeast yaourt-tmp-albert]$ cd aur-amarok1/
[albert@BlueBeast aur-amarok1]$ ls
amarok-1.4.10.coverfetcher.diff  gcc45.patch              ruby19_rstring.patch
amarok-1.4.10.tar.bz2            libmtp.patch             src
amarok_addaspodcast.desktop      pkg                      wikipedia.patch
amarok.install                   PKGBUILD
gcc44.patch                      ruby19_configure2.patch
[albert@BlueBeast aur-amarok1]$ cd pkg
[albert@BlueBeast pkg]$ ls
[albert@BlueBeast pkg]$ cd ..
[albert@BlueBeast aur-amarok1]$ cd src
[albert@BlueBeast src]$ ls
amarok-1.4.10                    gcc44.patch              ruby19_rstring.patch
amarok-1.4.10.coverfetcher.diff  gcc45.patch              wikipedia.patch
amarok-1.4.10.tar.bz2            libmtp.patch
amarok_addaspodcast.desktop      ruby19_configure2.patch
[albert@BlueBeast src]$ cd ..
[albert@BlueBeast aur-amarok1]$ ls
amarok-1.4.10.coverfetcher.diff  gcc45.patch              ruby19_rstring.patch
amarok-1.4.10.tar.bz2            libmtp.patch             src
amarok_addaspodcast.desktop      pkg                      wikipedia.patch
amarok.install                   PKGBUILD
gcc44.patch                      ruby19_configure2.patch
[albert@BlueBeast aur-amarok1]$
post #10 of 23
yaourt -S qt-mt

On a side note, something isn't right if it won't run. =S I'm up to date as of this week and it's running fine.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Amarok doesn't love me =[