Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5850 Big Problem, Please help!
New Posts  All Forums:Forum Nav:

HD5850 Big Problem, Please help!

post #1 of 6
Thread Starter 
My Sapphire Radeon HD5850 is having many problems, I have the latest ATi Catalyst Drivers, My card is Correctly placed into the PCIe 2.1 Slot and the Card's External Power connecters are plugged in properly. Also, any and all Nvidia Drivers have been removed the computer.

Now Here is the problem: Every time I try to Play a Game it freezes immediatly after it is done loading and my computer shows the Message, "Video Drivers have Stop Working and Have Recovered Succesfully". I am totally Clueless right no, I have never experienced anything Like this problem Before, Please Help!

Gear mentioned in this thread:

post #2 of 6
Uninstall the drivers and reinstall them, or try rolling them back.

Clean throughly.
The White Wolf
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 955 @ 3.7GHZ Biostar TA890FXE ASUS 6870 DirectCu @ 1GHZ G.SKILL Ripjaws, 2X2 
Hard DriveOptical DriveOSMonitor
1TB Samsung Spinpoint F3 ASUS 24X SATA Drive Windows 7 64-bit Some Viewsonic at 1680X1050 
KeyboardPowerCaseMouse
Microsoft Seasonic X-750 80 Plus Gold NZXT Phantom Logitech something something 
Mouse Pad
Custom 
  hide details  
Reply
The White Wolf
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II X4 955 @ 3.7GHZ Biostar TA890FXE ASUS 6870 DirectCu @ 1GHZ G.SKILL Ripjaws, 2X2 
Hard DriveOptical DriveOSMonitor
1TB Samsung Spinpoint F3 ASUS 24X SATA Drive Windows 7 64-bit Some Viewsonic at 1680X1050 
KeyboardPowerCaseMouse
Microsoft Seasonic X-750 80 Plus Gold NZXT Phantom Logitech something something 
Mouse Pad
Custom 
  hide details  
Reply
post #3 of 6
Hi charlie97. Yeah the use of a driver sweeper will probably help out. You may have removed the drivers yourself, but some traces could remain which can cause conflicts. Once used you can then do a fresh install of the latest drivers.

Harry @ Videocardshop.
post #4 of 6
Charlie just as the previous 2 posts stated..Download Driver Sweeper and install it...Reboot in safe mode run Driver Sweeper and remove anything left..Restart do a clean install and all should be good and if not roll back to the previous drivers you had installed...Good luck.
Toxic i7
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 930 (3951A687)4.01@1.23v ASUS P6T Deluxe V2 MSI GTX570 Twin Frozr II CORSAIR DOMINATOR 6GB 
Hard DriveOSMonitorPower
OCZ Agility60gb SSD(Boot)+WD Black 640GB (Storage) Windows 7 Home Premium 64-bit Dell U2410 and View Sonic VX2025WM 20.1 SeaSonic X750-750 Watt 
Case
Coolermaster Cosmos S 
  hide details  
Reply
Toxic i7
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 930 (3951A687)4.01@1.23v ASUS P6T Deluxe V2 MSI GTX570 Twin Frozr II CORSAIR DOMINATOR 6GB 
Hard DriveOSMonitorPower
OCZ Agility60gb SSD(Boot)+WD Black 640GB (Storage) Windows 7 Home Premium 64-bit Dell U2410 and View Sonic VX2025WM 20.1 SeaSonic X750-750 Watt 
Case
Coolermaster Cosmos S 
  hide details  
Reply
post #5 of 6
I assume your card is not overclocked at all? sometimes drives will cuase a overclock to fail and you have to back them off a little. The only time i ever got that error is when my overclock on my card was to much.

But i think the above is more likly... use driversweeper and reinstall the drivers.
Shadow
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 C0 @ 3.76 EVGA X58 5850 TOXIC 2GB 6GB OCZ 1600 7.7.7 
Hard DriveOSMonitorKeyboard
Seagate 250GB X 5 (Raid 5) WIndows 7 Pro SECPTRE 1920 X 1200 X 3 Saitek Eclipse 
PowerCaseMouseMouse Pad
1000W Rosewell NZXT OCZ Equalizer Blue squishy thing 
  hide details  
Reply
Shadow
(13 items)
 
  
CPUMotherboardGraphicsRAM
I7 920 C0 @ 3.76 EVGA X58 5850 TOXIC 2GB 6GB OCZ 1600 7.7.7 
Hard DriveOSMonitorKeyboard
Seagate 250GB X 5 (Raid 5) WIndows 7 Pro SECPTRE 1920 X 1200 X 3 Saitek Eclipse 
PowerCaseMouseMouse Pad
1000W Rosewell NZXT OCZ Equalizer Blue squishy thing 
  hide details  
Reply
post #6 of 6
I just went through 4 ( yes 4) 5850s from Sapphire that had were all bad. If it keeps giving you trouble RMA it. go for the 6900 series.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500K@ 4.8ghz 1.37v in CPUZ Asus P8Z68-V PRO/GEN3 6950 stock Corsair 16GB 1600 
OSPowerCase
Win 7 64 Corsair TX850 Lian-Li Full tower 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
2500K@ 4.8ghz 1.37v in CPUZ Asus P8Z68-V PRO/GEN3 6950 stock Corsair 16GB 1600 
OSPowerCase
Win 7 64 Corsair TX850 Lian-Li Full tower 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI

Gear mentioned in this thread:

Overclock.net › Forums › Graphics Cards › AMD/ATI › HD5850 Big Problem, Please help!