Overclock.net › Forums › Graphics Cards › AMD/ATI › Very odd 5770 problem
New Posts  All Forums:Forum Nav:

Very odd 5770 problem

post #1 of 5
Thread Starter 
Hey everyone, I'm having a problem with the Sapphire HD5770 in my Phenom rig. I was installing the latest cat 11.5 driver when my screen went black halfway through the install. I thought nothing of it since that happens once in a while when installing new drivers. But the screen stayed black for over 5 mins so I restarted my system. When I got back into Windows 7, all seemed fine until the screen went black again after about 10 seconds. The monitor is still on but is totally black.

I've tried uninstalling and reinstalling cat 11.3/11.4/11.5 with no success using safe mode to manually get rid of the previous display drivers. The black screen after 10 seconds is consistent no matter what driver I use and I can hear the fan on the card spool up to about 60 percent once the screen blanks out. If I boot into safe mode, there isn't an issue with the black screen and all seems fine. I also uninstalled msi afterburner in case that was causing the problem but the black screen of doom persists.

Has anyone else had a problem like this? I've owned ONLY ati video cards and this is the first time a driver has messed up my system. I'm at a loss with the consistency of this problem. I'm going to swap in a 4850 and see if it really is the driver or perhaps it could be the actual card causing the trouble.

Thanks for your time and +Rep to anyone who has worthwhile idea's for solving this problem
post #2 of 5
Do you have 2 monitors plugged in? I bet if you do that the black screen is just because it's been turned into your 2nd monitor!
    
CPUMotherboardGraphicsRAM
i5-2500k  MSI z68ma-EP55 4870 1GB 8GB Kingston Hyper X DDR3 1333 (7-7-7-20) 
Hard DriveOptical DriveOSMonitor
60GB OCZ V2 SSD and lots of mech drives DVD-ROM Windows 7 chronic edition BENQ 1680X1050 
KeyboardPowerCaseMouse
Kinesis Freestyle PC Power and Cooling 610watt Lian Li PC-A04B wowpen joy 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i5-2500k  MSI z68ma-EP55 4870 1GB 8GB Kingston Hyper X DDR3 1333 (7-7-7-20) 
Hard DriveOptical DriveOSMonitor
60GB OCZ V2 SSD and lots of mech drives DVD-ROM Windows 7 chronic edition BENQ 1680X1050 
KeyboardPowerCaseMouse
Kinesis Freestyle PC Power and Cooling 610watt Lian Li PC-A04B wowpen joy 
  hide details  
Reply
post #3 of 5
See the "old catalyst removal" section. I used it to get rid of a "top right corner mouse lag" issue that was lingering through different driver installs.

http://www.tweakguides.com/ATICAT_3.html

In my experience, when using safe mode the GPUs fan will speed up. That's most likely because it's not using ATIs driver. So yeah, fan speeding up should indicate that the card is not using the ATI driver... because it crashed.
Edited by cuad - 5/11/11 at 6:39pm
sinep
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 GA-X58A-UD3R MSI GTX 650Ti Corsair XMS3 
Hard DriveOSMonitorKeyboard
Seagate 4TB + Crucial M4 64-bit Windows 7 Home Premium Asus VG248QE </3 Sidewinder X4 
MouseMouse PadAudio
Wheel Mouse Optical Sideways Puretrak Talent Focusrite Scarlett 2i2 + Red Sony MDRZX300 
  hide details  
Reply
sinep
(11 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 GA-X58A-UD3R MSI GTX 650Ti Corsair XMS3 
Hard DriveOSMonitorKeyboard
Seagate 4TB + Crucial M4 64-bit Windows 7 Home Premium Asus VG248QE </3 Sidewinder X4 
MouseMouse PadAudio
Wheel Mouse Optical Sideways Puretrak Talent Focusrite Scarlett 2i2 + Red Sony MDRZX300 
  hide details  
Reply
post #4 of 5
Use this guide: http://www.overclock.net/ati-drivers...-software.html Works much better then driver sweeper and is much easier.
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
I is bad@naming
(21 items)
 
Up and running!!
(27 items)
 
 
CPUMotherboardGraphicsGraphics
Intel 4930k Asus Rampage IV Black edition Powercolor 7870 PCS+ Sapphire 7950 
RAMHard DriveHard DriveHard Drive
16gb 2133mhz G.Skill Sniper  Kingston SSD Western Digital R4 Seagate Barracuda 
CoolingCoolingCoolingOS
EK Supremacy acetyl/Nickel XSPC EX240 Phobya DC-12 400 Windows 7 
MonitorKeyboardPowerCase
Asus 23.5" Corsair K70 Antec True Power Quattro 850w Coolermaster Storm Trooper 
MouseMouse PadAudioAudio
Logitech G400 Steelseries QCK Schiit Magni Schiit Modi 
Audio
Hifiman HE-400 
CPUMotherboardGraphicsRAM
Intel Core i7 2600K Asrock Extreme 6 Z77 PowerColor 7870 PCS+ MYST Corsair Vengeance 
RAMHard DriveHard DriveHard Drive
Corsair Vengeance 30gb Kingston SSD 500gb seagate Western Digital R4 
Hard DriveOptical DriveCoolingCooling
Seagate Barracuda Lite-on 18x Danger Den TDX XSPC EX240 
CoolingOSOSOS
Phobya DC12-400 Windows 7 Home Premium 64bit Windows 8 pro 64bit Ubuntu 
MonitorMonitorKeyboardPower
Asus VH236H Acer V203W Logitech Business class Antec Truepower Quattro 850w 
CaseMouseMouse PadAudio
CoolerMaster Storm trooper Logitech G400 Steelseries QCK MOH edition Audio-Technica AD-700 
AudioAudioOther
Creative Soundblaster z Sony XB-800 Logysis white cold cathodes 
  hide details  
Reply
post #5 of 5
Thread Starter 
Thanks for the replies everybody. I tested my 4850 with new drivers and it worked fine so I knew it had to be something with the 5770 for some reason. I went ahead and "uninstalled" the driver from the installation menu in the cat driver setup. I then went ahead and deleted all associated ati files in program files manually. I also downloaded drive sweeper and ran that to weed out all the other pesky files hiding. After all that, I rebooted and installed cat 11.4 and was successful!!!! I am so happy and +rep for all!
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Very odd 5770 problem