Overclock.net › Forums › Graphics Cards › NVIDIA › New graphics card looks glitchy in games
New Posts  All Forums:Forum Nav:

New graphics card looks glitchy in games - Page 2

post #11 of 14
try this

1.install driver sweeper
2.get rid of previous drivers, and run driver sweeper
3.get latest drivers from site

never download from cd. ever.

it could however, be a lemon. it happens.
rebirth
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom 2 x4 955 BE Asus M4A88TD-V EVO Asus gtx560 ti (non ref) G.Skill DDR31600 x12 
Hard DriveOptical DriveCoolingOS
Western Digital 500Gb LG 22x Antec Kuhler 620 Win 7 64bit 
MonitorKeyboardPowerCase
Asus 24in Logitech g15 Corsair 650TX Corsair 600t 
MouseMouse Pad
Razor Diamondback Walmart 
  hide details  
Reply
rebirth
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom 2 x4 955 BE Asus M4A88TD-V EVO Asus gtx560 ti (non ref) G.Skill DDR31600 x12 
Hard DriveOptical DriveCoolingOS
Western Digital 500Gb LG 22x Antec Kuhler 620 Win 7 64bit 
MonitorKeyboardPowerCase
Asus 24in Logitech g15 Corsair 650TX Corsair 600t 
MouseMouse Pad
Razor Diamondback Walmart 
  hide details  
Reply
post #12 of 14
You need to enable Vsync, no reason to really have it off.
Gene-Z Dedi
(7 items)
 
Captain America
(6 items)
 
 
CPUMotherboardRAMHard Drive
i7 2600k @ 5.2 Ghz Asus Maximus IV Gene-Z Gskill 2133 4GB Caviar Black 
CoolingOSPower
Corsair H100 Arch x64 OCZ 650 Watt 
CPUCPUMotherboardGraphics
Intel Xeon E5-2650 Intel Xeon E5-2650 ASUS Z9PE-D8 WS XFX 6870 
RAMOS
32 GB Samsung Arch Nix 
  hide details  
Reply
Gene-Z Dedi
(7 items)
 
Captain America
(6 items)
 
 
CPUMotherboardRAMHard Drive
i7 2600k @ 5.2 Ghz Asus Maximus IV Gene-Z Gskill 2133 4GB Caviar Black 
CoolingOSPower
Corsair H100 Arch x64 OCZ 650 Watt 
CPUCPUMotherboardGraphics
Intel Xeon E5-2650 Intel Xeon E5-2650 ASUS Z9PE-D8 WS XFX 6870 
RAMOS
32 GB Samsung Arch Nix 
  hide details  
Reply
post #13 of 14
Thread Starter 
Turning on vsync worked wonders. Thank you all. Games look amazing now.
post #14 of 14
Quote:
Originally Posted by JedixJarf View Post
You need to enable Vsync, no reason to really have it off.
I disagree. having at least 85fps on cs + cod improves the overall smoothness of the game and registration. I do so much better with it off. For me, single play experience = vsync on, multiplayer = vsync off.
my first child
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.2ghz Evga X58 Sli3 2x Gtx 460 @ 820Mhz [SLI] 12GB G skill 1600 
Hard DriveHard DriveHard DriveCooling
Corsair Force GT 120gb SSD x2 1TB Western digital Caviar Black 1TB 5900 rpm Seagate (Storage) Corsair H50 
OSMonitorKeyboardPower
Windows 7 pro 64 bit Samsung 27" 1920x1080 Saitek Eclipse II Corsair AX 850w 
CaseMouseAudio
Haf X R.A.T. 7 Albino Klipsch Promedia 2.1 w/ 200W sub 
  hide details  
Reply
my first child
(17 items)
 
  
CPUMotherboardGraphicsRAM
i7 950 @ 3.2ghz Evga X58 Sli3 2x Gtx 460 @ 820Mhz [SLI] 12GB G skill 1600 
Hard DriveHard DriveHard DriveCooling
Corsair Force GT 120gb SSD x2 1TB Western digital Caviar Black 1TB 5900 rpm Seagate (Storage) Corsair H50 
OSMonitorKeyboardPower
Windows 7 pro 64 bit Samsung 27" 1920x1080 Saitek Eclipse II Corsair AX 850w 
CaseMouseAudio
Haf X R.A.T. 7 Albino Klipsch Promedia 2.1 w/ 200W sub 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › New graphics card looks glitchy in games