Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 570 Worse Performance Than GTX 275?
New Posts  All Forums:Forum Nav:

GTX 570 Worse Performance Than GTX 275?

post #1 of 27
Thread Starter 
Hey guys,

So I recently upgraded from a GTX 275 to a GTX 570 and was expecting performance increases in games. However, when I tested games on my new card I found that I was getting lower FPS than with my GTX 275, which obviously isn't right. In fact, I was just playing Battlefield Bad Company 2 on DirectX 9 on high settings (same settings as I always used on the GTX 275) and noticed that my FPS was dropping in the 20's and even in the teens! It's frustrating because my GTX 275 played on these settings very smoothly and when I upgraded to this card I was expecting an increase in performance not a decrease. It's weird because it seems the performance of the card gets even worse over time (although it starts off poorly in the first place). For instance, when I first start playing I was getting around 25-40 FPS, which is still worse than my GTX 275, but as I kept playing I would get even lower FPS around the 15-28 FPS range.

I have an older computer that I built in 2007 (which still uses Windows XP Professional) but have made a few upgrades to it. Here are my system specs:

Motherboard: EVGA 680i SE
CPU: intel Core2Duo @ 3.00 GHz
Memory: Corsair Dominator DDR2 1066
Graphics Card: EVGA GTX 570 SC
Power Supply: PC Power & Cooling 750W

Now I understand that games like BFBC2 prefer a quad core processor but I should be getting higher FPS than that and like I said before I was getting a lot better FPS with the same setup on my GTX 275. I've also tried a couple other games and noticed I can barely keep 30 fps and often times drop into the 20's even in an old game like the Witcher.

Here is a list of things I've tried so far (list is not in chronological order):

-Cleaned and reinstalled the latest drivers
-Updated BIOS to the latest version
-Installed latest motherboard drivers
-Tested in other user profiles.
-Checked the processes, nothing's eating up resources
-All hardware is set to default (no overclocking, unless it came factory overclocked)
-Checked the temperatures, everything is running cool, including the graphic card
-GPU-Z shows that the GPU usage is low when playing games, even though I get terrible FPS.

So I'm stomped, I don't know what else to do, that's why I came here to ask others who may know what it is.
post #2 of 27
Have you tested the card in another system? Sounds like it's power throttling or staying on 2d clocks or something? I'm a little clueless right here because this sounds weird.
>dat smooth feel
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k MSI z77 GD65 ASUS EAH6970 CrossFire Crucial ballistix 8gb 1866Mhz 
Hard DriveOptical DriveCoolingOS
Crucial m4 512gb,2x128GB Samsung 830 SSDs in RA... None H60 Windows 7 
MonitorKeyboardPowerCase
Samsung 2343BW Steelseries 7g Antec TP New 750W Lian Li A71F 
MouseMouse Pad
IME 3.0 Qck+ 
  hide details  
Reply
>dat smooth feel
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k MSI z77 GD65 ASUS EAH6970 CrossFire Crucial ballistix 8gb 1866Mhz 
Hard DriveOptical DriveCoolingOS
Crucial m4 512gb,2x128GB Samsung 830 SSDs in RA... None H60 Windows 7 
MonitorKeyboardPowerCase
Samsung 2343BW Steelseries 7g Antec TP New 750W Lian Li A71F 
MouseMouse Pad
IME 3.0 Qck+ 
  hide details  
Reply
post #3 of 27
First of all fill this http://www.overclock.net/specs.php also from what I see You have Core2Duo @ 3.00 GHz which is too weak for such a powerful card.
Rozpierdalator :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 920 D0 @ 4.2GHz HT On 1.27v MSI Eclipse SLI 2x Gainward GTX570 Phantom 1280MB DDR5 in SLI OCZ Reaper 3x1GB 1866MHz @ 1640MHz 7-6-6-15 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 60GB + 3x HD502HJ + SP2504C Sony Optiarc AD-7260S Windows 7 32bit Hyundai N220Wa+ 
PowerCaseMouse
OCZ ModXStream Pro 700W NZXT Phantom White Logitech G300 
  hide details  
Reply
Rozpierdalator :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 920 D0 @ 4.2GHz HT On 1.27v MSI Eclipse SLI 2x Gainward GTX570 Phantom 1280MB DDR5 in SLI OCZ Reaper 3x1GB 1866MHz @ 1640MHz 7-6-6-15 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 60GB + 3x HD502HJ + SP2504C Sony Optiarc AD-7260S Windows 7 32bit Hyundai N220Wa+ 
PowerCaseMouse
OCZ ModXStream Pro 700W NZXT Phantom White Logitech G300 
  hide details  
Reply
post #4 of 27
GPU usage SHOULD be high, at 99%+ load constantly for you to get good FPS, can you post a GPU-Z / MSI Afterburner shot of a few minutes in a game with VSYNC off.
You've done most things, so I'm stumped, maybe it's PSU problem?
Sandyman
(14 items)
 
Lenovo Y500
(8 items)
 
 
CPUGraphicsRAMHard Drive
i7 3630QM GT 650M SLI 2x4GB DDR3 1600 MHz Sandisk Extreme II 240GB 
Optical DriveOSMonitorMouse
None Windows 8 15.6" 1080p Steelseries Sensei RAW 
  hide details  
Reply
Sandyman
(14 items)
 
Lenovo Y500
(8 items)
 
 
CPUGraphicsRAMHard Drive
i7 3630QM GT 650M SLI 2x4GB DDR3 1600 MHz Sandisk Extreme II 240GB 
Optical DriveOSMonitorMouse
None Windows 8 15.6" 1080p Steelseries Sensei RAW 
  hide details  
Reply
post #5 of 27
Quote:
Originally Posted by sp4wners;13487609 
First of all fill this http://www.overclock.net/specs.php also from what I see You have Core2Duo @ 3.00 GHz which is too weak for such a powerful card.

Of course it has a bottleneck but it shouldn't be outperformed by a 275.
>dat smooth feel
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k MSI z77 GD65 ASUS EAH6970 CrossFire Crucial ballistix 8gb 1866Mhz 
Hard DriveOptical DriveCoolingOS
Crucial m4 512gb,2x128GB Samsung 830 SSDs in RA... None H60 Windows 7 
MonitorKeyboardPowerCase
Samsung 2343BW Steelseries 7g Antec TP New 750W Lian Li A71F 
MouseMouse Pad
IME 3.0 Qck+ 
  hide details  
Reply
>dat smooth feel
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 3570k MSI z77 GD65 ASUS EAH6970 CrossFire Crucial ballistix 8gb 1866Mhz 
Hard DriveOptical DriveCoolingOS
Crucial m4 512gb,2x128GB Samsung 830 SSDs in RA... None H60 Windows 7 
MonitorKeyboardPowerCase
Samsung 2343BW Steelseries 7g Antec TP New 750W Lian Li A71F 
MouseMouse Pad
IME 3.0 Qck+ 
  hide details  
Reply
post #6 of 27
Quote:
Originally Posted by andos;13487623 
Of course it has a bottleneck but it shouldn't be outperformed by a 275.

Yeah? If GPU uasge will be about 50-60% he can dream about performance better than with GTX275.
Rozpierdalator :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 920 D0 @ 4.2GHz HT On 1.27v MSI Eclipse SLI 2x Gainward GTX570 Phantom 1280MB DDR5 in SLI OCZ Reaper 3x1GB 1866MHz @ 1640MHz 7-6-6-15 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 60GB + 3x HD502HJ + SP2504C Sony Optiarc AD-7260S Windows 7 32bit Hyundai N220Wa+ 
PowerCaseMouse
OCZ ModXStream Pro 700W NZXT Phantom White Logitech G300 
  hide details  
Reply
Rozpierdalator :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 920 D0 @ 4.2GHz HT On 1.27v MSI Eclipse SLI 2x Gainward GTX570 Phantom 1280MB DDR5 in SLI OCZ Reaper 3x1GB 1866MHz @ 1640MHz 7-6-6-15 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 60GB + 3x HD502HJ + SP2504C Sony Optiarc AD-7260S Windows 7 32bit Hyundai N220Wa+ 
PowerCaseMouse
OCZ ModXStream Pro 700W NZXT Phantom White Logitech G300 
  hide details  
Reply
post #7 of 27
Your CPU is definitely bottlenecking your graphics card. If you have sufficient wattage to power both, you might want to try a mild overclock on your CPU maybe 500-700mhz. After testing for stability, see if your framerates have increased. Most likely it is throttling itself because it's drawing enuogh power to affect the CPU. For example, in my setup, if my CPU takes on 100% load in a graphically intense environment my SLi will throttle my cards down to avoid stressing the CPU even more. It's like a fail safe or protection trigger.
PRONE
(19 items)
 
Cap't Crunch
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 3930k @ 5Ghz Msi X79A-GD45 Gigabyte Radeon 7950 Patriot Sector 7 
Hard DriveOptical DriveCoolingCooling
2xCorsair Force Series 3 Raid-0 LG DVDR/W Custom Water Loop Swiftech Apogee Drive II waterblock/pump 
CoolingCoolingOSMonitor
Swiftech MCRES-Micro Rev 2 Larkooler 240mm Rad server 2008 RC2 HP 2207HD 
KeyboardPowerCaseMouse
HP Classic wireless PC Power and Cooling Silencer Mk II 950W High P... NZXT Phantom...again lol HP Classic wireless 
Mouse PadAudioOther
MicroCenter Onboard TBA 
CPUMotherboardGraphicsRAM
2500k Maximus V Extreme Radeon 6950HD Avexir 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 LG DVD RW Corsair H100i WIndowd 8.1 
MonitorKeyboardPowerCase
HP 2159M Logitech CX750M Cosair Carbide 540AIR 
MouseMouse Pad
logitech logitech 
  hide details  
Reply
PRONE
(19 items)
 
Cap't Crunch
(14 items)
 
 
CPUMotherboardGraphicsRAM
i7 3930k @ 5Ghz Msi X79A-GD45 Gigabyte Radeon 7950 Patriot Sector 7 
Hard DriveOptical DriveCoolingCooling
2xCorsair Force Series 3 Raid-0 LG DVDR/W Custom Water Loop Swiftech Apogee Drive II waterblock/pump 
CoolingCoolingOSMonitor
Swiftech MCRES-Micro Rev 2 Larkooler 240mm Rad server 2008 RC2 HP 2207HD 
KeyboardPowerCaseMouse
HP Classic wireless PC Power and Cooling Silencer Mk II 950W High P... NZXT Phantom...again lol HP Classic wireless 
Mouse PadAudioOther
MicroCenter Onboard TBA 
CPUMotherboardGraphicsRAM
2500k Maximus V Extreme Radeon 6950HD Avexir 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 LG DVD RW Corsair H100i WIndowd 8.1 
MonitorKeyboardPowerCase
HP 2159M Logitech CX750M Cosair Carbide 540AIR 
MouseMouse Pad
logitech logitech 
  hide details  
Reply
post #8 of 27
Welcome to OCN Spork thumb.gif

You've tried everything I'd suggest already aside from trying a re-install of Windows.

At this point I'd be wondering if maybe the XP drivers just run cruddy on 570's.

You're right that even with a CPU BN (which you will have in BFBC2 with that proc) it seems like you should at least get the same FPS as the 275, worst-case scenario, provided all settings are truly the same in both cases.

I kinda hate to break it you, but it's probably time to go ahead and update your OS, dude. You don't even get to use DX10 w/XP, let alone DX11. XP ... it just doesn't cut it anymore I'm afraid.

And soon after that, you should probably think about upgrading the rest of your system to match the might of your GTX570.
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
xeon X5675 6-core @ 4.1ghz (1.29v, 20x205 +ht ) rampage iii extreme msi rx470 gaming X (the $159 budget king) 3 x 2gb corsair xms3 pc12800 (9-9-9-24-1T@1600MHz) 
Hard DriveOptical DriveCoolingOS
hynix 250gb ssd (boot), 2tb deskstar (apps),1tb... plextor px-712sa - still the best optical drive... corsair h8o v2 aio W10 home 
MonitorPowerCaseAudio
asus vw266h 25.5" (1920x1200) abs sl (enermax revolution) * single 70A rail 850w silverstone rv-03 XFi Titanium 
  hide details  
Reply
post #9 of 27
Also install Win7. Man try to get full potential of this beast and stop sitting on XP tongue.gif If You're using MSI Afterburner just run some games and make a screenshot of GPU Utilization in Afterburner. Post a screenshot here, so we can help You. But it's 100% CPU bottlenecking. Try to overclock it at least 500MHz.
Rozpierdalator :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 920 D0 @ 4.2GHz HT On 1.27v MSI Eclipse SLI 2x Gainward GTX570 Phantom 1280MB DDR5 in SLI OCZ Reaper 3x1GB 1866MHz @ 1640MHz 7-6-6-15 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 60GB + 3x HD502HJ + SP2504C Sony Optiarc AD-7260S Windows 7 32bit Hyundai N220Wa+ 
PowerCaseMouse
OCZ ModXStream Pro 700W NZXT Phantom White Logitech G300 
  hide details  
Reply
Rozpierdalator :D
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i7 920 D0 @ 4.2GHz HT On 1.27v MSI Eclipse SLI 2x Gainward GTX570 Phantom 1280MB DDR5 in SLI OCZ Reaper 3x1GB 1866MHz @ 1640MHz 7-6-6-15 
Hard DriveOptical DriveOSMonitor
OCZ Vertex 2 60GB + 3x HD502HJ + SP2504C Sony Optiarc AD-7260S Windows 7 32bit Hyundai N220Wa+ 
PowerCaseMouse
OCZ ModXStream Pro 700W NZXT Phantom White Logitech G300 
  hide details  
Reply
post #10 of 27
Thread Starter 
Wow, I wasn't expecting so many replies so quick.

Here are screenshots of the Afterburner hardware monitor while I was playing BFBC2 and then The Witcher:

Battlefield Bad Company 2 (dirextX 9, high settings, 4x AF, no AA, Resolution 1680x1050)

BFBC2-1.jpg

The Witcher (High settings, everything turned on, everything maxed, Resolution 1680x1050)

TheWitcher.jpg

As you can see, the GPU usage is extremely low for both games, staying around 25-30% GPU usage. The GPU usage seems to be slightly higher for The Witcher game.


I forgot to mention in my original post that when I was playing BFBC2 and I turned down the graphics as low as they would go I still either got the same FPS or even worse, which is strange.
Edited by Sporkfire - 5/13/11 at 4:23am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › GTX 570 Worse Performance Than GTX 275?