Overclock.net › Forums › Components › Power Supplies › PSU failure?
New Posts  All Forums:Forum Nav:

PSU failure?

post #1 of 4
Thread Starter 
Well a little over a week ago, my 590 apparently died.. the geforce logo went cold after 3 minutes or so, but fan power was still on. So it seemed like an RMA to me, since I have a tagan 1200, and the rails are more than enough for it. It had been running fine for a month previously. Today my pc just randomly shut itself down, and then started up 1 second later, before dieng 2 seconds after that, this repeated until I switched the flick on the back of the PSU, so it basically went off-on-off-on-off-on. After flicking it, I switched it on again and it ran until I went to sleep. I turned it on this morning, and guess what, 30 minutes and off it went. Kept powering in a loop, so now it won't turn on at all. Just the on-off it won't stay on for more than 2-3 seconds. I'm no PSU expert, but is this a PSU fault, or a mobo? It's a Tagan Piperock 1200w modular PSU, I've used it for about 2-3 years.

If I do have to replace it, can anyone recommend a good alterantive? Here's my specs:
Specs:
CPU: Core i7 920 @ 3.8 C0
Motherboard: Asus P6T Deluxe X58
RAM: 12GB DDR3 G.Skill E.Q Series 1333Mhz auto timings
Video Card: nVidia GTX 590
Corsair 800D
Tagan 1200w Modular PSU
2X 24" Samsung Syncmaster 2443BW 1920x1200
Cooling:
EK Supreme HF Nickel
XSPC Dual Bay Res/Pump
Black Ice SR-2 360 Radiator

If it failed, wouldn't it be completely dead?
MAIN-PC
(18 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 c0 Asus P6T Deluxe Intel x58 Asus GTX 590 12GB DDR3 1333Mhz E.Q G.Skill 
Hard DriveHard DriveHard DriveCooling
Intel x-25m 80GB Samsung Spinpoint F3 Samsung Spinpoint F3 Frio 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 2x Samsung 2443BW Razer Lycosa 1200AX 
CaseMouseMouse PadAudio
Corsair Obsidian 800D G9 V1 RZR eXactMat DT880 
Other
Asus Xonar Essence STX 
  hide details  
Reply
MAIN-PC
(18 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 c0 Asus P6T Deluxe Intel x58 Asus GTX 590 12GB DDR3 1333Mhz E.Q G.Skill 
Hard DriveHard DriveHard DriveCooling
Intel x-25m 80GB Samsung Spinpoint F3 Samsung Spinpoint F3 Frio 
OSMonitorKeyboardPower
Windows 7 Ultimate x64 2x Samsung 2443BW Razer Lycosa 1200AX 
CaseMouseMouse PadAudio
Corsair Obsidian 800D G9 V1 RZR eXactMat DT880 
Other
Asus Xonar Essence STX 
  hide details  
Reply
post #2 of 4
I'd think that is your PSU, the mobo option goes in 2nd place.

Try to go with Corsair, Seasonic, XFX or Antec and I think that 850W are enough for your rig.
The New One
(19 items)
 
Ocing rig z97
(9 items)
 
 
CPUMotherboardGraphicsRAM
6700k Gigabyte Z170X Ulta Gaming GTX 1080 HoF Mushking 4*4GB 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 Crucial M500 Itachi Desktar Itachi Desktar 
Hard DriveCoolingOSMonitor
Toshiba Raystorm Pro CPU Windows 10 Professional BenQ XL2420Z 
KeyboardPowerCaseMouse
Thermaltake Corsair AX1200i HAF X Thermaltake Saphira 
Mouse PadAudioOther
QCK Gamecome 780 APC 1500VA 
CPUMotherboardGraphicsRAM
Intel Core G3258 Gigabyte Z97X SOC Force ASUS GTX 760 Striker Platinum G.Skill TridentX 
Hard DriveCoolingOSOS
Crucial MX100 Extreme cooling Windows 7 Pro x64 Windows XP Pro SP3 x86 
Power
EVGA SuperNOVA 1300V G2 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T Gigabyte 890FXA-UD5 ASUS GTX 760 Striker Platinum Crucial Ballistix Tracer 
RAMHard DriveHard DriveHard Drive
G.Skill Trident Crucial M4 Itachi Desktar Itachi Desktar 
Hard DriveHard DriveOptical DriveCooling
Crucial M500 Toshiba LG EK Supreme HF Full Nickel 
CoolingCoolingCoolingOS
Swiftech MCR-320QP Swiftech MCP655-D XSPC Reservoir Windows 7 Professional 
MonitorKeyboardPowerCase
BenQ XL2420z TT eSports Meka G1 Corsair AX1200i Cooler Master HAF X 
MouseMouse PadAudioOther
TT eSports Saphira QCK+ Creative Sound Blaster Recon3D Fatal1ty Profess... Plantronics GameCom 780 
  hide details  
Reply
The New One
(19 items)
 
Ocing rig z97
(9 items)
 
 
CPUMotherboardGraphicsRAM
6700k Gigabyte Z170X Ulta Gaming GTX 1080 HoF Mushking 4*4GB 
Hard DriveHard DriveHard DriveHard Drive
Crucial M4 Crucial M500 Itachi Desktar Itachi Desktar 
Hard DriveCoolingOSMonitor
Toshiba Raystorm Pro CPU Windows 10 Professional BenQ XL2420Z 
KeyboardPowerCaseMouse
Thermaltake Corsair AX1200i HAF X Thermaltake Saphira 
Mouse PadAudioOther
QCK Gamecome 780 APC 1500VA 
CPUMotherboardGraphicsRAM
Intel Core G3258 Gigabyte Z97X SOC Force ASUS GTX 760 Striker Platinum G.Skill TridentX 
Hard DriveCoolingOSOS
Crucial MX100 Extreme cooling Windows 7 Pro x64 Windows XP Pro SP3 x86 
Power
EVGA SuperNOVA 1300V G2 
CPUMotherboardGraphicsRAM
Phenom II X6 1090T Gigabyte 890FXA-UD5 ASUS GTX 760 Striker Platinum Crucial Ballistix Tracer 
RAMHard DriveHard DriveHard Drive
G.Skill Trident Crucial M4 Itachi Desktar Itachi Desktar 
Hard DriveHard DriveOptical DriveCooling
Crucial M500 Toshiba LG EK Supreme HF Full Nickel 
CoolingCoolingCoolingOS
Swiftech MCR-320QP Swiftech MCP655-D XSPC Reservoir Windows 7 Professional 
MonitorKeyboardPowerCase
BenQ XL2420z TT eSports Meka G1 Corsair AX1200i Cooler Master HAF X 
MouseMouse PadAudioOther
TT eSports Saphira QCK+ Creative Sound Blaster Recon3D Fatal1ty Profess... Plantronics GameCom 780 
  hide details  
Reply
post #3 of 4
Sounds like its probably a bad PSU, but you may just have a loose connection somewhere in there. I'd go through the rig and make sure everything is totally secure, and try another PSU if you've got a spare or can borrow one
enough cow bell
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 990x EVGA X58 3X SLI EVGA GTX580 6GB OCZ Gold DDR3 1600 
Hard DriveOSPowerMouse
Intel X-25M 80GB Windows 7 Ultimate 64 Corsair 750tx Logitech G500 
  hide details  
Reply
enough cow bell
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 990x EVGA X58 3X SLI EVGA GTX580 6GB OCZ Gold DDR3 1600 
Hard DriveOSPowerMouse
Intel X-25M 80GB Windows 7 Ultimate 64 Corsair 750tx Logitech G500 
  hide details  
Reply
post #4 of 4
My nx-8050 died 2 days ago.

It was in restart cycle when I found out, could show the 2 first bios screens and restart before OS list. After shutdown it would still give "idle" power to mobo(power/cmos leds on), but if I tried to start it would give power for a ~0.5secs, then shutdown to "idle"-mode.

When I opened the PSU I found out there was 3x capacitors popped. New PSU from shop -> everything working now.

PS: Get a one on the list if you buy new one
Durable
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-4930k 4.4Ghz Asus Rampage IV Formula ASUS DCII 680 GTX 16GB 
Hard DriveHard DriveHard DriveCooling
2x Intel 320 SSD 120GB Western Digital 1TB Caviar Blue 2x Western Digital 2TB Red in Raid0 Noctua NH-U14 
MonitorMonitorMonitorKeyboard
Benq XL2420T Dell U2412M LG Flatron wide L226W Steelseries 6Gv2 
PowerCaseMouseMouse Pad
Antec Truepower New 750W Cooling Master Test Bench Steelseries Kinzu V2 pro SteelSeries S&S 
AudioAudio
Koss PortaPro ModMic 
  hide details  
Reply
Durable
(18 items)
 
  
CPUMotherboardGraphicsRAM
i7-4930k 4.4Ghz Asus Rampage IV Formula ASUS DCII 680 GTX 16GB 
Hard DriveHard DriveHard DriveCooling
2x Intel 320 SSD 120GB Western Digital 1TB Caviar Blue 2x Western Digital 2TB Red in Raid0 Noctua NH-U14 
MonitorMonitorMonitorKeyboard
Benq XL2420T Dell U2412M LG Flatron wide L226W Steelseries 6Gv2 
PowerCaseMouseMouse Pad
Antec Truepower New 750W Cooling Master Test Bench Steelseries Kinzu V2 pro SteelSeries S&S 
AudioAudio
Koss PortaPro ModMic 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › PSU failure?