Overclock.net › Forums › Graphics Cards › AMD/ATI › HELP! My HD5970 bugs!!
New Posts  All Forums:Forum Nav:

HELP! My HD5970 bugs!!

post #1 of 3
Thread Starter 
Hi!

First i'd like to tell you, that my english isnt so great..


But then over to my problem.

I got an Club 3D HD5970 2gb card. It works fine until i install the CatalystControl Center, then it starts bugging and not showing anything at all.

But, if i only install the DisplayDriver it works fine.


Now to the real problem, ive heard that without CCC CrossFire isnt possbile. Id like to know if im using only the half of the card or not?


GPUZ says "Crossfire", and CPUZ recognizes both GPUs..
iKoala
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom ll X6 1090T Asus Crosshair IV Formula ATi Radeon HD 5970 CF 2x4GB Ripjaws 1600mhz 
Hard DriveOptical DriveOSMonitor
1tb Seagate + 100GB OCZ Revodrive Asus BD-R Windows 7 Home Premium x64 HP w20 x3 
PowerCaseMouse Pad
SilverStone Decathlon 850W Antec 1200 (Assembly Winter '11 coolest case 2nd!) Steelseries Ock 
  hide details  
Reply
iKoala
(13 items)
 
  
CPUMotherboardGraphicsRAM
Phenom ll X6 1090T Asus Crosshair IV Formula ATi Radeon HD 5970 CF 2x4GB Ripjaws 1600mhz 
Hard DriveOptical DriveOSMonitor
1tb Seagate + 100GB OCZ Revodrive Asus BD-R Windows 7 Home Premium x64 HP w20 x3 
PowerCaseMouse Pad
SilverStone Decathlon 850W Antec 1200 (Assembly Winter '11 coolest case 2nd!) Steelseries Ock 
  hide details  
Reply
post #2 of 3
maybe try different drivers?

Uninstall using AMDs own uninstaller and refrain from using any 3rd party tool such as driver sweeper if it isn't absolutely necessary.

And a good way to know if you're using crossfire is to download MSI after burner and check the GPU usage during games / other applications you want to run that utilize your card and support CFX. If both cores are utilized you're using CFX.
 
Benching
(17 items)
 
 
CPUMotherboardGraphicsRAM
[i7 5960X @ 4.8GHz] [Rampage V Extreme] [Titan 1400MHz (1500MHz bench)] [Various] 
Hard DriveCoolingCoolingCooling
[250GB 840EVO +2x SpinpointF3 1TB RAID0] [LD PC-V2 SS Phase Change] [XSPC X2O 750 pump/res] [Monsta 360 full copper + EK XT 360 + XT 240] 
MonitorPowerCaseAudio
[Crossover 27Q LED-P 1440p+ASUS 1200p+LG 1080p] [Corsair AX1200] [Dimastech Easy v3.0] [Sennheiser HD558s] 
CPUCPUMotherboardGraphics
FX 8320, FX 8350, Phenom II x2 555BE i7 3930K, i7 860, i7 4770K, 68x Celeron D CVF, commando, 2x RIVE, Z87X-OC Asus 4870x2, Sapphire 4870 
GraphicsGraphicsGraphicsGraphics
2x 5870, 5850, 5830, 5770 2x 3870x2, 3870 GTX Titan, GTX 480, GTX 590 GTX 285, GTX 260, 4x 9800GT, 8800GTX 
RAMHard DriveCoolingCooling
4x4GB vengeance, 2x4GB predatorX, 2x1GB OCZ DDR2 Intel X25-M 80GB LD PC-V2 SS Phase Change OCN Marksman 
CoolingCoolingOSPower
2x old tek slims (GPU) Various watercooling stuff win7, winxp AX1200 
Case
test bench / cardboard box 
  hide details  
Reply
 
Benching
(17 items)
 
 
CPUMotherboardGraphicsRAM
[i7 5960X @ 4.8GHz] [Rampage V Extreme] [Titan 1400MHz (1500MHz bench)] [Various] 
Hard DriveCoolingCoolingCooling
[250GB 840EVO +2x SpinpointF3 1TB RAID0] [LD PC-V2 SS Phase Change] [XSPC X2O 750 pump/res] [Monsta 360 full copper + EK XT 360 + XT 240] 
MonitorPowerCaseAudio
[Crossover 27Q LED-P 1440p+ASUS 1200p+LG 1080p] [Corsair AX1200] [Dimastech Easy v3.0] [Sennheiser HD558s] 
CPUCPUMotherboardGraphics
FX 8320, FX 8350, Phenom II x2 555BE i7 3930K, i7 860, i7 4770K, 68x Celeron D CVF, commando, 2x RIVE, Z87X-OC Asus 4870x2, Sapphire 4870 
GraphicsGraphicsGraphicsGraphics
2x 5870, 5850, 5830, 5770 2x 3870x2, 3870 GTX Titan, GTX 480, GTX 590 GTX 285, GTX 260, 4x 9800GT, 8800GTX 
RAMHard DriveCoolingCooling
4x4GB vengeance, 2x4GB predatorX, 2x1GB OCZ DDR2 Intel X25-M 80GB LD PC-V2 SS Phase Change OCN Marksman 
CoolingCoolingOSPower
2x old tek slims (GPU) Various watercooling stuff win7, winxp AX1200 
Case
test bench / cardboard box 
  hide details  
Reply
post #3 of 3
Are you using the correct CCC with the correct drivers. Apparently it matters if you try to use an older version of drivers with a new version of CCC, or vice versa.
I Love Cheese
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 3.4 Asus P8P67 Basic XFX 5970 2 gig Black Edition 2x 4 gig DDR 1600 G-Skill 
Hard DriveOSMonitorPower
2x500 gig WD Vista Ultimate 64-bit Dual 25" Hannspree LCD CM 750 Watt 
CaseMouse
Rosewill THOR Logitech Trackball 
  hide details  
Reply
I Love Cheese
(13 items)
 
  
CPUMotherboardGraphicsRAM
2600k @ 3.4 Asus P8P67 Basic XFX 5970 2 gig Black Edition 2x 4 gig DDR 1600 G-Skill 
Hard DriveOSMonitorPower
2x500 gig WD Vista Ultimate 64-bit Dual 25" Hannspree LCD CM 750 Watt 
CaseMouse
Rosewill THOR Logitech Trackball 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › HELP! My HD5970 bugs!!