Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Linux and S/PDIF audio.
New Posts  All Forums:Forum Nav:

Linux and S/PDIF audio. - Page 5

post #41 of 53
There's a IEC958 mixer setting that needs to be unmuted. That's all I can think of.
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
post #42 of 53
Thread Starter 
That's what I though as well ^^

I went back to gstreamer-properties after watching a couple youtube videos to see if I could give it another shot. All of the sudden SB400 S/PDIF Out was not in the drop box, only SB400 AC'97 Analog.

Another interesting fact. After installing OSS4 Firefox doesn't work anymore, I can't uninstall it, and updating it to 4.01 did absolutely nothing.
This computer does not get along with Linux very well, lol.
post #43 of 53
Quote:
Originally Posted by *ka24e* View Post
That's what I though as well ^^

I went back to gstreamer-properties after watching a couple youtube videos to see if I could give it another shot. All of the sudden SB400 S/PDIF Out was not in the drop box, only SB400 AC'97 Analog.

Another interesting fact. After installing OSS4 Firefox doesn't work anymore, I can't uninstall it, and updating it to 4.01 did absolutely nothing.
This computer does not get along with Linux very well, lol.
The firefox issue is because its ment for ALSA. If your on debian/ubuntu you have to install the plugins. Go read up on the OSS4 wikki:
http://www.opensound.com/wiki/index....ions_for_OSSv4

http://www.opensound.com/wiki/index....ALSA_Emulation

That's a dirty hack, there are plugins somewhere so you don't have to do that.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #44 of 53
Well, you're long overdue for an upgrade anyway, as discussed elsewhere
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
Underground
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 920 C0 ASUS P6T6 WS Revolution GTX 460 TR3X6G1600C8D 
Hard DriveOptical DriveCoolingOS
WD1001FALS SAMSUNG SH-S223F 22X DVD MULTI Corsair H50 Fedora 16 KDE x86_64 
MonitorKeyboardPowerCase
HP w19b Microsoft Comfort Curve Corsair CX600 Thermaltake Armor VA8003BWS 
MouseMouse Pad
Razer DeathAdder Black 
  hide details  
Reply
post #45 of 53
My advice, get a cheap soundblaster live used. I've got one (just in case my onboard goes out or later ones don't work). I just use stereo so its all I need! SBLs work with ALSA and OSS flawlessly and they should be dirt cheap. [edit] They even work in windows extremely well with the KX audio drivers.
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #46 of 53
Thread Starter 
I finally got it working!

After messing around with OSS4 (randomly ticking stuff, switching dev0,1,2 etc) I actually got it to work with the S/PDIF out. That is until I reboot then it will probably go to hell, lol, but it works now at least.

Oh I got FF back up also. ALSA and Pulse were conflicting with it somehow.

Thanks again guys.


Edited by *ka24e* - 5/16/11 at 11:23pm
post #47 of 53
Haha, glad it all worked out! ALSA drivers might just be broken, or maybe not updated in the kernel/distro you are using (updated enough to fix the problem). So they might still work or might work in the future. Either way that's irrelevant since you got it working. =) Sweet stuff though, just remember next time you tick "random stuff" and mark it down. =P
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
Current Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 4.6GHz@1.44v GA-990FXA-UD3 R4.0 HD 7950 (1100/1450) 8G Muskin DDR3 1866@8CLS 
Hard DriveOptical DriveOSMonitor
1TB WD LiteOn DVD-RW DL Linux/Windows 19" Phillips TV 1080p 
PowerCaseMouseMouse Pad
OCZ 600W Generic Junk Logitech MX400 Generic Junk 
Audio
SBL 5.1 
  hide details  
Reply
post #48 of 53
Thread Starter 
The only thing I can say 100% that caused it not to work was ALC/DAC under the SPDOUT tab in OSS4 not being checked. As soon as i checked that I came pretty close to blowing my ear drums out, lol.

Just in case anyone else has the same problem, tic the ALC/DAC box in OSS4.
post #49 of 53
I hope you compiled OSS from source. The binary has a 6 month limit on usage.
Skylake Build
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-6600k Gigabyte Z-170 Gaming 7 Gigabyte R9 390  Gskill Ripjaws V DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo Corsair H115i Windows 10 Pro Asus  
KeyboardPowerCaseMouse
Generic EVGA NEX750 G1 Phanteks Eclipse P400 GSkill MX780 
  hide details  
Reply
Skylake Build
(12 items)
 
  
CPUMotherboardGraphicsRAM
Intel Core i5-6600k Gigabyte Z-170 Gaming 7 Gigabyte R9 390  Gskill Ripjaws V DDR4 
Hard DriveCoolingOSMonitor
Samsung 850 Evo Corsair H115i Windows 10 Pro Asus  
KeyboardPowerCaseMouse
Generic EVGA NEX750 G1 Phanteks Eclipse P400 GSkill MX780 
  hide details  
Reply
post #50 of 53
Thread Starter 
Doesn't really matter, I switch OS's all the time. I'm sure I'll be using a different distro an a couple weeks, only because I'm still very new to linux and want to see what else is out there you know.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Linux, Unix
Overclock.net › Forums › Software, Programming and Coding › Operating Systems › Linux, Unix › Linux and S/PDIF audio.