Overclock.net › Forums › Case Mods & Cases › Builds & Case Mods › Case Mods › Trouble with pins on M12II 620w PSU
New Posts  All Forums:Forum Nav:

Trouble with pins on M12II 620w PSU

post #1 of 4
Thread Starter 
I absolutely cannot get the ATX pins out of the cables on my power supply. I do not own the tool, did not want to spend $20 on something I would only need for a couple of hours, so I have been trying with staples.

I have tried the staples method on other cables and they come out no problem, but the cables on my PSU refuse to budge.

Does anyone have any suggestions? It wouldn't be a big deal, but I need the housing on the modular cables in order to plug the cables back into the PSU. Without the housing I have no way of making my own cables.

Any help is appreciated.



Sorry if this is in the wrong section, but I saw a lot of threads about sleeving in here so figured this was related. Just move it if it doesn't belong please.
Edited by Kinru - 5/16/11 at 1:06pm
post #2 of 4
You may just simply need the tool. It really is worth the money.
http://ftwpc.com/cables-and-sleeving...tion-tool.html
post #3 of 4
Thread Starter 
I really can't justify it/do not want to wait a week for it to arrive. I would only be using it this once, and MAYBE in the very distant future, but to me that is not worth the $25 I would spend after shipping.
post #4 of 4
Try using a needle nose pliers to push the staples into the housing. I've found that can help to push the tabs down if it's too hard to push in the staples with your fingers.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Case Mods
Overclock.net › Forums › Case Mods & Cases › Builds & Case Mods › Case Mods › Trouble with pins on M12II 620w PSU