Overclock.net › Forums › Components › Sound Cards and Computer Audio › X-Fi Titanium HD speaker auto-mute problem
New Posts  All Forums:Forum Nav:

X-Fi Titanium HD speaker auto-mute problem

post #1 of 14
Thread Starter 
Hello audiophile peeps!

I just bought the X-Fi Titanium HD from Amazon.co.uk and hooked it up to my z5500 5.1 set.

Quite honestly, I cannot believe the sound quality difference from the onboard Realtek sound chip ive been using for 3 years. Its night and day. Ill never go back.

However, im having a bit of trouble with the auto-speaker mute function of the driver. The problem is, that when I plug my headphones in via the front-panel OR the jack on the sound card itself, it doesn't mute the speakers. I get both coming through simultaneously. It's odd. Apparently there is an option in the driver console to mute speakers automatically but It just isnt there for me.

Any suggestions? Ive updated the drivers etc. Speaker auto-mute worked beforehand.

[ATTACH]211326[/ATTACH]

Heres what the built in help system gives me -.-
Quote:
In the Settings dialog box, select the Headphones tab.

Select the Automatically enable headphone settings check box to automatically switch to the headphone settings when you connect headphones to your audio device.

Select the Automatically mute speakers check box to mute your speakers when you connect headphones to your audio device.
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
post #2 of 14
Do you mean that it worked before installing a newer driver? I mean if so, then rollback to the previous driver.
Edited by TwoCables - 5/21/11 at 7:21pm
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #3 of 14
Thread Starter 
Nah the driver was the first thing I installed. I didnt use the CD driver i got the most up-to-date driver from Creatives support site.

I meant the old Realtek onboard cards driver. I was just confirming that it worked before and there is nothing wrong with the front-panel audio connector itself.
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
post #4 of 14
Quote:
Originally Posted by Desmolas;13564943 
Nah the driver was the first thing I installed. I didnt use the CD driver i got the most up-to-date driver from Creatives support site.

I meant the old Realtek onboard cards driver. I was just confirming that it worked before and there is nothing wrong with the front-panel audio connector itself.
Is the onboard audio still enabled? If so, then disable it (and uninstall the driver first).

Beyond that, I guess I would try uninstalling everything and going with what's on the CD.
Edited by TwoCables - 5/21/11 at 7:25pm
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #5 of 14
TwoCables is right on the money.

Install from the Cd, then update the drivers and applications.
post #6 of 14
It might just be that the optical doesn't get disabled when you have headphones plugged in. I'm fairly certain you might have to turn that off manually.
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
Malignance
(24 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K Asus P8Z68-V eVGA GTX670 FTW 16GB Mushkin DDR3-2100 1.5V 
Hard DriveHard DriveHard DriveOptical Drive
2 x 128GB Crucial M4 2 x 1TB Samsung F3 RAID0 1.5TB Seagate Asus 22X DVDRW 
CoolingOSMonitorMonitor
Noctua NH-D14 Windows 7 Ultimate 64-bit Dell Ultrasharp U2410 Asus ProArt PA248Q 
KeyboardPowerCaseMouse
Rosewill RK-9000BR PCP&P Silencer MKIII 600W Lian Li PC-A05NB Logitech G500 
Mouse PadAudioAudioAudio
Rocketfish Dual Sided Asus Xonar Essence STX Infinity Primus P153 | Dayton DTA-120 Amplifier... Shure SRH840 
AudioAudioAudio
Audio Technica ATH-AD700X Objective DAC Audio-Technica ATR2500-USB 
  hide details  
Reply
post #7 of 14
If installing the driver from the CD makes it work, then I say don't mess with it after that.
Edited by TwoCables - 5/21/11 at 7:27pm
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
It's a computer!
(19 items)
 
  
CPUMotherboardGraphicsRAM
i5-2500K @ 4.5GHz (1.368-1.384V fixed voltage) ASUS P8P67 EVO B3 (UEFI ver. 1850) GTX 780 ASUS DirectCU II (1228 / 6300, 1.180V) G.SKILL Ripjaws X 8GB (2 x 4GB) 1866MHz, CL9 
Hard DriveHard DriveHard DriveOptical Drive
250 GB Samsung 840 EVO (C:\) 250 GB Samsung 840 EVO (D:\) 150 GB WD VelociRaptor Samsung SH-S243N 24x DVD Burner 
Optical DriveCoolingOSMonitor
Samsung SH-S203N 20X DVD Burner Thermaltake Frio Win 7 Home Premium x64 SP1 Retail AOC G2460PG (24" 1920 x 1080 144Hz G-SYNC) 
KeyboardPowerCaseMouse
Filco Majestouch 104-key Cherry MX Blues w/NKRO Corsair HX650 (Bronze, ordered on 12-12-2009) CM 690 Intellimouse Optical (1.1A) 1000Hz polling rate 
Mouse PadAudioAudio
Basic, but premium round X-Fi Titanium HD Klipsch ProMedia 2.1 (with 16 AWG Monster Cable... 
  hide details  
Reply
post #8 of 14
Thread Starter 
Quote:
Originally Posted by RallyMaster;13565120 
It might just be that the optical doesn't get disabled when you have headphones plugged in. I'm fairly certain you might have to turn that off manually.

Yep its connected via optical TOSLINK cable.

I uninstalled the old Realtek driver and disabled onboard audio from the BIOS so im pretty sure theres nothing wrong there (steps taken BEFORE installing new card;))
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
post #9 of 14
If you have the speakers connected by digital, it will not mute when you plug in headphones. I did a professional review of the card and that is a flaw that I found when using the card on a regular basis.

The software does automatically switch to a two channel headphone output mode, but there will still be sound over digital and the headphone out. You can simply shut off your speakers while listening to headphones and then turn them back on when you are done.
post #10 of 14
Thread Starter 
Oh wow, really? That is quite unbelievable for a £170 card. I know I can just switch of my receiver its in arms reach, but for conveniences sake id rather not. Surely thats an easy peasy driver fix or is it down at the hardware level?

Oh well, I suppose the actual sound quality of the card makes up for it but that is quite a burn. While im at it chalk, do you have a link to that professional review?
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
RiggyRiggington
(19 items)
 
  
CPUMotherboardGraphicsRAM
i7 920 2.66Ghz Asus P6T Intel X56 MSI 6950 2GB 18GB OCZ DDR3 1600MHz 
Hard DriveHard DriveOptical DriveCooling
1TB Hitachi Deskstar Crucial M4 256GB ASUS 22x DVD±RW HyperX 
OSMonitorMonitorKeyboard
Win7 64bit Asus PB278Q 27" Dell U2410 24" CM QuickFire TK 
PowerCaseMouseMouse Pad
Corsair TX 850w Coolermaster RC-1000 Logitech G5 Razer Goliathus 
AudioAudioAudio
Creative SB X-Fi Titanium HD Pioneer VSX-LX70 Reciever Pair Elac FS189, Pair Elac BS184, 1 PSB SubSeri... 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › X-Fi Titanium HD speaker auto-mute problem