Overclock.net › Forums › Components › Sound Cards and Computer Audio › (Solved) Unable to turn on EAX effects in games
New Posts  All Forums:Forum Nav:

(Solved) Unable to turn on EAX effects in games - Page 2

post #11 of 23
Thread Starter 
Ok still not working. I'm trying to use it in guildwars.
@chalk
1st. Thank you for your help so far
2nd. I went to that web page you linked and it says its supported, i even copied the reg path to make sure it was right and it still doesn't work.

I know it doesn't add alot to the game but it should still work

Edit: I have also tried using the game path option and that wont work either
post #12 of 23
With what game is this?
post #13 of 23
Thread Starter 
Guildwars at the moment, its the only game I'm playing that supports EAX
post #14 of 23
Quote:
Originally Posted by DeviousAddict View Post
Ok still not working. I'm trying to use it in guildwars.
@chalk
1st. Thank you for your help so far
2nd. I went to that web page you linked and it says its supported, i even copied the reg path to make sure it was right and it still doesn't work.

I know it doesn't add alot to the game but it should still work

Edit: I have also tried using the game path option and that wont work either
have you tried running the game in xp mode or force it to run in dx 9 mode?
Just go to the games shortcut and add -d9 after the gamesname.exe file

Eg

Game.exe -dx9
post #15 of 23
Quote:
Originally Posted by DeviousAddict View Post
Ok still not working. I'm trying to use it in guildwars.
@chalk
1st. Thank you for your help so far
2nd. I went to that web page you linked and it says its supported, i even copied the reg path to make sure it was right and it still doesn't work.

I know it doesn't add alot to the game but it should still work

Edit: I have also tried using the game path option and that wont work either
Did you move the game from the list in the left hand side over to the right in alchemy? That enables Alchemy to work for the game

1) you create the entry in Alchemy

2) then you click the ">" to move it to the right in order to enable Alchemy to translate the game to OpenAl.
post #16 of 23
Thread Starter 
Quote:
Originally Posted by chalkbluffgrown View Post
Did you move the game from the list in the left hand side over to the right in alchemy? That enables Alchemy to work for the game

1) you create the entry in Alchemy

2) then you click the ">" to move it to the right in order to enable Alchemy to translate the game to OpenAl.
Yep did that dude
post #17 of 23
Thread Starter 
Quote:
Originally Posted by Spooony View Post
have you tried running the game in xp mode or force it to run in dx 9 mode?
Just go to the games shortcut and add -d9 after the gamesname.exe file

Eg

Game.exe -dx9
I shall give this a try

Edit: OK that kinda worked, it gave me the 3d audio hardware option which I didn't have before but the EAX option is still faded

2nd Edit: Yay its working now, I kept it running in XP mode and i used the game path in alchemy instead of the root path..


Thank you all for your help
Edited by DeviousAddict - 5/19/11 at 5:35pm
post #18 of 23
Just add that -dx9 behind the shortcut then you don't have to right click then xp mode on it everytime
post #19 of 23
Again Spoony, you do not know what you are talking about.

DX9 is for the video renderer not the sound renderer.

XP allowed for hardware acceleration under Direct Sound 3D. Vista and Windows 7 do not unless sound calls are translated to OpenAL. All three operating systems are DirectX 9 compatible with video.

If you have ever played World of Warcraft, the same thing had to be done to its executable with XP compatibility mode in order to make hardware accelerated sound work.

The Windows XP mode has nothing to do with graphics.
Edited by chalkbluffgrown - 5/20/11 at 11:17pm
post #20 of 23
Quote:
Originally Posted by chalkbluffgrown View Post
Again Spoony, you do not know what you are talking about.

DX9 is for the video renderer not the sound renderer.

XP allowed for hardware acceleration under Direct Sound 3D. Vista and Windows 7 do not unless sound calls are translated to OpenAL. All three operating systems are DirectX 9 compatible with video.

If you have ever played World of Warcraft, the same thing had to be done to its executable with XP compatibility mode in order to make hardware accelerated sound work.

The Windows XP mode has nothing to do with graphics.
yes your right dx is just graphics. Sound is not part of the dx api Sound uses the magic carpet api. If you look closely you can see Aladdin rubbing a lamp on it.

Alchemy is used to intercept the calls not the game.
Edited by Spooony - 5/22/11 at 12:09am
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Sound Cards and Computer Audio
Overclock.net › Forums › Components › Sound Cards and Computer Audio › (Solved) Unable to turn on EAX effects in games