Overclock.net › Forums › Video Games › PC Gaming › How did you fix the BFBC2 crashing issue?
New Posts  All Forums:Forum Nav:

How did you fix the BFBC2 crashing issue?

post #1 of 86
Thread Starter 
If you are not aware of this problem, or if you have not experienced this problem, please do not post in this thread. Thank you.

The issue is no longer a conflict between a GPU monitoring utility and Punkbuster. Now it's something in addition to that.

With Punkbuster + GPU monitoring utility, it would just freeze and require a hard reset. Now with just BFBC2 open with no GPU monitoring utility, it makes a continuous looping sound and crashes to the desktop.

I have reinstalled the game as well as updated PB to the latest version.

What I am asking is, several users have already fixed this problem but there is absolutely no information about what has been done to resolve the issue.

Potential resolutions I personally have done to try to circumvent the problem:
-Change audio bitrate to 48KHz (and everything in between)
-Disable onboard audio (Realtek drivers are not even installed)
-Update PB
-Update Trixx
-Reinstall BFBC2
-Update BFBC2
-Close all excess programs prior to running BFBC2
-Updating drivers (for everything in my system)
(Note that all of the above potential resolutions were done at stock speeds and volts)

If you have resolved the crashing issue, please just share with me (us) how you did it, because this is just ridiculous. I literally cannot have the game open for more than ~5 minutes without a sound looping crash to desktop.
post #2 of 86
Tried all of it, still hasn't fixed it. It still crashes randomly.
/hwaw
(20 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 3770k @ 4.3ghz 1.160v ASRock Z77 Extreme6 Gigabyte R9 290 Windforce Sapphire R9 290 
RAMHard DriveHard DriveHard Drive
2x4gb Samsung RAM @ 2000mhz 9-10-9-28 1.425v OCZ Vertex 4 Hitacho Deskstar Crucial M550 
CoolingCoolingCoolingOS
Corsair H80 (CPU) Thermalright Spitfire (GPU) Gelid Icy Vision (GPU) Windows 7 Ultimate 64-bit 
MonitorMonitorKeyboardPower
BENQ GW2450 Asus PB278Q Cooler Master Quickfire Rapid Seasonic 750w  
CaseMouseMouse Pad
Black Interior HAF 932 Roccat Kone  Artisan Hien Hard 
  hide details  
Reply
/hwaw
(20 items)
 
  
CPUMotherboardGraphicsGraphics
Intel Core i7 3770k @ 4.3ghz 1.160v ASRock Z77 Extreme6 Gigabyte R9 290 Windforce Sapphire R9 290 
RAMHard DriveHard DriveHard Drive
2x4gb Samsung RAM @ 2000mhz 9-10-9-28 1.425v OCZ Vertex 4 Hitacho Deskstar Crucial M550 
CoolingCoolingCoolingOS
Corsair H80 (CPU) Thermalright Spitfire (GPU) Gelid Icy Vision (GPU) Windows 7 Ultimate 64-bit 
MonitorMonitorKeyboardPower
BENQ GW2450 Asus PB278Q Cooler Master Quickfire Rapid Seasonic 750w  
CaseMouseMouse Pad
Black Interior HAF 932 Roccat Kone  Artisan Hien Hard 
  hide details  
Reply
post #3 of 86
Thread Starter 
Some OCNers report that the most recent PB update did it for them.
post #4 of 86
Take out your sound card, uninstall your sound card drivers and try playing it.


In my case I had EasyTune running, which caused it to bluescreen after 10 minutes.
Edited by OverTheBelow - 5/21/11 at 2:08am
Current i5 Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-760 (4.0ghz @ 1.28v) GIGABYTE P55-USB3 Asus GTX 770 DirectCU II OC 2GB 4GB DDR3 (XMS3 1600) 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 120gb + 2.5TB HDDs LG Noctua NH-D14 Windows 7 Home Premium x64 
MonitorKeyboardPowerCase
23" Acer X233H + 19" GNR Logitech G110 OCZ ModXStream Pro 700W Coolermaster 690 
MouseMouse Pad
Logitech G500 Razer Sphex 
  hide details  
Reply
Current i5 Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-760 (4.0ghz @ 1.28v) GIGABYTE P55-USB3 Asus GTX 770 DirectCU II OC 2GB 4GB DDR3 (XMS3 1600) 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 120gb + 2.5TB HDDs LG Noctua NH-D14 Windows 7 Home Premium x64 
MonitorKeyboardPowerCase
23" Acer X233H + 19" GNR Logitech G110 OCZ ModXStream Pro 700W Coolermaster 690 
MouseMouse Pad
Logitech G500 Razer Sphex 
  hide details  
Reply
post #5 of 86
Thread Starter 
No success...
post #6 of 86
Ahhh I had this. Fixed it recently. All I did was set my sound card to 48 kHz sample rate whereas I always used to use 192 kHz. Also, update your sound card drivers!

Sent from my HTC Desire HD using Tapatalk
    
CPUMotherboardGraphicsRAM
Intel Core i7-5820K Haswell-E Asus ROG Rampage V Extreme Intel X99 EVGA GeForce GTX 1080 FTW Corsair Vengeance Red LED 32GB (4x8GB) DDR4-300... 
Hard DriveHard DriveHard DriveCooling
Samsung 840 500GB SSD (SATA-6Gbps) Western Digital Black 1TB 64MB Cache HDD (SATA-... Western Digital Black 4TB 64MB Cache HDD (SATA-... NZXT Kraken X52 & 2x Corsair SP120 RGB 120mm Fa... 
CoolingCoolingCoolingOS
EVGA ACX 3.0 (Graphics Card) 4x Corsair SP120 RGB 120mm Case Fans IC Diamond 7 Carat Thermal Compound Microsoft Windows 10 Home 
MonitorKeyboardPowerCase
LG Flatron 34UM95-P 34" 3440x1440 21:9 IPS SteelSeries Apex 350 Low Profile RGB EVGA SuperNova G2 1000W Modular Corsair Crystal 570X RGB 
MouseMouse PadAudioAudio
Logitech G502 Proteus Core ModMyMachine SlamePad Aluminium Magnum Champagne Creative Labs Sound Blaster ZxR 2x Acoustic Energy Aego M 2.1 Speakers & 1 Cent... 
AudioOtherOtherOther
Beyerdynamic DT770 Pro 250Ohm Headphones (Dynam... Saitek X-55 Rhino HOTAS Logitech G27 Racing Steering Wheel HTC Vive 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-5820K Haswell-E Asus ROG Rampage V Extreme Intel X99 EVGA GeForce GTX 1080 FTW Corsair Vengeance Red LED 32GB (4x8GB) DDR4-300... 
Hard DriveHard DriveHard DriveCooling
Samsung 840 500GB SSD (SATA-6Gbps) Western Digital Black 1TB 64MB Cache HDD (SATA-... Western Digital Black 4TB 64MB Cache HDD (SATA-... NZXT Kraken X52 & 2x Corsair SP120 RGB 120mm Fa... 
CoolingCoolingCoolingOS
EVGA ACX 3.0 (Graphics Card) 4x Corsair SP120 RGB 120mm Case Fans IC Diamond 7 Carat Thermal Compound Microsoft Windows 10 Home 
MonitorKeyboardPowerCase
LG Flatron 34UM95-P 34" 3440x1440 21:9 IPS SteelSeries Apex 350 Low Profile RGB EVGA SuperNova G2 1000W Modular Corsair Crystal 570X RGB 
MouseMouse PadAudioAudio
Logitech G502 Proteus Core ModMyMachine SlamePad Aluminium Magnum Champagne Creative Labs Sound Blaster ZxR 2x Acoustic Energy Aego M 2.1 Speakers & 1 Cent... 
AudioOtherOtherOther
Beyerdynamic DT770 Pro 250Ohm Headphones (Dynam... Saitek X-55 Rhino HOTAS Logitech G27 Racing Steering Wheel HTC Vive 
  hide details  
Reply
post #7 of 86
Thread Starter 
Quote:
Originally Posted by Gib007 View Post
Ahhh I had this. Fixed it recently. All I did was set my sound card to 48 kHz sample rate whereas I always used to use 192 kHz. Also, update your sound card drivers!

Sent from my HTC Desire HD using Tapatalk
Read OP
post #8 of 86
Quote:
Originally Posted by kiwiasian View Post
Read OP
Oh right!
Couldn't be bothered on the bus with my hand moving around randomly. Ok, then I honestly have no suggestions, sorry!
That's what fixed it for me. It does certainly point to a sound issue, though, considering the kind of crash. May I suggest a good, clean format to your system?
i.e. Start fresh.
    
CPUMotherboardGraphicsRAM
Intel Core i7-5820K Haswell-E Asus ROG Rampage V Extreme Intel X99 EVGA GeForce GTX 1080 FTW Corsair Vengeance Red LED 32GB (4x8GB) DDR4-300... 
Hard DriveHard DriveHard DriveCooling
Samsung 840 500GB SSD (SATA-6Gbps) Western Digital Black 1TB 64MB Cache HDD (SATA-... Western Digital Black 4TB 64MB Cache HDD (SATA-... NZXT Kraken X52 & 2x Corsair SP120 RGB 120mm Fa... 
CoolingCoolingCoolingOS
EVGA ACX 3.0 (Graphics Card) 4x Corsair SP120 RGB 120mm Case Fans IC Diamond 7 Carat Thermal Compound Microsoft Windows 10 Home 
MonitorKeyboardPowerCase
LG Flatron 34UM95-P 34" 3440x1440 21:9 IPS SteelSeries Apex 350 Low Profile RGB EVGA SuperNova G2 1000W Modular Corsair Crystal 570X RGB 
MouseMouse PadAudioAudio
Logitech G502 Proteus Core ModMyMachine SlamePad Aluminium Magnum Champagne Creative Labs Sound Blaster ZxR 2x Acoustic Energy Aego M 2.1 Speakers & 1 Cent... 
AudioOtherOtherOther
Beyerdynamic DT770 Pro 250Ohm Headphones (Dynam... Saitek X-55 Rhino HOTAS Logitech G27 Racing Steering Wheel HTC Vive 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7-5820K Haswell-E Asus ROG Rampage V Extreme Intel X99 EVGA GeForce GTX 1080 FTW Corsair Vengeance Red LED 32GB (4x8GB) DDR4-300... 
Hard DriveHard DriveHard DriveCooling
Samsung 840 500GB SSD (SATA-6Gbps) Western Digital Black 1TB 64MB Cache HDD (SATA-... Western Digital Black 4TB 64MB Cache HDD (SATA-... NZXT Kraken X52 & 2x Corsair SP120 RGB 120mm Fa... 
CoolingCoolingCoolingOS
EVGA ACX 3.0 (Graphics Card) 4x Corsair SP120 RGB 120mm Case Fans IC Diamond 7 Carat Thermal Compound Microsoft Windows 10 Home 
MonitorKeyboardPowerCase
LG Flatron 34UM95-P 34" 3440x1440 21:9 IPS SteelSeries Apex 350 Low Profile RGB EVGA SuperNova G2 1000W Modular Corsair Crystal 570X RGB 
MouseMouse PadAudioAudio
Logitech G502 Proteus Core ModMyMachine SlamePad Aluminium Magnum Champagne Creative Labs Sound Blaster ZxR 2x Acoustic Energy Aego M 2.1 Speakers & 1 Cent... 
AudioOtherOtherOther
Beyerdynamic DT770 Pro 250Ohm Headphones (Dynam... Saitek X-55 Rhino HOTAS Logitech G27 Racing Steering Wheel HTC Vive 
  hide details  
Reply
post #9 of 86
Thread Starter 
Quote:
Originally Posted by Gib007 View Post
Oh right!
Couldn't be bothered on the bus with my hand moving around randomly. Ok, then I honestly have no suggestions, sorry!
That's what fixed it for me. It does certainly point to a sound issue, though, considering the kind of crash. May I suggest a good, clean format to your system?
i.e. Start fresh.
I want to reinstall Windows, but I don't want to take another 30 GB off the life of my SSD

I guess I will sometime.

Actually you know what I am going to completely disable all sound on my system (incl. onboard, sound card, AMD HDMI sound) and see if it still crashes.
post #10 of 86
Well, this is weird.
You have this problem waay more than it happens to me. I get this every now and then.. As in, maybe once a day or a couple of days. Sometimes it would stop in an endless loop of sound for a second or two and then crash to desktop, sometimes it would just completely stop with the image still on the screen and then crash to desktop after a few seconds ... or sometimes it would instantly crash to desktop.
What I do get more ofter however, is the regular stalls... as in the game would stall for a second or less (mostly) and get this loop of sound and then everythings back to normal and I can continue playing.

PS: if it helps, I'm always playing with Afterburner running with the OSD and Fraps running for the occasional recording.

Another issue I'm having is that every time I log in I have to re enter my password otherwise it wont.
Animal Mother
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 2600k 4.5Ghz 1.368v  Gigabyte Z68X UD3H B3 ver. 1.3 MSI GTX 780 Ti Twin Frozr IV @ 1180Mhz 16GB Kingston Hyperx Savage 1600Mhz 9.9.9.27 1.5v 
Hard DriveCoolingOSMonitor
Kingston UV400 240GB SSD, WD 3x640GB, 1TB & 3TB  Noctua NHU12P SE2 w/ KAZE 1200RPM & 1800RPM Windows 10 x64 Samsung P2450H 24" 
KeyboardPowerCaseMouse
Redragon Karuna Corsair TX750W V2 Cooler Master 690 II Advanced Redragon Pegasus 
Mouse PadAudio
SteelSeries QcK XFi Gamer Fatality Pro + Plantronics Gamecom 777 
  hide details  
Reply
Animal Mother
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 2600k 4.5Ghz 1.368v  Gigabyte Z68X UD3H B3 ver. 1.3 MSI GTX 780 Ti Twin Frozr IV @ 1180Mhz 16GB Kingston Hyperx Savage 1600Mhz 9.9.9.27 1.5v 
Hard DriveCoolingOSMonitor
Kingston UV400 240GB SSD, WD 3x640GB, 1TB & 3TB  Noctua NHU12P SE2 w/ KAZE 1200RPM & 1800RPM Windows 10 x64 Samsung P2450H 24" 
KeyboardPowerCaseMouse
Redragon Karuna Corsair TX750W V2 Cooler Master 690 II Advanced Redragon Pegasus 
Mouse PadAudio
SteelSeries QcK XFi Gamer Fatality Pro + Plantronics Gamecom 777 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › How did you fix the BFBC2 crashing issue?