Overclock.net › Forums › Graphics Cards › AMD/ATI › issue w/ directx 11
New Posts  All Forums:Forum Nav:

issue w/ directx 11

post #1 of 8
Thread Starter 
Hi guys, i'm at a loss for what to do. I play world of wacraft and i have been emailing a gm back and forth for about 4 days to fix my problem but none of his solutions helped. There is a directx 11 option in WoW that i was trying to use but everytime i enabled it in game it was not working. The game would load up like it's in a restricted window. If i was to minimize and come back into the game the graphics would be horrible, i was barely able to read text.I don't have any other Dx11 games so i can't check those...

He came to the conclusion after i showed him my msifo files that something is wrong w/ my system setup or my graphics card.

The card i'm running is in my system info. Is there any tests or something i can run to see if my card is running appropriately. Also maybe someone can show me where to get all the necessary updates for my card. even though i'm running new 11.5a hotfix drivers . ( my OS is W7 ultimate 64bit)
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
post #2 of 8
Try downloading MSi Kombustor and running that in DX11 just to see if its a DX11 problem or the card.
    
CPUMotherboardGraphicsRAM
Xeon w3680 Gigabyte X58A-UD3R GTX 295 Engineering Samples 2X Corsair XMS3 
Hard DriveHard DriveCoolingOS
Sandisk SSD Seagate Corsair H50 W7 Ult 
MonitorMonitorKeyboardCase
Viewsonic VA1912wb Viewsonic VA912b K350 CM HAF 
Mouse
Logitech M570 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Xeon w3680 Gigabyte X58A-UD3R GTX 295 Engineering Samples 2X Corsair XMS3 
Hard DriveHard DriveCoolingOS
Sandisk SSD Seagate Corsair H50 W7 Ult 
MonitorMonitorKeyboardCase
Viewsonic VA1912wb Viewsonic VA912b K350 CM HAF 
Mouse
Logitech M570 
  hide details  
Reply
post #3 of 8
You definitely have something wrong

I can play WoW on max settings using DX11 with my sig rig's card

Try rolling back one driver version?
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x2 560BE (unlocked to Phenom II x4 B60) Biostar TA890FXE Radeon HD5670 4GB (2x2GB) Kingston HyperX Blu 1600mhz DDR3 
Hard DriveHard DriveOptical DriveCooling
64GB Crucial C300 SSD Hitachi HDD LG 24x Blu-Ray/DVD-DL Reader/Writer Cooler Master Hyper 212+ 
OSMonitorKeyboardPower
Windows 7 x64 Ultimate Edition Gateway FPD1730 Logitech G11 OCZ 600w Mod Xstream-Pro 
MouseAudio
Logitech M-UV69 Soundblaster Audigy 2 ZS Platinum Pro 
  hide details  
Reply
My System
(16 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II x2 560BE (unlocked to Phenom II x4 B60) Biostar TA890FXE Radeon HD5670 4GB (2x2GB) Kingston HyperX Blu 1600mhz DDR3 
Hard DriveHard DriveOptical DriveCooling
64GB Crucial C300 SSD Hitachi HDD LG 24x Blu-Ray/DVD-DL Reader/Writer Cooler Master Hyper 212+ 
OSMonitorKeyboardPower
Windows 7 x64 Ultimate Edition Gateway FPD1730 Logitech G11 OCZ 600w Mod Xstream-Pro 
MouseAudio
Logitech M-UV69 Soundblaster Audigy 2 ZS Platinum Pro 
  hide details  
Reply
post #4 of 8
Thread Starter 
Quote:
Originally Posted by MR KROGOTH;13585371 
Try downloading MSi Kombustor and running that in DX11 just to see if its a DX11 problem or the card.

well i tried downloading kombustor. After the installation. I opened the program. but i got a system error: The program can't start because D3DCompiler_42.dll is missing from your computer. Try reinstalling the program to fix this problem. I tried reinstalling, same error. (i wish things would just work like they should for me lol)
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
post #5 of 8
Had the same problem and sometimes it goes back to that problem... I added the -dx11 thing at the end of the shortcut. Also edited my config file. If you haven't tried those I'm not sure what to tell you frown.gif

I can tell when it jumps off of DX11 when all of the graphics look fuzzy for me. I haven't had any issues with other games including ones like Metro 2033 with DX11. The fix for me is I just open up the config file and look to see if it's still in there. Save it. Then check my shortcut to see if the -dx11 is still at the end. Takes me a couple of times for it to actually kick in DX11 mode.

How are your fps in WoW? Mine seem like they should be more. I get around 30-40 in org on spinebreaker. Everything is turned on ultra except for shadows.
White Devil
(13 items)
 
  
CPUMotherboardGraphicsRAM
6700k Asus Z170-A EVGA 980 Ti Hybrid Corsair Vengence 
Hard DriveCoolingOSMonitor
Crucial M550 Kraken X61 Win10 Acer 24'' 
KeyboardPowerCaseMouse
Dell Corsair HX850i Corsair 760T Logitec 
Mouse Pad
SteelSeries 
  hide details  
Reply
White Devil
(13 items)
 
  
CPUMotherboardGraphicsRAM
6700k Asus Z170-A EVGA 980 Ti Hybrid Corsair Vengence 
Hard DriveCoolingOSMonitor
Crucial M550 Kraken X61 Win10 Acer 24'' 
KeyboardPowerCaseMouse
Dell Corsair HX850i Corsair 760T Logitec 
Mouse Pad
SteelSeries 
  hide details  
Reply
post #6 of 8
Thread Starter 
Quote:
Originally Posted by NeRoToXeN;13585502 
Had the same problem and sometimes it goes back to that problem... I added the -dx11 thing at the end of the shortcut. Also edited my config file. If you haven't tried those I'm not sure what to tell you frown.gif

I can tell when it jumps off of DX11 when all of the graphics look fuzzy for me. I haven't had any issues with other games including ones like Metro 2033 with DX11. The fix for me is I just open up the config file and look to see if it's still in there. Save it. Then check my shortcut to see if the -dx11 is still at the end. Takes me a couple of times for it to actually kick in DX11 mode.

How are your fps in WoW? Mine seem like they should be more. I get around 30-40 in org on spinebreaker. Everything is turned on ultra except for shadows.

I have everything pushed up to the max. i have 16x multisampling. i'm usually maxing out at vertical sync 60fps. If i'm in org it's 30-60. This is w/o directx 11 working..... cause i can't play it in direct 11 at all. Something makes me think that i am playing in Dx11 w/o it saying because i can see water reflections of buildings and such which i heard dx9 doesn't render.
Edited by Cynder - 5/21/11 at 10:17am
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
post #7 of 8
Thread Starter 
Quote:
Originally Posted by MR KROGOTH;13585371 
Try downloading MSi Kombustor and running that in DX11 just to see if its a DX11 problem or the card.

downloaded DX SDK fixed the missing file. What do i do w/ Kombustor to determine if it's Dx11 or the card?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II x6 1100T 4.3Ghz Asus Cross hair IV 2x Sapphire HD Radeon 6970 2gb 16 GB 1866 Corsair Vengeance 
Hard DriveMonitorKeyboardPower
OCZ Agility SSD 128gb 27 inch Yamakasi Catleap Razer Black Widow Ultimate Antec 1200Watt 
CaseMouseMouse Pad
NZXT Phantom Razer Naga Razer Goliathus 
  hide details  
Reply
post #8 of 8
Try to see if it will will run it.
    
CPUMotherboardGraphicsRAM
Xeon w3680 Gigabyte X58A-UD3R GTX 295 Engineering Samples 2X Corsair XMS3 
Hard DriveHard DriveCoolingOS
Sandisk SSD Seagate Corsair H50 W7 Ult 
MonitorMonitorKeyboardCase
Viewsonic VA1912wb Viewsonic VA912b K350 CM HAF 
Mouse
Logitech M570 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Xeon w3680 Gigabyte X58A-UD3R GTX 295 Engineering Samples 2X Corsair XMS3 
Hard DriveHard DriveCoolingOS
Sandisk SSD Seagate Corsair H50 W7 Ult 
MonitorMonitorKeyboardCase
Viewsonic VA1912wb Viewsonic VA912b K350 CM HAF 
Mouse
Logitech M570 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › issue w/ directx 11