Overclock.net › Forums › Components › Power Supplies › BFG EX 1000 and GTX 580 SLI
New Posts  All Forums:Forum Nav:

BFG EX 1000 and GTX 580 SLI

post #1 of 17
Thread Starter 
Ive had this BFG EX 1000 for about a year now. It Ran GTX 460 SLI and GTX 580 good solid performance for in till about 3 months ago i start to notice some sluggish performance with high FPS and other kinds of stuttering. Ive done every kind of trick in the book (Vsync, higher OCs, disable core parking, Re Install windows 7, try every driver, different sli rendering modes you name it! ) but replace the PSU.

I also went ahead and bought another gtx 580 to sli a month ago but still getting the same kind of effect. my gpu usage is about 99% in benchmarks and then usage goes everywhere in games like cods, crysis 2 and bfbc2 and so on.

I was wondering if this Would be a good PSU "New Power Supply" Be more then enough to run everything in my set up plus maybe bulldozer or sandy bridge down the line ?

Do you think this might solve my problem. I also bought another monitor too, I thought it might been some ghosting but this did not help.

This is driving my crazy

Thank you

No ideas or suggestion are stupid
Edited by Fallendreams - 5/22/11 at 10:57pm
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
post #2 of 17
I have this psu actually in my sig rig and been using it for about a year now with no problems like this. I would say no but it could be if i were you i would try everything possible before i replaced it. I am currently running 3 gtx 580s in tri sli also with it with no such problems.
post #3 of 17
Thread Starter 
Quote:
Originally Posted by Rucka315 View Post
I have this psu actually in my sig rig and been using it for about a year now with no problems like this. I would say no but it could be if i were you i would try everything possible before i replaced it. I am currently running 3 gtx 580s in tri sli also with it with no such problems.

i see people say this and then i see people talking about "ripple Problems in BFG EX 1000" not recommending this psu for today age set ups

Yeah i don't under stand where my problem is coming from. Cant be bottleneck. I wont find this out in till next month when i buy a new cpu and mobo .

I rather buy a psu now then wait.
Edited by Fallendreams - 5/22/11 at 10:33pm
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
post #4 of 17
Whats happening in detail with your comp?
post #5 of 17
Thread Starter 
Quote:
Originally Posted by Rucka315 View Post
Whats happening in detail with your comp?
As far as what ? My problem or upgrade.
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
post #6 of 17
Yea the problem with your comp when your using it.
post #7 of 17
Thread Starter 
Quote:
Originally Posted by Rucka315 View Post
Yea the problem with your comp when your using it.
its like i get massive stuttering and it just feels so sluggish. Fps are high but It hurts my eyes when Im play black ops, bfbc2, and cod4. Ive never had this problem in till 3 months ago for some reason. Ive tried bunch of console commands too within the game and config changes. Also i thought might have been the sound card but my cousin has almost the same exact set up as me and does not experience this problem at all.

( i do notice this in black ops though and i don't under stand. In black ops the Fps counter in the game will show white fps and then it will go red for about 1-2 secs.)
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
post #8 of 17
Have you tried reinstalling windows? It might suck but if it works then you will know you had a major issue with drivers or your registry. If my comp ever feels sluggish or something feels out of place and i just cannot find a fix i reinstall.
post #9 of 17
Thread Starter 
Quote:
Originally Posted by Rucka315 View Post
Have you tried reinstalling windows? It might suck but if it works then you will know you had a major issue with drivers or your registry. If my comp ever feels sluggish or something feels out of place and i just cannot find a fix i reinstall.
Yeah i did this twice already. Tried 2 different Hard Drives. I'm just hoping that maybe my PSU might be bad and new one is what i need. It sucks working all day and other crap. Come home to just relax and i cant because my Computer isn't running right.

Edit: +1 Rep for each post man.
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
Haswell-E
(15 items)
 
  
CPUMotherboardGraphicsRAM
I7 5960X ASUS Sabertooth X99 GTX TITAN X SLI Corsair Veneance LPX 16GB (4x4GB) DDR4 
Hard DriveHard DriveCoolingOS
Intel 750 400GB Samsung 850 Evo Pro 1TB EK EVO WaterBlock / EK Titan X WaterBlock / XSP... Windows 10 Pro x64 
MonitorMonitorKeyboardPower
Acer x34 GSYNC 100hz ASUS PG278Q 1440p 144hz Corsair Strafe  EVGA 850 WATT 
CaseMouse
Corsair 750D  Razer DeathAdder Chroma  
  hide details  
Reply
post #10 of 17
Have you tried running just one video card at a time and see if it occurs?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › BFG EX 1000 and GTX 580 SLI