Overclock.net › Forums › Video Games › PC Gaming › Loading time for Bad Company 2
New Posts  All Forums:Forum Nav:

Loading time for Bad Company 2

post #1 of 30
Thread Starter 
So I am getting annoyed from this problem.
When I find a server and loads the map everything goes smooth until its finished loading. I see the map, in about 3 second the game freezes/hangs for 15-20 seconds. And then all goes smooth again... It wasn't like this before.
Things I have tried to solve this issue:
  • Downgrading the BIOS
  • Downgrading the graphics card driver
  • Overclocking the CPU
  • Moving my graphics card into another pci 16x slot
  • Tweaking catalyst
  • Reinstalling windows 7
  • Uninstalling AVAST

Somebody got this issue?
Edited by HenrikMeister - 5/24/11 at 9:05am
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
post #2 of 30
Quote:
Originally Posted by HenrikMeister View Post
So I am getting annoyed from this problem.
When I find a server and loads the map everything goes smooth until its finished loading. I see the map, in about 3 second the game freezes/hangs for 15-20 seconds. And then all goes smooth again... It wasn't like this before.
Things I have tried to solve this issue:
  • Downgrading the BIOS
  • Downgrading the graphics card driver
  • Overclocking the CPU
  • Moving my graphics card into another pci 16x slot
  • Tweaking catalyst

Somebody got this issue?
I'm literally having the same issue, but it last for 3-5 seconds IF i don't touch the mouse or press any keys during the phenomena. If i do press anything, it might last longer or the game will just freeze and il have to restart the game.
No idea what causes it, people claim its punkbuster.
What
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7-6950X X99 Deluxe ASUS GTX Titan Black 32GB @ 3200 
Hard DriveOSMonitorKeyboard
Samsung 960 Pro Windows 10 Pro x64 Dell UltraSharp U3014 Microsoft SideWinder X4 
PowerCaseMouseAudio
Corsair AX860 NZXT Switch 810 Mionix Castor Asus Xonar STX + 2x LME49860NA OPs + HD650s 
  hide details  
Reply
What
(12 items)
 
  
CPUMotherboardGraphicsRAM
i7-6950X X99 Deluxe ASUS GTX Titan Black 32GB @ 3200 
Hard DriveOSMonitorKeyboard
Samsung 960 Pro Windows 10 Pro x64 Dell UltraSharp U3014 Microsoft SideWinder X4 
PowerCaseMouseAudio
Corsair AX860 NZXT Switch 810 Mionix Castor Asus Xonar STX + 2x LME49860NA OPs + HD650s 
  hide details  
Reply
post #3 of 30
I too have the same issue but i thought it was due to my Crossfire eyefinity setup, i do notice that when i go to one screen 1920x1080 it doesnt do that but i cant play at reg reso. anymore............ i will stay tuned to this thread and hopefully we will find an answer........

btw same thing for me too if i leave the mouse alone it will go though alot quicker......
 
money$ $y$tem
(14 items)
 
CPUMotherboardGraphicsRAM
Q9550 (E0) @ 4.2ghz (1.360) Gigabyte EP45-UD3P 7970 oc windforce, 6870CF, 4870CF an Eyefinity Corsair dominator4gb new GSkill 4gb @ oced 1158mhz 
Hard DriveOSMonitorKeyboard
Intel X25-V SSD&WD 640gb cav black, 750gb cav blk Windows 7 home premium 64bit Dell 23"LCD 2xBenQs 21.5"LED Eyefinity Razer Black Widow Mech. and Logitech illuminated 
PowerCaseMouseMouse Pad
Corsair AX750w Gold before was Ocz gameXtream 850w Silverstone Raven 2 new NZXT Phantom (white) Logitech G 500 steelseries 
Audio
7.2 setup with Z-2300 
  hide details  
Reply
 
money$ $y$tem
(14 items)
 
CPUMotherboardGraphicsRAM
Q9550 (E0) @ 4.2ghz (1.360) Gigabyte EP45-UD3P 7970 oc windforce, 6870CF, 4870CF an Eyefinity Corsair dominator4gb new GSkill 4gb @ oced 1158mhz 
Hard DriveOSMonitorKeyboard
Intel X25-V SSD&WD 640gb cav black, 750gb cav blk Windows 7 home premium 64bit Dell 23"LCD 2xBenQs 21.5"LED Eyefinity Razer Black Widow Mech. and Logitech illuminated 
PowerCaseMouseMouse Pad
Corsair AX750w Gold before was Ocz gameXtream 850w Silverstone Raven 2 new NZXT Phantom (white) Logitech G 500 steelseries 
Audio
7.2 setup with Z-2300 
  hide details  
Reply
post #4 of 30
Weird I dont have this problem... well maybe i do... im gunna check hold on

UPDATE: No I dont have this problem... on another note though, Im in the OCN SD server if anyone wants to join me
Edited by kill - 5/24/11 at 8:28am
Streamer/Gamer
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-5820K Asus X99-A Sapphire R9-290 Crucial Ballistics Sport 16gb 2400mhz 
Hard DriveHard DriveCoolingOS
OCZ Agility 3 60gb Seagate 1TB Corsair H100  Windows 10 64-bit 
MonitorKeyboardPowerCase
3x 22" 1080 monitors Logitech G510 Corsair HX620 Nzxt Switch 810 
MouseMouse PadAudio
Logitech G402 Steel series QCK cloth Logitech G930 headset 
  hide details  
Reply
Streamer/Gamer
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7-5820K Asus X99-A Sapphire R9-290 Crucial Ballistics Sport 16gb 2400mhz 
Hard DriveHard DriveCoolingOS
OCZ Agility 3 60gb Seagate 1TB Corsair H100  Windows 10 64-bit 
MonitorKeyboardPowerCase
3x 22" 1080 monitors Logitech G510 Corsair HX620 Nzxt Switch 810 
MouseMouse PadAudio
Logitech G402 Steel series QCK cloth Logitech G930 headset 
  hide details  
Reply
post #5 of 30
Thread Starter 
Hmm, when I play with my friend he tells me that I have 999 ping while loading. Maybe its a network issue?
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
post #6 of 30
Thread Starter 
And I tried reinstalling windows 7 (64-bit) but no chance...
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
post #7 of 30
Sounds like a network problem to me. Either yours or theirs or punkbuster's like someone else mentioned.
post #8 of 30
All 3 of you guys with the problem in this thread are using ATI HD6 series cards. kill, Strat79 and I do not have this problem and we are using nvidia cards.

Coincidence?
post #9 of 30
I'd say this could sound like an anti virus issue. Try making an exception for BFBC2 in your documents folder. It's just a random guess, but lots of people get freezes when starting a map because of their AV.
M1XN
(18 items)
 
Study Zenbook
(5 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770K @ 4.2 GHz ASUS Maximus VI Impact MSI GTX 970 Gaming 4G 2x8 GB Kingston HyperX DDR3 @ 2400 MHz 
Hard DriveHard DriveHard DriveOptical Drive
Crucial M4 64 GB Crucial M4 128 GB SAMSUNG Spinpoint M9T 2 TB LiteOn DL-8ATSH 
CoolingOSMonitorKeyboard
Noctua NH-C14 Windows 10 64-bit ViewSonic VP2770 Vortex Pok3r 
PowerCaseMouseMouse Pad
Corsair SF600 NCASE M1 V2.5 Logitech G502 SteelSeries QcK+ 
AudioOther
HiFiMan HE-400 Logitech C920 
CPUGraphicsRAMHard Drive
i5-3317 GT 620M 2 GB soldered + 8 GB Corsair OCZ Vertex 3 120 
OS
Windows 7 Home Premium 64-bit 
  hide details  
Reply
M1XN
(18 items)
 
Study Zenbook
(5 items)
 
 
CPUMotherboardGraphicsRAM
i7 4770K @ 4.2 GHz ASUS Maximus VI Impact MSI GTX 970 Gaming 4G 2x8 GB Kingston HyperX DDR3 @ 2400 MHz 
Hard DriveHard DriveHard DriveOptical Drive
Crucial M4 64 GB Crucial M4 128 GB SAMSUNG Spinpoint M9T 2 TB LiteOn DL-8ATSH 
CoolingOSMonitorKeyboard
Noctua NH-C14 Windows 10 64-bit ViewSonic VP2770 Vortex Pok3r 
PowerCaseMouseMouse Pad
Corsair SF600 NCASE M1 V2.5 Logitech G502 SteelSeries QcK+ 
AudioOther
HiFiMan HE-400 Logitech C920 
CPUGraphicsRAMHard Drive
i5-3317 GT 620M 2 GB soldered + 8 GB Corsair OCZ Vertex 3 120 
OS
Windows 7 Home Premium 64-bit 
  hide details  
Reply
post #10 of 30
Thread Starter 
Quote:
Originally Posted by B!0HaZard View Post
I'd say this could sound like an anti virus issue. Try making an exception for BFBC2 in your documents folder. It's just a random guess, but lots of people get freezes when starting a map because of their AV.
I have also tried uninstallig AVAST, then started the game...Still the same. Then I installed bitdefender, still...
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
R&B
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X6 1090T Black Edition ASUS Crosshair IV Formula XFX RADEON HD6870 Corsair XMS3 DDR3 1333MHz 6GB 
Hard DriveOptical DriveOSMonitor
Western Digital 680 GB Sony Optical Drive Windows 7 Ultimate 64 Bit SAMSUNG SyncMaster 245B 
KeyboardPowerCaseMouse
A keyboard from 2001 XFX CORE EDITION 750W Cooler Master HAF 912 Plus Moded Logitech School Mouse 
Mouse Pad
My Table 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Loading time for Bad Company 2