Overclock.net › Forums › Video Games › PC Gaming › The Witcher 2 High settings problem
New Posts  All Forums:Forum Nav:

The Witcher 2 High settings problem

post #1 of 18
Thread Starter 
With my sig rig I get around 23-25 FPS at High settings and 1920x1200. Also the autodetect best settings finds my computer as medium spec. Is it medium?
I'm using last 11.5 Catalyst Drivers and fresh Windows install.
I saw guys with similar hardware configurations scoring well over 40 FPS.
So where is my problem?
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
post #2 of 18
Quote:
Originally Posted by ramthor View Post
With my sig rig I get around 23-25 FPS at High settings and 1920x1200. Also the autodetect best settings finds my computer as medium spec. Is it medium?
I'm using last 11.5 Catalyst Drivers and fresh Windows install.
I saw guys with similar hardware configurations scoring well over 40 FPS.
So where is my problem?
Overclock your cpu to 4.0. Overclock your 6950 to the max and unlock to a 6970 if you can. Set everything to ultra and turn off ubersampling, bloom, motion blur and vsync. You will be happy
OG TRIPPLE OG
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8GHz Asus Maximus IV Extreme  evga gtx 680 16GB Gskill Ripjaws ddr3 2133 
Hard DriveOptical DriveCoolingOS
Crucial RealSSD C300 128gb LIght On Blue Ray Burner h100 Windows 7 64bit 
MonitorKeyboardPowerCase
Samsung SyncMaster 305T 30 inch LCD Microsoft Sidewinder x4 Ultra x3 1000 watt Azza Solano Red 
MouseAudioAudio
Razor Deathadder Asus Xonar Dx Logitech z 5300 
  hide details  
Reply
OG TRIPPLE OG
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8GHz Asus Maximus IV Extreme  evga gtx 680 16GB Gskill Ripjaws ddr3 2133 
Hard DriveOptical DriveCoolingOS
Crucial RealSSD C300 128gb LIght On Blue Ray Burner h100 Windows 7 64bit 
MonitorKeyboardPowerCase
Samsung SyncMaster 305T 30 inch LCD Microsoft Sidewinder x4 Ultra x3 1000 watt Azza Solano Red 
MouseAudioAudio
Razor Deathadder Asus Xonar Dx Logitech z 5300 
  hide details  
Reply
post #3 of 18
Thread Starter 
I cant overclock CPU any more until I purchase a better cooling and RAM.
But I tried and managed to unlock the GPU with 6970 BIOS and to OC it to 930MHz core with 1400MHz memory.
With this I gained about 2000 more points in 3DMark Vantage: P21582 3DMarks
Getting back to the game lead me to dissapointment once again. No visible raise in my FPS. I lowered the settings to medium and I get the same FPS as high settings. Lowering even more to low settings it's the same FPS.
Something must be wrong here.
I tried to reinstall DirectX, install latest Catalyst 11.5b Hotfix and still nothing.
One more strange thing is when I launch PerformanceTester.exe it sais I have 736MB of video memory and "Your configuration capabilitys: PC_Medium", when my actual video memory is 2GB.
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
post #4 of 18
How much VRAM does GPU-Z say you have?

Could be your processor limiting it. My friend's graphics card often doesn't reach 100% usage despite the framerate dropping, leaving it down to the CPU as the bottleneck. His isn't overclocked.
Current i5 Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-760 (4.0ghz @ 1.28v) GIGABYTE P55-USB3 Asus GTX 770 DirectCU II OC 2GB 4GB DDR3 (XMS3 1600) 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 120gb + 2.5TB HDDs LG Noctua NH-D14 Windows 7 Home Premium x64 
MonitorKeyboardPowerCase
23" Acer X233H + 19" GNR Logitech G110 OCZ ModXStream Pro 700W Coolermaster 690 
MouseMouse Pad
Logitech G500 Razer Sphex 
  hide details  
Reply
Current i5 Rig
(14 items)
 
  
CPUMotherboardGraphicsRAM
Core i5-760 (4.0ghz @ 1.28v) GIGABYTE P55-USB3 Asus GTX 770 DirectCU II OC 2GB 4GB DDR3 (XMS3 1600) 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 120gb + 2.5TB HDDs LG Noctua NH-D14 Windows 7 Home Premium x64 
MonitorKeyboardPowerCase
23" Acer X233H + 19" GNR Logitech G110 OCZ ModXStream Pro 700W Coolermaster 690 
MouseMouse Pad
Logitech G500 Razer Sphex 
  hide details  
Reply
post #5 of 18
Thread Starter 
Quote:
Originally Posted by OverTheBelow View Post
How much VRAM does GPU-Z say you have?


Quote:
Could be your processor limiting it. My friend's graphics card often doesn't reach 100% usage despite the framerate dropping, leaving it down to the CPU as the bottleneck. His isn't overclocked.
I've monitored my CPU with Windows' Resource monitor (I'd like something better if you know one) and it never reaches over 30% load.
I've monitored my GPU with GPU-Z and the load is between 50-70%.
Why is that?
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
post #6 of 18
Do you have ubersampling on? That'll cut your fps roughly in third.
Jane
(11 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 Zotac H55ITX-C-E Sapphire 7850 4GB Corsair XMS 1333Mhz 
Hard DriveCoolingOSMonitor
Samsung F3 1TB Antec 620 Windows 7 Samsung BX2331 23" LED 
PowerCaseAudio
Silverstone 45SF 450W Silverstone SG05 Swan M10 
  hide details  
Reply
Jane
(11 items)
 
  
CPUMotherboardGraphicsRAM
i5 750 Zotac H55ITX-C-E Sapphire 7850 4GB Corsair XMS 1333Mhz 
Hard DriveCoolingOSMonitor
Samsung F3 1TB Antec 620 Windows 7 Samsung BX2331 23" LED 
PowerCaseAudio
Silverstone 45SF 450W Silverstone SG05 Swan M10 
  hide details  
Reply
post #7 of 18
Quote:
Originally Posted by a pet rock View Post
Do you have ubersampling on? That'll cut your fps roughly in third.
I'm pretty sure this is your problem.

I have the same graphics card and get more than double your fps.
space heater
(29 items)
 
S-HVH-01
(11 items)
 
PfSense
(5 items)
 
CPUMotherboardGraphicsRAM
Intel 2500k 4.7GHz  Asus P8P67 Pro(B3) 2 x Club3D 280X 3GB 16GB g.skill 1600MHz C9 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Pro 256GB 4 x 2TB Barracudas in RAID10 2 x WD Blue 1TB RAID0 2 x 3TB Seagate Barracuda 
Hard DriveHard DriveOptical DriveCooling
8 x 146GB HP 10k SAS - various RAID levels RAID Controller LSI 9260-8i 512MB LiteOn IHAS124 Noctua NH-D15 
OSMonitorMonitorMonitor
8.1 Enterprise Acer GD245HQ (120hz) LG W2420P LG IPS231P 
MonitorMonitorKeyboardPower
HP ZR24w LG 32LH3000 (w/IPS) Razer Blackwidow Antec TruePower New 750W 
CaseMouseAudioAudio
Corsair 750D Modified original G5 Asus Xonar PCIe Sennheiser HD595 
AudioAudioAudioAudio
Tannoy Mercury 5 NAD C165BEE Bowers & Wilkins 683 Cambridge Audio DACMagic+ 
CPUCPUMotherboardRAM
Intel® Xeon® Processor E5-2630 v3 (20M Cache, 2... Intel® Xeon® Processor E5-2630 v3 (20M Cache, 2... Lenovo RD650 128GB DDR4 ECC REG 
Hard DriveHard DriveHard DriveHard Drive
720ix 12Gbps SAS RAID Controller with 1GB FBWC RAID 0 - 2 x Intel S3500 120GB SSD (deduped VHD... Intel 530 120GB SSD RAID 10 - 8 x Seagate 146GB 10k SAS  
OSPowerCase
Windows Hyper-V Server 2012 R2 2 x LiteION 750W 80PLUS Platinum RD650 24x2.5" chassis 
CPURAMHard DriveOS
Intel® Xeon® Processor X5650  8GB ECC 2 x 146GB SCSI RAID1 PfSense 2.2b 
Other
Intel 4 x 1GbE 
  hide details  
Reply
space heater
(29 items)
 
S-HVH-01
(11 items)
 
PfSense
(5 items)
 
CPUMotherboardGraphicsRAM
Intel 2500k 4.7GHz  Asus P8P67 Pro(B3) 2 x Club3D 280X 3GB 16GB g.skill 1600MHz C9 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 Pro 256GB 4 x 2TB Barracudas in RAID10 2 x WD Blue 1TB RAID0 2 x 3TB Seagate Barracuda 
Hard DriveHard DriveOptical DriveCooling
8 x 146GB HP 10k SAS - various RAID levels RAID Controller LSI 9260-8i 512MB LiteOn IHAS124 Noctua NH-D15 
OSMonitorMonitorMonitor
8.1 Enterprise Acer GD245HQ (120hz) LG W2420P LG IPS231P 
MonitorMonitorKeyboardPower
HP ZR24w LG 32LH3000 (w/IPS) Razer Blackwidow Antec TruePower New 750W 
CaseMouseAudioAudio
Corsair 750D Modified original G5 Asus Xonar PCIe Sennheiser HD595 
AudioAudioAudioAudio
Tannoy Mercury 5 NAD C165BEE Bowers & Wilkins 683 Cambridge Audio DACMagic+ 
CPUCPUMotherboardRAM
Intel® Xeon® Processor E5-2630 v3 (20M Cache, 2... Intel® Xeon® Processor E5-2630 v3 (20M Cache, 2... Lenovo RD650 128GB DDR4 ECC REG 
Hard DriveHard DriveHard DriveHard Drive
720ix 12Gbps SAS RAID Controller with 1GB FBWC RAID 0 - 2 x Intel S3500 120GB SSD (deduped VHD... Intel 530 120GB SSD RAID 10 - 8 x Seagate 146GB 10k SAS  
OSPowerCase
Windows Hyper-V Server 2012 R2 2 x LiteION 750W 80PLUS Platinum RD650 24x2.5" chassis 
CPURAMHard DriveOS
Intel® Xeon® Processor X5650  8GB ECC 2 x 146GB SCSI RAID1 PfSense 2.2b 
Other
Intel 4 x 1GbE 
  hide details  
Reply
post #8 of 18
Thread Starter 
As I said before I have the same FPS with all pre-sets Low, Medium and High settings. Ubersampling is enabled on Ultra pre-set.
I didnt even try to enable uber. I am depressed enough like this.
All other games (Assassin's Creed Brootherhood, Fallout3: New Vegas) work very well. And 3DMark Vantage shows card is above average scores.
Edited by ramthor - 5/27/11 at 4:21am
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
post #9 of 18
Thread Starter 
Anyone has any ideea?
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
My rig
(13 items)
 
  
CPUMotherboardGraphicsRAM
QuadCore Intel Core i7 920, 3400 MHz (20 x 170) Asus P6T Deluxe V2 HD6950 2GB unlocked to 6970 (930/1400MHz) 6135 MB (DDR3-1333 DDR3 SDRAM) 
Hard DriveOSMonitorPower
WDC WD10EALX-009BA0 ATA Device (931 GB, IDE) Microsoft Windows 7 Ultimate x64 Samsung SyncMaster T240 Thermaltake 750W 
  hide details  
Reply
post #10 of 18
Is the 6950 a CrossFireX card?

If so then install the 11.5b hotfix. It enables CrossFireX for The Witcher 2.

I tried the game before applying the hotfix with CrossFireX enabled and the games framerate was terrible. Since I installed it the game is running perfectly fine.

Also have you installed the 1.1 patch?

If not then I have no idea how to help you, sorry.
Edited by Lifeshield - 5/28/11 at 2:56pm
War Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670k @ 3.4ghz Asus B85M Gamer MSI Twin Frozr V R9 390X 8gb Kingston Hyper X Beast 16gb 
Hard DriveCoolingCoolingOS
HGS 2.5" Sata 1tb Corsair H100i v2 4 x Corsair SP120 Quiet Windows 10 64bit 
MonitorKeyboardPowerCase
Benq RL2455 Microsoft Sidewinder X4 EVGA Supernova G2 750w Corsair Carbide Air 240 
MouseMouse PadAudio
Razer Naga Molten Edition Steel Series Guild Wars 2 Sennheiser HD201 
  hide details  
Reply
War Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670k @ 3.4ghz Asus B85M Gamer MSI Twin Frozr V R9 390X 8gb Kingston Hyper X Beast 16gb 
Hard DriveCoolingCoolingOS
HGS 2.5" Sata 1tb Corsair H100i v2 4 x Corsair SP120 Quiet Windows 10 64bit 
MonitorKeyboardPowerCase
Benq RL2455 Microsoft Sidewinder X4 EVGA Supernova G2 750w Corsair Carbide Air 240 
MouseMouse PadAudio
Razer Naga Molten Edition Steel Series Guild Wars 2 Sennheiser HD201 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › The Witcher 2 High settings problem