Overclock.net › Forums › Graphics Cards › NVIDIA › GeForce GTS 250 - No Display
New Posts  All Forums:Forum Nav:

GeForce GTS 250 - No Display

post #1 of 3
Thread Starter 
Hi All,

I just bought a new GTS 250 and I have installed it along with a new Corsair 650W PSU but I have no display.

I did everything right while installing:
- I grounded myself
- I removed old card
- Installed the GPS 250
- Attached PCI-e connectors to card
But I turn it on and still no display. I know the computer gets past BIOS because the screen on my keyboard comes on when XP has booted and it comes on.

I have tried the following to see if they are the problem:
-Reseated card
-Reseated RAM
-Cleared CMOS
-Removed old drivers

I tried the old card and it still works.

Is my new card a bad card or am I missing something out?
Thanks.
    
CPUMotherboardGraphicsRAM
Athlon II X4 3.0 GHz ASRock N68C-S UCC GeForce GTS 250 4GB DDR3 RAM 
Hard DriveKeyboardPower
1TB SATA Logitech G19 Corsair TX650 V2 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Athlon II X4 3.0 GHz ASRock N68C-S UCC GeForce GTS 250 4GB DDR3 RAM 
Hard DriveKeyboardPower
1TB SATA Logitech G19 Corsair TX650 V2 
  hide details  
Reply
post #2 of 3
Does the cards fan spin up?
post #3 of 3
Thread Starter 
Yes it does.
I have now found out that the DVI port works but the VGA does not.
I am currently connected through DVI.

Can you think why the VGA port is not working?
    
CPUMotherboardGraphicsRAM
Athlon II X4 3.0 GHz ASRock N68C-S UCC GeForce GTS 250 4GB DDR3 RAM 
Hard DriveKeyboardPower
1TB SATA Logitech G19 Corsair TX650 V2 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Athlon II X4 3.0 GHz ASRock N68C-S UCC GeForce GTS 250 4GB DDR3 RAM 
Hard DriveKeyboardPower
1TB SATA Logitech G19 Corsair TX650 V2 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › GeForce GTS 250 - No Display