Overclock.net › Forums › Graphics Cards › AMD/ATI › Crossfire XFX 5870 XXX Problems
New Posts  All Forums:Forum Nav:

Crossfire XFX 5870 XXX Problems

post #1 of 4
Thread Starter 
Hi guys,

I have recently gotten two XFX 5870 XXX edition cards. The problem is the card always crashes during games and I'm forced to restart. I've updated the BIOS to the newest 900/1250 one and it did not help. What I did find to help was raising fan speed and lowering clocks to 825/1225. Still, it's not working that great.

I wanted to know if I can use the XFX 5870 800/1200 BIOS on my cards. Please let me know if it's possible. I'd like to try this before doing any RMA or anything. Thanks!
post #2 of 4
I would do a complete wipe out and re install of drivers before messing with the bios on the hardware.

Probably even to the point of fresh windows install
Poison
(13 items)
 
  
CPUMotherboardGraphicsRAM
3820 @ 4.7 Sabertooth x79 Powercolor 6870x2 G Skill 2133 8gb 
Hard DriveCoolingOSMonitor
Crucial m4 Noctua DH14 win7 64 ultimate HP 2511x 
KeyboardPowerMouseMouse Pad
microsoft Sidewinder Enermax Modu 87+ 900 Asus GX800 none 
Audio
Yamaha RX-V955, B&W bookshelves and Infinity PS-8 
  hide details  
Reply
Poison
(13 items)
 
  
CPUMotherboardGraphicsRAM
3820 @ 4.7 Sabertooth x79 Powercolor 6870x2 G Skill 2133 8gb 
Hard DriveCoolingOSMonitor
Crucial m4 Noctua DH14 win7 64 ultimate HP 2511x 
KeyboardPowerMouseMouse Pad
microsoft Sidewinder Enermax Modu 87+ 900 Asus GX800 none 
Audio
Yamaha RX-V955, B&W bookshelves and Infinity PS-8 
  hide details  
Reply
post #3 of 4
a gpu bios wont fix the issue more like a driver issue

if all fails try a fresh OS install
Gaming Rig
(13 items)
 
  
CPUMotherboardRAMOS
4790k @ 4.8GHZ z97 sabretooth mark s 290 Win 7 64bit 
KeyboardMouse
Saitek Saitek 
  hide details  
Reply
Gaming Rig
(13 items)
 
  
CPUMotherboardRAMOS
4790k @ 4.8GHZ z97 sabretooth mark s 290 Win 7 64bit 
KeyboardMouse
Saitek Saitek 
  hide details  
Reply
post #4 of 4
Test them individually. This happened on an XFX 5850 of mine and I tried everything to fix it, including reinstalling drivers, OS, reseating the card, checking cables, etc. They had me RMA it. But, check and see which card is doing this and try to single that out so you can work with it before RMAing it. Also, if you still can, RMA to where you bought it from (Newegg perhaps?) as XFX will send you a refurbished card, not necessarily XXX edition. the card I recieved from them was a stripped down 5850 with a tiny heatsink/fan unit, where I paid extra for a better one.
Wings
(9 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600k Gigabyte Z68X-UD3H MSI N560-GTX-Ti-Hawk Corsair Vengeance 
Hard DriveCoolingOSPower
Samsung F4 Corsair H100 Windows 7 Ultimate x64 Corsair AX850 
Case
Corsair Obsidian 650D 
  hide details  
Reply
Wings
(9 items)
 
  
CPUMotherboardGraphicsRAM
Core i7 2600k Gigabyte Z68X-UD3H MSI N560-GTX-Ti-Hawk Corsair Vengeance 
Hard DriveCoolingOSPower
Samsung F4 Corsair H100 Windows 7 Ultimate x64 Corsair AX850 
Case
Corsair Obsidian 650D 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD/ATI
Overclock.net › Forums › Graphics Cards › AMD/ATI › Crossfire XFX 5870 XXX Problems