Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Computer crashed while playing Witcher 2 and now ahci mode doesn't work.
New Posts  All Forums:Forum Nav:

Computer crashed while playing Witcher 2 and now ahci mode doesn't work.

post #1 of 9
Thread Starter 
So my computer crashed while playing and when I rebooted the entire hard drive it was corrupted (or at least a good chunk of it was) and I had to reformat and reinstall windows.

Now I reinstalled in IDE mode but whenever I switch to AHCI mode I get a BSOD. Don't have the error, I'll get it when I get home but has anyone experience anything similar?
Edited by Dooginater - 5/30/11 at 4:51pm
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
post #2 of 9
AHCI? When you switch the SATA operation to something other than what it already is, a warning usually pops up saying you may need to reinstall your OS because of the switch. I'm guessing your SSD is your OS drive. They use AHCI preferably.
BlueRaven
(13 items)
 
Dead BIOS
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 G74Sx NVIDIA GeForce GTX 560M  Samsung  
RAMRAMHard DriveHard Drive
Samsung  Samsung  Momentus 7200.4 Scorpio Blue 
Mouse
Logitech G700 
  hide details  
Reply
BlueRaven
(13 items)
 
Dead BIOS
(9 items)
 
 
CPUMotherboardGraphicsRAM
Intel Core i7 G74Sx NVIDIA GeForce GTX 560M  Samsung  
RAMRAMHard DriveHard Drive
Samsung  Samsung  Momentus 7200.4 Scorpio Blue 
Mouse
Logitech G700 
  hide details  
Reply
post #3 of 9
Easy to fix. Switch back to IDE mode in BIOS. Load Windows. Then do this registry tweak:

http://www.windows7news.com/2010/05/...-in-windows-7/

After that go into BIOS again and change to AHCI. Now Windows is in AHCI mode.

You get BSOD because Windows still thinks that it should operate in IDE mode since you installed Windows while in IDE. You should normally switch to AHCI before installing Windows to avoid this kind of problem.
post #4 of 9
Quote:
Originally Posted by XSCounter View Post
Easy to fix. Switch back to IDE mode in BIOS. Load Windows. Then do this registry tweak:

http://www.windows7news.com/2010/05/...-in-windows-7/

After that go into BIOS again and change to AHCI. Now Windows is in AHCI mode.

You get BSOD because Windows still thinks that it should operate in IDE mode since you installed Windows while in IDE. You should normally switch to AHCI before installing Windows to avoid this kind of problem.
^ This.
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #5 of 9
Thread Starter 
Yeah...it didn't let me install in AHCI mode. I had to go back to IDE. Not sure why. Latest bios, not even sure what happened in the first place.
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
post #6 of 9
Quote:
Originally Posted by Dooginater View Post
Yeah...it didn't let me install in AHCI mode. I had to go back to IDE. Not sure why. Latest bios, not even sure what happened in the first place.
So did the fix work then?
post #7 of 9
Thread Starter 
Pretty sure it will, don't get outta work for another 4 1/2 hours. I wanted to jump on the afternoon rush here so I can get opinions on what I might try. Usually I'm on here late when hardly anyone's on. =( Rep'd accordingly though. ^_~
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
post #8 of 9
Thread Starter 
That's worked beautifully. Now magically after reformatting I get a 7.3 WEI on my SSD. Up from 5.9. O_O Not sure what's different but I'll take it.
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
D-1000
(16 items)
 
  
CPUMotherboardGraphicsGraphics
4790k @ 4.8Ghz 1.23v Evga z87 Classified 980ti sc acx+ SLI 980ti sc acx+ SLI 
RAMHard DriveOptical DriveCooling
CORSAIR Vengeance Pro 32GB (4 x 8GB) 240-Pin DD... Kingston 128GB SSD LG BD-RW H100 
OSMonitorMonitorKeyboard
Windows 8.1 x64 with Media Center U28D590 4k Acer HN274h 27" 1080p 120hz  G19 
PowerCaseMouseMouse Pad
Ultra X4 1600W Corsair 800D Razor Naga Epic Goliathus 
  hide details  
Reply
post #9 of 9
Quote:
Originally Posted by Dooginater View Post
That's worked beautifully. Now magically after reformatting I get a 7.3 WEI on my SSD. Up from 5.9. O_O Not sure what's different but I'll take it.
Congratz
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Computer crashed while playing Witcher 2 and now ahci mode doesn't work.