New Posts  All Forums:Forum Nav:

NAT problem - Page 3

post #21 of 38
Ok go back into the modem and either try to either turn off the port forwarding or change the destination address for the forward to the address of your router, I have no idea if either of these will work but since you have access now we need to start poking at it.

Edit make sure when you try to port forward to your router you are using the IP address of the router that your modem/router gives it not the one that you assigned to it.


Or after looking around for a little bit I found that if you turn off dhcp on your router let the dhcp on the modem handle everything then you might be able to do it that way. Having the dhcp from the modem give out an IP to the router and the dhcp from the router give out an IP to the computers is putting the two on different networks (this is more than likely your problem).
Edited by Macnemarion - 6/1/11 at 9:18pm
post #22 of 38
SET up separate port forwarding rules on each device so that incoming traffic is directed through both layers of NAT. So for example, on the first NAT device (the one closest to your Internet connection) forwardthe port(s) you need to the IP address of your router's WAN port. Then on your router, forward the same ports to the address of the device you need to reach. a Simple way is to configure the first NAT device to make your router's IP address the DMZ. This will hustle all incoming traffic through the first layer of NAT no questions asked, but when it hits your router it will be filtered or forwarded as appropriate.
post #23 of 38
Thread Starter 
Quote:
Originally Posted by Macnemarion View Post
On a side note you could just have your modem handle dhcp, set up a reservation for your router mac addy and and the computer that you need to port forward too then just turn dhcp off on the router. But this all hinges on being able to access your router interface.
how can i do this?

or would it be easier to turn dhcp off on the modem? and if so, can i still use the QoS settings on modem?
post #24 of 38
It would prolly do what spoony suggested above you. It will allow you to only have to worry about messing with the modem config once and you can just do all your future config in from within your router.

I am not sure if your modem has a reservation setting (your router prolly does though), or not I was thinking out loud when I suggested what I did.

If you don't know what a reservation is then it is a way for you to tell dhcp to only give a reserved IP address to a certain MAC addy , almost like setting static but you are letting DHCP handle it.
post #25 of 38
Thread Starter 
when i go to the DMZ tab in the modem, i can choose to enable/disable DMZ (it is disabled right now) and when i enable it i may choose a DMZ host PC name from a pulldown tab, and it has 2 things listed - an IP that doesnt match my router or modem idk what it goes to and a bunch of numbers/letters. it doesnt list my routers IP and i cannot set it manually
post #26 of 38
your router actually has 2 ip addresses

The external which it gets from the modem dhcp
(should be one off from the modem ip ex. modem ip-192.168.2.1: router external-192.168.2.2)

and the private which you assign it (prolly 192.168.1.1)

When setting up the DMZ on your modem you want to put the EXTERNAL IP for the router in it

this will just let all traffic flow right through the modem and to router, then you can go ahead and set up your ports from within the router and not have to worry about the modem any more
Edited by Macnemarion - 6/2/11 at 1:20pm
post #27 of 38
Thread Starter 
ok, still have NAT problems for red factions.

only thing that strikes me odd is, my modem ip is 192.168.0.1, and my router is 192.168.2.1, but the DMZ is enabled for 192.168.0.3?
post #28 of 38
is the 192.168.2.1 the external ip for the router if so then that is the one that needs to in the DMZ
post #29 of 38
Thread Starter 
no, you said the external ip should be 1 off from the modem. which would be 192.168.0.2 but instead its 192.168.0.3 for the DMZ (according to modem, it wont let me select any other options)



this may not even be the problem though
post #30 of 38
yeah i would think that if the modem is handing out the IP to the router it would pick the first one on it's range list which should be the following ip after the one it has. If the external is xxx.xxx.0.3 then it's no problem for that matter any way.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Networking & Security