Overclock.net › Forums › Video Games › PC Gaming › Bad Company 2 Black Flickering
New Posts  All Forums:Forum Nav:

Bad Company 2 Black Flickering

post #1 of 12
Thread Starter 
I have recently reinstalled everything from scratch, including OS, and noticed while I am in BC2 on Heavy Metal, sometimes my entire screen goes black. If I remember correctly, I could still see the map and other things at the bottom of the screen, but everything else is black. After awhile it would come back after flickering. I havent played much, so I am not sure if this is all the maps or just this one. I am on water, so temps arent high (under 40C). I am using the latest 11.5 drivers with xfire 6950s. Any thoughts would be greatly appreciated.

Thanks!
post #2 of 12
Hm....
Do you have the drivers for EVERYTHING (mobo, proc, RAM, netwrok/sound card) up to latest?
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
post #3 of 12
I had that problem with my old graphics card, it didn't seem to be related to temps. I never found a permanent solution (when I got my new card, it went away), but I've heard turning off bloom helps. To do that, go to the bfbc2 folder in my documents, open up the settings file, and change the bloom setting to 0.
Workstation
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 920 c0 @ 3.50 Asus Sabertooth X58 Nvidia gtx 570 Nvidia gtx 210 
RAMHard DriveOptical DriveOptical Drive
12 GB (Patriot 4GB DDR3 1600 Mhz + G.Skill Ripj... OCZ Vertex II 60GB + x2 WD 1TB + WD 500 GB Lite-On DVD Burner LG Blu Ray Burner 
OSMonitorMonitorMonitor
Windows 8 Professional x64, Arch Linux x64 Samsung 22 inch 1920x1080 60Hz Asus 23 inch 1920x1080 IPS Acer 19 inch 1600x900 
KeyboardPowerCaseMouse
Logitech g11 Corsair 750 Watt NZXT Tempest Razer deathadder 3500 dpi 
Mouse PadAudioAudio
OCZ Audigy SE Sony MDR-V6 
  hide details  
Reply
Workstation
(19 items)
 
  
CPUMotherboardGraphicsGraphics
Intel i7 920 c0 @ 3.50 Asus Sabertooth X58 Nvidia gtx 570 Nvidia gtx 210 
RAMHard DriveOptical DriveOptical Drive
12 GB (Patriot 4GB DDR3 1600 Mhz + G.Skill Ripj... OCZ Vertex II 60GB + x2 WD 1TB + WD 500 GB Lite-On DVD Burner LG Blu Ray Burner 
OSMonitorMonitorMonitor
Windows 8 Professional x64, Arch Linux x64 Samsung 22 inch 1920x1080 60Hz Asus 23 inch 1920x1080 IPS Acer 19 inch 1600x900 
KeyboardPowerCaseMouse
Logitech g11 Corsair 750 Watt NZXT Tempest Razer deathadder 3500 dpi 
Mouse PadAudioAudio
OCZ Audigy SE Sony MDR-V6 
  hide details  
Reply
post #4 of 12
Turn off any overclocking software you have on. Afterburner, trixx, ect... By turn it off i mean, make sure it has nothing running in the background.
Gnomeon
(16 items)
 
GnomeBook Pro
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon E3-1245 V2 ASUS P8Z77-V SAPPHIRE TRI-X OC Radeon R9 290X 4GB  Crucial Ballistix Tactical 16GB DDR3 1866 
Hard DriveHard DriveCoolingOS
Crucial M550 256GB HGST Travelstar 7K1000 2.5-Inch 1TB 7200 RPM Cooler Master Hyper 212 Evo Windows 10 Pro 64-Bit 
MonitorKeyboardPowerCase
BenQ XL2730Z Cooler Master Quickfire Pro Unbranded (Tenkeyless) SeaSonic SG12 550W Fractal Design Define S 
MouseAudioAudioOther
Mionix Avior Swan M10 Philips Fidelio X1 Audio-Technica ATR2500-USB 
CPUMotherboardGraphicsRAM
Intel Core i7-2720QM Logic Board Intel HD Graphics 3000 and AMD 6750M 1gb Crucial 16GB 1333MHZ 
Hard DriveOptical DriveOSMonitor
750gb Hitachi 5400rpm 8x double-layer SuperDrive OS x 10.7.4 15.4" LED-backlit glossy widescreen display 144... 
KeyboardPowerCaseMouse
Apple Keyboard Apple 85W MagSafe Power Adapter 2011 Unibody Magic Trackpad 
Audio
Built-in Stereo Speakers with Subwoofer 
  hide details  
Reply
Gnomeon
(16 items)
 
GnomeBook Pro
(13 items)
 
 
CPUMotherboardGraphicsRAM
Intel Xeon E3-1245 V2 ASUS P8Z77-V SAPPHIRE TRI-X OC Radeon R9 290X 4GB  Crucial Ballistix Tactical 16GB DDR3 1866 
Hard DriveHard DriveCoolingOS
Crucial M550 256GB HGST Travelstar 7K1000 2.5-Inch 1TB 7200 RPM Cooler Master Hyper 212 Evo Windows 10 Pro 64-Bit 
MonitorKeyboardPowerCase
BenQ XL2730Z Cooler Master Quickfire Pro Unbranded (Tenkeyless) SeaSonic SG12 550W Fractal Design Define S 
MouseAudioAudioOther
Mionix Avior Swan M10 Philips Fidelio X1 Audio-Technica ATR2500-USB 
CPUMotherboardGraphicsRAM
Intel Core i7-2720QM Logic Board Intel HD Graphics 3000 and AMD 6750M 1gb Crucial 16GB 1333MHZ 
Hard DriveOptical DriveOSMonitor
750gb Hitachi 5400rpm 8x double-layer SuperDrive OS x 10.7.4 15.4" LED-backlit glossy widescreen display 144... 
KeyboardPowerCaseMouse
Apple Keyboard Apple 85W MagSafe Power Adapter 2011 Unibody Magic Trackpad 
Audio
Built-in Stereo Speakers with Subwoofer 
  hide details  
Reply
post #5 of 12
Happens to me as well. Most speculate it is related to MSI AB and any OSD program you use to monitor your temperatures and such. It isn't enough for me to turn those off, so I just let it be.
post #6 of 12
I used to have this problem when I was running a GTX 285 and an E8400
it would start out like a black cloud in the middle of the screen and then it would slowly
disappear from the outer edge inward.
It was like the v-card was not getting fed info fast enough
Have not experienced since I went to an i7 @ 4.2ghz. and a GTX 470

(edit)
When it was happening my OS of choice was winXP, haven't had it happen with Win7
Pa's Puter
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 i930@4.2ghz. Gigabyte EX58-UD4P EVGA GTX 970 FTW + GSkill DDR3-1600 12 gig 
Hard DriveOptical DriveCoolingOS
Samsung Evo SSD  DVDROM EK supreme HF Cu gold plated/ XSPC 480 Windows 7 Pro. 64 bit 
MonitorKeyboardPowerCase
LG 27EA63 IPS monitor merc stealth Corsair TX850 Corsair 700D 
MouseMouse PadAudio
logitech G5 Rocketfish dual surface Creative Xfx extreme and Zalman 5.1 headphones 
  hide details  
Reply
Pa's Puter
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i7 i930@4.2ghz. Gigabyte EX58-UD4P EVGA GTX 970 FTW + GSkill DDR3-1600 12 gig 
Hard DriveOptical DriveCoolingOS
Samsung Evo SSD  DVDROM EK supreme HF Cu gold plated/ XSPC 480 Windows 7 Pro. 64 bit 
MonitorKeyboardPowerCase
LG 27EA63 IPS monitor merc stealth Corsair TX850 Corsair 700D 
MouseMouse PadAudio
logitech G5 Rocketfish dual surface Creative Xfx extreme and Zalman 5.1 headphones 
  hide details  
Reply
post #7 of 12
Try running BFBC2 in DX9 mode by setting it in the INI file.
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
post #8 of 12
Thread Starter 
I have had it go completely white a couple of times and boot me to the desktop. Once I am at the desktop, BC2 is still running, but I cant get into it. I have to kill it from task manager. My temps never go above 40. I have overclocked nothing at this point, and I have no MSI or Trixx software running.
post #9 of 12
Turn Crossfire off.
post #10 of 12
Quote:
Originally Posted by Kand View Post
Turn Crossfire off.
This.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Bad Company 2 Black Flickering