Overclock.net › Forums › Components › Hard Drives & Storage › SSD › SSD IDE => AHCI After Install??
New Posts  All Forums:Forum Nav:

SSD IDE => AHCI After Install??

post #1 of 36
Thread Starter 
As the title states, I think I saw a thread around here somewhere telling how to make this work.

Basically I installed windows 7 on my ssd in IDE mode because at the time I could not find where to change it in the bios, but I found it last night and when I change it from IDE to AHCI windows does not load it just BSOD's.

So is there a way to get it changed? I really don't want to spend another 2 days getting my OS like I like I like it. Can I run a backup of my OS then reinstall in AHCI mode then recover from the backup?? Is it worth it to change?
Paper Weight
(11 items)
 
Home Work
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7 2600k  Gigabyte Z68 UD6H-B3 GTX 580 HC2 2x4 GB G.Skill Ripjaw X 2133 
Hard DriveCoolingOSMonitor
A-Data N001 SSD  XSPC Rasa 750 Win 7 Ult. 64bit Asus 22" 
PowerCaseAudio
Corsiar TX750 Antec 1200 X-Fi Xtreme Gamer 
CPUMotherboardGraphicsRAM
Q6600 (3.6Ghz 1.487v) Asus P5Q-E (2x CF)Sapphire HD 4870 512 & 1GB 4GB (2x2GB) G.Skill PC8000 
Hard DriveOptical DriveCoolingOS
A-Data N002 128GB SSD, 1.5TB WD Green Pioneer DL-DvD/RW XSPC RASA 360 push/pull Windows 7 64bit Ultimate 
MonitorKeyboardPowerCase
22" Asus WS-HD VK222H Logitech Elite Corsair Tx750 Antec 1200 
MouseMouse PadAudio
Logitech G5 Series 2 Rocketfish 2 sided X-Fi Xtreme Gamer / Logitech 5.1 
  hide details  
Reply
Paper Weight
(11 items)
 
Home Work
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7 2600k  Gigabyte Z68 UD6H-B3 GTX 580 HC2 2x4 GB G.Skill Ripjaw X 2133 
Hard DriveCoolingOSMonitor
A-Data N001 SSD  XSPC Rasa 750 Win 7 Ult. 64bit Asus 22" 
PowerCaseAudio
Corsiar TX750 Antec 1200 X-Fi Xtreme Gamer 
CPUMotherboardGraphicsRAM
Q6600 (3.6Ghz 1.487v) Asus P5Q-E (2x CF)Sapphire HD 4870 512 & 1GB 4GB (2x2GB) G.Skill PC8000 
Hard DriveOptical DriveCoolingOS
A-Data N002 128GB SSD, 1.5TB WD Green Pioneer DL-DvD/RW XSPC RASA 360 push/pull Windows 7 64bit Ultimate 
MonitorKeyboardPowerCase
22" Asus WS-HD VK222H Logitech Elite Corsair Tx750 Antec 1200 
MouseMouse PadAudio
Logitech G5 Series 2 Rocketfish 2 sided X-Fi Xtreme Gamer / Logitech 5.1 
  hide details  
Reply
post #2 of 36
No you can't. You need to have AHCI turned on before you install Windows. After the installation is complete you could then change it back to IDE.

Here's my highest benchmark after AHCI>>Windows install>>IDE in the bios:

crystaldiskmark_03.png

So avoiding the re-installation of Windows is impossible at this time. Someone please correct me if I'm wrong on this.
Edited by CrashPush - 6/2/11 at 5:55am
    
CPUMotherboardGraphicsRAM
Intel Core i7 2600k 3.4Ghz Gigabyte GA-P67A-UD7-B3 EVGA Classified Geforce GTX 590 Corsair Vengeance 16GB (4 x 4GB) DDR3 
Hard DriveOptical DriveOSMonitor
OCZ V3 240GB WD VRaptor 450GB WD Caviar Black 2TB Sony Blu-ray 12x BD-R Lite-On 24x DVD-R Windows 7 Ultimate x64 HP ZR30w 30" S-IPS 2560x1600 
KeyboardPowerCaseMouse
Logitech G510 Gaming Keyboard Coolermaster Silent Pro Gold 1000W Corsair Obsidian 800D Logitech G700 Gaming Mouse 
Mouse Pad
Mouse Rug 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
Intel Core i7 2600k 3.4Ghz Gigabyte GA-P67A-UD7-B3 EVGA Classified Geforce GTX 590 Corsair Vengeance 16GB (4 x 4GB) DDR3 
Hard DriveOptical DriveOSMonitor
OCZ V3 240GB WD VRaptor 450GB WD Caviar Black 2TB Sony Blu-ray 12x BD-R Lite-On 24x DVD-R Windows 7 Ultimate x64 HP ZR30w 30" S-IPS 2560x1600 
KeyboardPowerCaseMouse
Logitech G510 Gaming Keyboard Coolermaster Silent Pro Gold 1000W Corsair Obsidian 800D Logitech G700 Gaming Mouse 
Mouse Pad
Mouse Rug 
  hide details  
Reply
post #3 of 36
Unless I'm misunderstanding you can change it to AHCI mode after windows is installed. I had to do this to update the firmware on my SSD. Inside of windows the SSD is quite a bit faster, however the boot time basically tripled after I switched to AHCI.
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
Gaming
(20 items)
 
HTPC
(21 items)
 
My Stuff
(12 photos)
CPUMotherboardGraphicsRAM
Intel Core i3-3220 ASRock H77M EVGA 750ti CORSAIR Vengeance 8GB DDR3 1600 
Hard DriveHard DriveHard DriveOptical Drive
1TB WD Black  2TB WD Green 4TB WD My Book Samsung Blu-Ray 
CoolingOSMonitorKeyboard
Cougar 120mm PWM Windows 10 60" Vizio M60-C3 4K Logitech K400 
PowerCaseMouseAudio
OCZ ModXStream 600w Silverstone GD05 Logitech K400 / MCE Remote Denon AVR-X2200W 
AudioAudioAudioAudio
Polk Audio Monitor II - CS2 BIC F12 - 12" Sub Polk Audio Monitor II - Monitor 70 x 2 Polk Audio Monitor II - Monitor 30 x 2 
  hide details  
Reply
post #4 of 36
You are wrong.
Search is your friend!

change registry, change option in bios, boot windows, install new drivers, reboot.
Quick and easy.
Synthkart
(13 items)
 
  
CPUMotherboardGraphicsRAM
1055T Asus Onboard x4200 2x2GB GeIL DDR 1333 (9-9-9) 
Hard DriveOptical DriveOSMonitor
Seagate 320GB Sata3.0 Liteon iHAS124 Win7 x64 Some old crt 
KeyboardPowerCaseMouse
digital Raidmax-450K Some cheap raidmax Labtec 
Mouse Pad
  hide details  
Reply
Synthkart
(13 items)
 
  
CPUMotherboardGraphicsRAM
1055T Asus Onboard x4200 2x2GB GeIL DDR 1333 (9-9-9) 
Hard DriveOptical DriveOSMonitor
Seagate 320GB Sata3.0 Liteon iHAS124 Win7 x64 Some old crt 
KeyboardPowerCaseMouse
digital Raidmax-450K Some cheap raidmax Labtec 
Mouse Pad
  hide details  
Reply
post #5 of 36
Thread Starter 
I have another problem effecting my boot time, since I have installed the SSD now I get a cursor flashing for about 20 seconds after BIOS post and before windows starts loading, I have no idea what it is looking for but it just goes to a black screen with the cursor flashing for a bout 20 seconds then the cursor moves down a line then windows starts to load .. any idea what is causing this? I will try the registry thing tonight.
Paper Weight
(11 items)
 
Home Work
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7 2600k  Gigabyte Z68 UD6H-B3 GTX 580 HC2 2x4 GB G.Skill Ripjaw X 2133 
Hard DriveCoolingOSMonitor
A-Data N001 SSD  XSPC Rasa 750 Win 7 Ult. 64bit Asus 22" 
PowerCaseAudio
Corsiar TX750 Antec 1200 X-Fi Xtreme Gamer 
CPUMotherboardGraphicsRAM
Q6600 (3.6Ghz 1.487v) Asus P5Q-E (2x CF)Sapphire HD 4870 512 & 1GB 4GB (2x2GB) G.Skill PC8000 
Hard DriveOptical DriveCoolingOS
A-Data N002 128GB SSD, 1.5TB WD Green Pioneer DL-DvD/RW XSPC RASA 360 push/pull Windows 7 64bit Ultimate 
MonitorKeyboardPowerCase
22" Asus WS-HD VK222H Logitech Elite Corsair Tx750 Antec 1200 
MouseMouse PadAudio
Logitech G5 Series 2 Rocketfish 2 sided X-Fi Xtreme Gamer / Logitech 5.1 
  hide details  
Reply
Paper Weight
(11 items)
 
Home Work
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7 2600k  Gigabyte Z68 UD6H-B3 GTX 580 HC2 2x4 GB G.Skill Ripjaw X 2133 
Hard DriveCoolingOSMonitor
A-Data N001 SSD  XSPC Rasa 750 Win 7 Ult. 64bit Asus 22" 
PowerCaseAudio
Corsiar TX750 Antec 1200 X-Fi Xtreme Gamer 
CPUMotherboardGraphicsRAM
Q6600 (3.6Ghz 1.487v) Asus P5Q-E (2x CF)Sapphire HD 4870 512 & 1GB 4GB (2x2GB) G.Skill PC8000 
Hard DriveOptical DriveCoolingOS
A-Data N002 128GB SSD, 1.5TB WD Green Pioneer DL-DvD/RW XSPC RASA 360 push/pull Windows 7 64bit Ultimate 
MonitorKeyboardPowerCase
22" Asus WS-HD VK222H Logitech Elite Corsair Tx750 Antec 1200 
MouseMouse PadAudio
Logitech G5 Series 2 Rocketfish 2 sided X-Fi Xtreme Gamer / Logitech 5.1 
  hide details  
Reply
post #6 of 36
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
post #7 of 36
Of course you can! Don't let people confuse you.

How to Enable AHCI in Windows 7
post #8 of 36
Quote:
Originally Posted by PLeXuS4200;13723629 
I have another problem effecting my boot time, since I have installed the SSD now I get a cursor flashing for about 20 seconds after BIOS post and before windows starts loading, I have no idea what it is looking for but it just goes to a black screen with the cursor flashing for a bout 20 seconds then the cursor moves down a line then windows starts to load .. any idea what is causing this? I will try the registry thing tonight.

Do you have a non boot disk in your CD/DVD drive?
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
post #9 of 36
The flashing cursor could be a number of things, only time I get that is with an external storage is attached, or the disk drive is set as the default boot device. Pc waits to check the disk drive for a bootable disk, when there isn't one, it continues.
Synthkart
(13 items)
 
  
CPUMotherboardGraphicsRAM
1055T Asus Onboard x4200 2x2GB GeIL DDR 1333 (9-9-9) 
Hard DriveOptical DriveOSMonitor
Seagate 320GB Sata3.0 Liteon iHAS124 Win7 x64 Some old crt 
KeyboardPowerCaseMouse
digital Raidmax-450K Some cheap raidmax Labtec 
Mouse Pad
  hide details  
Reply
Synthkart
(13 items)
 
  
CPUMotherboardGraphicsRAM
1055T Asus Onboard x4200 2x2GB GeIL DDR 1333 (9-9-9) 
Hard DriveOptical DriveOSMonitor
Seagate 320GB Sata3.0 Liteon iHAS124 Win7 x64 Some old crt 
KeyboardPowerCaseMouse
digital Raidmax-450K Some cheap raidmax Labtec 
Mouse Pad
  hide details  
Reply
post #10 of 36
Thread Starter 
Quote:
Originally Posted by tout;13723673 
Do you have a non boot disk in your CD/DVD drive?

Nope, emptied the cd drive, although this may be as result of my bios thinking my SSD is a thumb drive?? Maybe this situation will resolve after the change to AHCI. Seems like it started right after I switched to H2O cooling and I was getting a cpu fan error press f1, then I disabled the press f1 thing so it would boot, but this pops up right the screen that that usually shows up on.
Paper Weight
(11 items)
 
Home Work
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7 2600k  Gigabyte Z68 UD6H-B3 GTX 580 HC2 2x4 GB G.Skill Ripjaw X 2133 
Hard DriveCoolingOSMonitor
A-Data N001 SSD  XSPC Rasa 750 Win 7 Ult. 64bit Asus 22" 
PowerCaseAudio
Corsiar TX750 Antec 1200 X-Fi Xtreme Gamer 
CPUMotherboardGraphicsRAM
Q6600 (3.6Ghz 1.487v) Asus P5Q-E (2x CF)Sapphire HD 4870 512 & 1GB 4GB (2x2GB) G.Skill PC8000 
Hard DriveOptical DriveCoolingOS
A-Data N002 128GB SSD, 1.5TB WD Green Pioneer DL-DvD/RW XSPC RASA 360 push/pull Windows 7 64bit Ultimate 
MonitorKeyboardPowerCase
22" Asus WS-HD VK222H Logitech Elite Corsair Tx750 Antec 1200 
MouseMouse PadAudio
Logitech G5 Series 2 Rocketfish 2 sided X-Fi Xtreme Gamer / Logitech 5.1 
  hide details  
Reply
Paper Weight
(11 items)
 
Home Work
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7 2600k  Gigabyte Z68 UD6H-B3 GTX 580 HC2 2x4 GB G.Skill Ripjaw X 2133 
Hard DriveCoolingOSMonitor
A-Data N001 SSD  XSPC Rasa 750 Win 7 Ult. 64bit Asus 22" 
PowerCaseAudio
Corsiar TX750 Antec 1200 X-Fi Xtreme Gamer 
CPUMotherboardGraphicsRAM
Q6600 (3.6Ghz 1.487v) Asus P5Q-E (2x CF)Sapphire HD 4870 512 & 1GB 4GB (2x2GB) G.Skill PC8000 
Hard DriveOptical DriveCoolingOS
A-Data N002 128GB SSD, 1.5TB WD Green Pioneer DL-DvD/RW XSPC RASA 360 push/pull Windows 7 64bit Ultimate 
MonitorKeyboardPowerCase
22" Asus WS-HD VK222H Logitech Elite Corsair Tx750 Antec 1200 
MouseMouse PadAudio
Logitech G5 Series 2 Rocketfish 2 sided X-Fi Xtreme Gamer / Logitech 5.1 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › SSD IDE => AHCI After Install??