Overclock.net › Forums › Components › Hard Drives & Storage › on-again off-again HDD ???
New Posts  All Forums:Forum Nav:

on-again off-again HDD ???

post #1 of 6
Thread Starter 
Hi all,
First off, I dug through some threads but I couldn't find anything that helped so I'm asking here. (if I missed something please point me in the right direction )

My roommates PC mysteriously stopped recognizing his HDD. He only has one internal HDD and two externals. The bios found the externals and the DVD drive, but not the primary.

1. I opened it and checked all the wiring, which was fine, nothing loose nothing cracked but it still didn't work.
2. His HDD was on his 1st sata connector and his DVD was on the 2nd, so I moved them both back one spot thinking the 1st sata port might be the problem; HDD is now on 2nd sata port and dvd on 3rd, with nothing on the 1st. The PC didn't find a primary or master but it did find the HDD and booted up windows no problem.
3. He turned off the pc, closed up his case and attempted to turn on the PC. It was back to not finding any bootable devices. I restarted it and went back into BIOS and it wasn't detecting the HDD, again.
4. I restarted his PC again, went into BIOS again and viola, it was magically there. I could boot from it but BIOS wouldn't allow me to set it to primary or master or anything of that sort.

So now his PC is on and working but he's afraid to turn it off. I told him his HDD might be failing but I'm hoping someone will have more insight. Anyone got any ideas?

P.S. Sorry if I missed anything or used any terms incorrectly, as I'm not super BIOS savvy.
1st build
(16 items)
 
  
CPUMotherboardGraphicsRAM
Q8300 @ 2.8 Asus P5P41T-LE MSI 5770 Hawk 4GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Western Digital Western Digital none, mwuahah 
CoolingOSMonitorPower
Hyper 212+ win7 ultimate x64 ASUS VK266H 500W OCZ SXS2 
CaseMouse
NZXT Tempest Evo G500 
  hide details  
Reply
1st build
(16 items)
 
  
CPUMotherboardGraphicsRAM
Q8300 @ 2.8 Asus P5P41T-LE MSI 5770 Hawk 4GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Western Digital Western Digital none, mwuahah 
CoolingOSMonitorPower
Hyper 212+ win7 ultimate x64 ASUS VK266H 500W OCZ SXS2 
CaseMouse
NZXT Tempest Evo G500 
  hide details  
Reply
post #2 of 6
Could possibly be failing. Have you tried clearing the cmos and seeing if that will allow it to see the drive again? If not and you think it is truly failing take the drive out place it in yours and see if you can save his files for him.
post #3 of 6
It may be the HDD, but it also may be the SATA ports on the motherboard. Depending how the PC is built you could check if it's the SB or the HDD more likely to overheat, this would point you in a direction.
Then you could simply disconnect the DVD, if AHCI is on you can even sign out the DVD and unplug it while the rig is running like an USB thumbdrive. With the DVD (who could also be the cause) out of the way you ca circle the HDD to different ports and find a consistent pattern, like certain ports not working ever, but some working always. If you find a port where the HDD always works you can connect the DVD and swap about until both work. If you find this combo it may be that some SATA ports are broken on the board and he can think of buying another soon.
If you don't have any pattern and it keeps working/failing on all ports and combinations then there's no other way but checking the HDD on another rig or swapping motherboards. You can check the HDD with HD Tune and see if both performance (benchmark) and SMART/Health are as it should - for example if it is too slow it points to a failing disk, or if health indicators are bad also failing disk. If the disk is fine then it's probably the board. You can try CMOS reset, BIOS update even at the same version as the one used now (it may have gotten corrupted).

This is about all I can think of to try, keep us posted on how it evolves. And you will have to shut down at a certain point, but don't do it before all files are saved and you ran a diagnostic with HD Tune.
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
Centurion
(14 items)
 
  
CPUMotherboardGraphicsRAM
Phenom II 940 @3.3GHz 1.25V Gigabyte 790X-DS4 XFX 5850 8GB OCZ DDR2-800 
Hard DriveCoolingOSMonitor
Corsair Force 3 TRUE Win 7 Pro x64 ACER 23" TN  
PowerCase
400W Silverstone Strider Antec P182 
  hide details  
Reply
post #4 of 6
Thread Starter 
Big thanks for the replies guys!!! Dragosmp went a little over my head, but I appreciate it as I would rather have too much than too little info; always learning

Well, luckily and unluckily for him I had the same PC before I built mine so he can swap parts with that, but my mobo failed on that pc so he can't use that and I'm using the HDD. My first thought was bad sata ports. Now, thinking back on my mobo fail, it seems even more likely that is the culprit. He only has 4 sata ports I believe so I hope we can find at least 2 good ones.

CMOS question: Could CMOS be the problem even if his pc was running fine just hours before this? Is the easiest way to reset CMOS to turn off the pc and take out/put back the battery on the mobo?

I did ask him about it making noise, and he said it was louder than usual lately, but he can't tell if it was a fan or HD sound and the temps have been on the rise here since summer.

Can I add his HDD to my pc without making it the boot drive and still save info to it?
If it will boot up from the drive but BIOS won't let me set it as a primary/master, what does that mean? Mobo problem?

He's at work right now so I can't do anything yet; I don't want him to come home to his pc being in more disarray that it was last night. I will try to get him to run HD Tune tonight and I'll post a screen shot of the results.

THANKS AGAIN GUYS!
1st build
(16 items)
 
  
CPUMotherboardGraphicsRAM
Q8300 @ 2.8 Asus P5P41T-LE MSI 5770 Hawk 4GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Western Digital Western Digital none, mwuahah 
CoolingOSMonitorPower
Hyper 212+ win7 ultimate x64 ASUS VK266H 500W OCZ SXS2 
CaseMouse
NZXT Tempest Evo G500 
  hide details  
Reply
1st build
(16 items)
 
  
CPUMotherboardGraphicsRAM
Q8300 @ 2.8 Asus P5P41T-LE MSI 5770 Hawk 4GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Western Digital Western Digital none, mwuahah 
CoolingOSMonitorPower
Hyper 212+ win7 ultimate x64 ASUS VK266H 500W OCZ SXS2 
CaseMouse
NZXT Tempest Evo G500 
  hide details  
Reply
post #5 of 6
Could be as simple as changing out the sata cable with a new one. They do go bad or intermittent bad.
My CM sniper
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8ghz @ 1.4v. ASRock Z68 EXTREME4 GEN3 EVGA gtx470 SC GSKILL SNIPER DDR3 1600 2X4 9.9.9.24 
Hard DriveOptical DriveOSMonitor
CRUCIAL 64GB SSD 1-VR300 4X F3 1TB SAMSUNG 22X SATA DVD BURNER WINDOWZ 7 64BIT 23'' ACER P235H WS 
KeyboardPowerCaseMouse
LOGITECH G15 V 2007 CORSAIR TX750 CM STORM SNIPER/ MODDED OCZ DOMINATRIX 
Mouse PadAudio
ALL OVER THE TABLE ON BOARD 
  hide details  
Reply
My CM sniper
(14 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k 4.8ghz @ 1.4v. ASRock Z68 EXTREME4 GEN3 EVGA gtx470 SC GSKILL SNIPER DDR3 1600 2X4 9.9.9.24 
Hard DriveOptical DriveOSMonitor
CRUCIAL 64GB SSD 1-VR300 4X F3 1TB SAMSUNG 22X SATA DVD BURNER WINDOWZ 7 64BIT 23'' ACER P235H WS 
KeyboardPowerCaseMouse
LOGITECH G15 V 2007 CORSAIR TX750 CM STORM SNIPER/ MODDED OCZ DOMINATRIX 
Mouse PadAudio
ALL OVER THE TABLE ON BOARD 
  hide details  
Reply
post #6 of 6
Thread Starter 
Thanks for the info about the cable. I'll have to check and see if we have spares we can test.
1st build
(16 items)
 
  
CPUMotherboardGraphicsRAM
Q8300 @ 2.8 Asus P5P41T-LE MSI 5770 Hawk 4GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Western Digital Western Digital none, mwuahah 
CoolingOSMonitorPower
Hyper 212+ win7 ultimate x64 ASUS VK266H 500W OCZ SXS2 
CaseMouse
NZXT Tempest Evo G500 
  hide details  
Reply
1st build
(16 items)
 
  
CPUMotherboardGraphicsRAM
Q8300 @ 2.8 Asus P5P41T-LE MSI 5770 Hawk 4GB DDR3 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital Western Digital Western Digital none, mwuahah 
CoolingOSMonitorPower
Hyper 212+ win7 ultimate x64 ASUS VK266H 500W OCZ SXS2 
CaseMouse
NZXT Tempest Evo G500 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hard Drives & Storage
Overclock.net › Forums › Components › Hard Drives & Storage › on-again off-again HDD ???