Overclock.net › Forums › Video Games › PC Gaming › Having trouble setting up MC server (port forward)
New Posts  All Forums:Forum Nav:

Having trouble setting up MC server (port forward) - Page 2

post #11 of 20
Quote:
Originally Posted by mcole254 View Post
Still returns "failed to bind to port" when I run the server trying to use port 80.
I even tried to open it like before, same thing (web sites still say port is closed as well.)
you CANNOT use port 80. other programs use port 80.

the reason its "failed to bind to port" is because something else is using that port. (when it "binds" it takes complete usage of it.)

use any other port, one that isn't being used by anything else, forward that port, and you will be GOLDEN.
Edited by Fooxz - 6/3/11 at 7:41pm
Fooxz Gamer
(18 items)
 
Sager 8130
(16 items)
 
MAXIMUM Server
(19 items)
 
CPUMotherboardGraphicsRAM
i5 2500K AsRock Extreme3 Gen3 GTX 470 Corsair Vengance (2x4GB) DDR3 
Hard DriveHard DriveHard DriveHard Drive
80GB Intel 320 SSD (Boot) 640GB WD Black (apps) 1TB WD Green (Fraps drive) MAXIMUS Server 
CoolingOSMonitorKeyboard
Corsair H50 Windows 7 Pro x64 HP 25" 1920x1080 Filco Majestouch Tenkeyless Cherry MX Black 
PowerCaseMouseMouse Pad
Antec TP-550 "New" NZXT Switch 810 Razer Mamba Steel Series 9HD 
AudioAudio
Logitech G930 Logitech 2.0 Speakers 
CPUMotherboardGraphicsRAM
i7-2670QM Clevo P151HM1 Base nVidia 560m 8GB 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 240GB Combo Way too weak. Win 7 Pro x64 
MonitorKeyboardPowerCase
15.6” LED Backlit 1920x1080 Super Clear Matte Laptop Keyboard 120W Power Brick Chrome Buran Stealth Black messenger bag 
MouseMouse PadAudioAudio
Logitech G700 Steel Series 4HD Onboard > JDS Labs CMoy > Yuin PK1s or AKG K271s Logitech G930 
CPUMotherboardGraphicsRAM
i7 870 ASUS MAXIMUS III GENE nVidia 440GT GSkill 2x4GB 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
Random 120GB Hitachi 2.5in 500GB  Western Digital Green 1TB Western Digital Green 2TB 
Hard DriveOptical DriveCoolingOS
Western Digital Green 3TB USB3 Samsung SATA BluRay Drive Noctua D14 Win 7 Pro x64 
MonitorKeyboardPowerCase
RDP RDP FSP 350w Fractal Design Define Mini 
MouseMouse PadAudio
RDP Nada Optical Out to 5.0 stereo  
  hide details  
Reply
Fooxz Gamer
(18 items)
 
Sager 8130
(16 items)
 
MAXIMUM Server
(19 items)
 
CPUMotherboardGraphicsRAM
i5 2500K AsRock Extreme3 Gen3 GTX 470 Corsair Vengance (2x4GB) DDR3 
Hard DriveHard DriveHard DriveHard Drive
80GB Intel 320 SSD (Boot) 640GB WD Black (apps) 1TB WD Green (Fraps drive) MAXIMUS Server 
CoolingOSMonitorKeyboard
Corsair H50 Windows 7 Pro x64 HP 25" 1920x1080 Filco Majestouch Tenkeyless Cherry MX Black 
PowerCaseMouseMouse Pad
Antec TP-550 "New" NZXT Switch 810 Razer Mamba Steel Series 9HD 
AudioAudio
Logitech G930 Logitech 2.0 Speakers 
CPUMotherboardGraphicsRAM
i7-2670QM Clevo P151HM1 Base nVidia 560m 8GB 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 240GB Combo Way too weak. Win 7 Pro x64 
MonitorKeyboardPowerCase
15.6” LED Backlit 1920x1080 Super Clear Matte Laptop Keyboard 120W Power Brick Chrome Buran Stealth Black messenger bag 
MouseMouse PadAudioAudio
Logitech G700 Steel Series 4HD Onboard > JDS Labs CMoy > Yuin PK1s or AKG K271s Logitech G930 
CPUMotherboardGraphicsRAM
i7 870 ASUS MAXIMUS III GENE nVidia 440GT GSkill 2x4GB 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
Random 120GB Hitachi 2.5in 500GB  Western Digital Green 1TB Western Digital Green 2TB 
Hard DriveOptical DriveCoolingOS
Western Digital Green 3TB USB3 Samsung SATA BluRay Drive Noctua D14 Win 7 Pro x64 
MonitorKeyboardPowerCase
RDP RDP FSP 350w Fractal Design Define Mini 
MouseMouse PadAudio
RDP Nada Optical Out to 5.0 stereo  
  hide details  
Reply
post #12 of 20
Try this program. It is what I used and it worked fine after I sent in my router info to them. they didnt have it at the time. http://www.simpleportforwarding.com/
post #13 of 20
Quote:
Originally Posted by Topgearfan View Post
Try this program. It is what I used and it worked fine after I sent in my router info to them. they didnt have it at the time. http://www.simpleportforwarding.com/
the issue is not with the port forward, the server is not starting properly, if it cannot bind the port, it DOES NOT START. (this happened to me the other day when I accidentally started two servers on the same port, the second one had this error, only one the first server was working.
Edited by Fooxz - 6/4/11 at 9:19am
Fooxz Gamer
(18 items)
 
Sager 8130
(16 items)
 
MAXIMUM Server
(19 items)
 
CPUMotherboardGraphicsRAM
i5 2500K AsRock Extreme3 Gen3 GTX 470 Corsair Vengance (2x4GB) DDR3 
Hard DriveHard DriveHard DriveHard Drive
80GB Intel 320 SSD (Boot) 640GB WD Black (apps) 1TB WD Green (Fraps drive) MAXIMUS Server 
CoolingOSMonitorKeyboard
Corsair H50 Windows 7 Pro x64 HP 25" 1920x1080 Filco Majestouch Tenkeyless Cherry MX Black 
PowerCaseMouseMouse Pad
Antec TP-550 "New" NZXT Switch 810 Razer Mamba Steel Series 9HD 
AudioAudio
Logitech G930 Logitech 2.0 Speakers 
CPUMotherboardGraphicsRAM
i7-2670QM Clevo P151HM1 Base nVidia 560m 8GB 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 240GB Combo Way too weak. Win 7 Pro x64 
MonitorKeyboardPowerCase
15.6” LED Backlit 1920x1080 Super Clear Matte Laptop Keyboard 120W Power Brick Chrome Buran Stealth Black messenger bag 
MouseMouse PadAudioAudio
Logitech G700 Steel Series 4HD Onboard > JDS Labs CMoy > Yuin PK1s or AKG K271s Logitech G930 
CPUMotherboardGraphicsRAM
i7 870 ASUS MAXIMUS III GENE nVidia 440GT GSkill 2x4GB 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
Random 120GB Hitachi 2.5in 500GB  Western Digital Green 1TB Western Digital Green 2TB 
Hard DriveOptical DriveCoolingOS
Western Digital Green 3TB USB3 Samsung SATA BluRay Drive Noctua D14 Win 7 Pro x64 
MonitorKeyboardPowerCase
RDP RDP FSP 350w Fractal Design Define Mini 
MouseMouse PadAudio
RDP Nada Optical Out to 5.0 stereo  
  hide details  
Reply
Fooxz Gamer
(18 items)
 
Sager 8130
(16 items)
 
MAXIMUM Server
(19 items)
 
CPUMotherboardGraphicsRAM
i5 2500K AsRock Extreme3 Gen3 GTX 470 Corsair Vengance (2x4GB) DDR3 
Hard DriveHard DriveHard DriveHard Drive
80GB Intel 320 SSD (Boot) 640GB WD Black (apps) 1TB WD Green (Fraps drive) MAXIMUS Server 
CoolingOSMonitorKeyboard
Corsair H50 Windows 7 Pro x64 HP 25" 1920x1080 Filco Majestouch Tenkeyless Cherry MX Black 
PowerCaseMouseMouse Pad
Antec TP-550 "New" NZXT Switch 810 Razer Mamba Steel Series 9HD 
AudioAudio
Logitech G930 Logitech 2.0 Speakers 
CPUMotherboardGraphicsRAM
i7-2670QM Clevo P151HM1 Base nVidia 560m 8GB 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 240GB Combo Way too weak. Win 7 Pro x64 
MonitorKeyboardPowerCase
15.6” LED Backlit 1920x1080 Super Clear Matte Laptop Keyboard 120W Power Brick Chrome Buran Stealth Black messenger bag 
MouseMouse PadAudioAudio
Logitech G700 Steel Series 4HD Onboard > JDS Labs CMoy > Yuin PK1s or AKG K271s Logitech G930 
CPUMotherboardGraphicsRAM
i7 870 ASUS MAXIMUS III GENE nVidia 440GT GSkill 2x4GB 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
Random 120GB Hitachi 2.5in 500GB  Western Digital Green 1TB Western Digital Green 2TB 
Hard DriveOptical DriveCoolingOS
Western Digital Green 3TB USB3 Samsung SATA BluRay Drive Noctua D14 Win 7 Pro x64 
MonitorKeyboardPowerCase
RDP RDP FSP 350w Fractal Design Define Mini 
MouseMouse PadAudio
RDP Nada Optical Out to 5.0 stereo  
  hide details  
Reply
post #14 of 20
Thread Starter 
I think the root of the problem is still the port not being forward, I've tried running it through the default port (25565) and another like 4200 or something. I always get the same error and every port i try to foward, when I check it with a website it says its closed.

@Topgearfan, thanks I'll try that when I get back home, I'll post the results.
Thanks for all the help.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.61 ASUS p6x58d-e Palit gtx 465 6GB Corsair Dominator 1600Mb 
Hard DriveOptical DriveOSMonitor
Crucial C300 64GB SataIII HP Blue Ray Combo Drive Windows 7 Pro 64 bit Samsung SyncMaster P2250 
PowerCase
XFX Black Edition 850W Coolermaster Storm Sniper 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.61 ASUS p6x58d-e Palit gtx 465 6GB Corsair Dominator 1600Mb 
Hard DriveOptical DriveOSMonitor
Crucial C300 64GB SataIII HP Blue Ray Combo Drive Windows 7 Pro 64 bit Samsung SyncMaster P2250 
PowerCase
XFX Black Edition 850W Coolermaster Storm Sniper 
  hide details  
Reply
post #15 of 20
Thread Starter 
Quote:
Originally Posted by Topgearfan View Post
Try this program. It is what I used and it worked fine after I sent in my router info to them. they didnt have it at the time. http://www.simpleportforwarding.com/
The program did not work, it does the same steps as I have already done, it runs its check and says to port is open, but website checkers still say its closed.

When I try to start the server I get the same error.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.61 ASUS p6x58d-e Palit gtx 465 6GB Corsair Dominator 1600Mb 
Hard DriveOptical DriveOSMonitor
Crucial C300 64GB SataIII HP Blue Ray Combo Drive Windows 7 Pro 64 bit Samsung SyncMaster P2250 
PowerCase
XFX Black Edition 850W Coolermaster Storm Sniper 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.61 ASUS p6x58d-e Palit gtx 465 6GB Corsair Dominator 1600Mb 
Hard DriveOptical DriveOSMonitor
Crucial C300 64GB SataIII HP Blue Ray Combo Drive Windows 7 Pro 64 bit Samsung SyncMaster P2250 
PowerCase
XFX Black Edition 850W Coolermaster Storm Sniper 
  hide details  
Reply
post #16 of 20
Quote:
Originally Posted by mcole254 View Post
The program did not work, it does the same steps as I have already done, it runs its check and says to port is open, but website checkers still say its closed.

When I try to start the server I get the same error.

what OS are you running the server on?
Fooxz Gamer
(18 items)
 
Sager 8130
(16 items)
 
MAXIMUM Server
(19 items)
 
CPUMotherboardGraphicsRAM
i5 2500K AsRock Extreme3 Gen3 GTX 470 Corsair Vengance (2x4GB) DDR3 
Hard DriveHard DriveHard DriveHard Drive
80GB Intel 320 SSD (Boot) 640GB WD Black (apps) 1TB WD Green (Fraps drive) MAXIMUS Server 
CoolingOSMonitorKeyboard
Corsair H50 Windows 7 Pro x64 HP 25" 1920x1080 Filco Majestouch Tenkeyless Cherry MX Black 
PowerCaseMouseMouse Pad
Antec TP-550 "New" NZXT Switch 810 Razer Mamba Steel Series 9HD 
AudioAudio
Logitech G930 Logitech 2.0 Speakers 
CPUMotherboardGraphicsRAM
i7-2670QM Clevo P151HM1 Base nVidia 560m 8GB 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 240GB Combo Way too weak. Win 7 Pro x64 
MonitorKeyboardPowerCase
15.6” LED Backlit 1920x1080 Super Clear Matte Laptop Keyboard 120W Power Brick Chrome Buran Stealth Black messenger bag 
MouseMouse PadAudioAudio
Logitech G700 Steel Series 4HD Onboard > JDS Labs CMoy > Yuin PK1s or AKG K271s Logitech G930 
CPUMotherboardGraphicsRAM
i7 870 ASUS MAXIMUS III GENE nVidia 440GT GSkill 2x4GB 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
Random 120GB Hitachi 2.5in 500GB  Western Digital Green 1TB Western Digital Green 2TB 
Hard DriveOptical DriveCoolingOS
Western Digital Green 3TB USB3 Samsung SATA BluRay Drive Noctua D14 Win 7 Pro x64 
MonitorKeyboardPowerCase
RDP RDP FSP 350w Fractal Design Define Mini 
MouseMouse PadAudio
RDP Nada Optical Out to 5.0 stereo  
  hide details  
Reply
Fooxz Gamer
(18 items)
 
Sager 8130
(16 items)
 
MAXIMUM Server
(19 items)
 
CPUMotherboardGraphicsRAM
i5 2500K AsRock Extreme3 Gen3 GTX 470 Corsair Vengance (2x4GB) DDR3 
Hard DriveHard DriveHard DriveHard Drive
80GB Intel 320 SSD (Boot) 640GB WD Black (apps) 1TB WD Green (Fraps drive) MAXIMUS Server 
CoolingOSMonitorKeyboard
Corsair H50 Windows 7 Pro x64 HP 25" 1920x1080 Filco Majestouch Tenkeyless Cherry MX Black 
PowerCaseMouseMouse Pad
Antec TP-550 "New" NZXT Switch 810 Razer Mamba Steel Series 9HD 
AudioAudio
Logitech G930 Logitech 2.0 Speakers 
CPUMotherboardGraphicsRAM
i7-2670QM Clevo P151HM1 Base nVidia 560m 8GB 
Hard DriveOptical DriveCoolingOS
Corsair Force 3 240GB Combo Way too weak. Win 7 Pro x64 
MonitorKeyboardPowerCase
15.6” LED Backlit 1920x1080 Super Clear Matte Laptop Keyboard 120W Power Brick Chrome Buran Stealth Black messenger bag 
MouseMouse PadAudioAudio
Logitech G700 Steel Series 4HD Onboard > JDS Labs CMoy > Yuin PK1s or AKG K271s Logitech G930 
CPUMotherboardGraphicsRAM
i7 870 ASUS MAXIMUS III GENE nVidia 440GT GSkill 2x4GB 1600mhz 
Hard DriveHard DriveHard DriveHard Drive
Random 120GB Hitachi 2.5in 500GB  Western Digital Green 1TB Western Digital Green 2TB 
Hard DriveOptical DriveCoolingOS
Western Digital Green 3TB USB3 Samsung SATA BluRay Drive Noctua D14 Win 7 Pro x64 
MonitorKeyboardPowerCase
RDP RDP FSP 350w Fractal Design Define Mini 
MouseMouse PadAudio
RDP Nada Optical Out to 5.0 stereo  
  hide details  
Reply
post #17 of 20
Quote:
Originally Posted by Fooxz View Post
you CANNOT use port 80. other programs use port 80.

the reason its "failed to bind to port" is because something else is using that port. (when it "binds" it takes complete usage of it.)

use any other port, one that isn't being used by anything else, forward that port, and you will be GOLDEN.
^ This. It happened on mine too - but I was running two servers. All you have to do is make sure that nothing is using up that port. That being said, it IS an unusual port, so I don't know anything that could be using it. Check the minecraft server config to see if you have the right port selected. Also, make sure you set up an exception in your firewall or put it in "Game-mode"
Icarus
(19 items)
 
   
CPUMotherboardRAMRAM
i5 3570k Asrock H77-m Pro4 Corsair Vengeance Patriot 
RAMHard DriveHard DriveHard Drive
Kingston HyperX Blu Western Digital Red 3x 3TB Intel 310 160GB Western Digital Green 2x 2TB 
OSMonitorPowerCase
Server 2008 R2 Sony KDL55HX750 Corsair Builder Series 400W Silverstone Grandia GD06B 
  hide details  
Reply
Icarus
(19 items)
 
   
CPUMotherboardRAMRAM
i5 3570k Asrock H77-m Pro4 Corsair Vengeance Patriot 
RAMHard DriveHard DriveHard Drive
Kingston HyperX Blu Western Digital Red 3x 3TB Intel 310 160GB Western Digital Green 2x 2TB 
OSMonitorPowerCase
Server 2008 R2 Sony KDL55HX750 Corsair Builder Series 400W Silverstone Grandia GD06B 
  hide details  
Reply
post #18 of 20
Thread Starter 
I figured it out earlier today, the problem wasn't actually the port (it was forwarded properly the whole time). When I was setting up the config file I put my IP in, when I removed it the server works.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.61 ASUS p6x58d-e Palit gtx 465 6GB Corsair Dominator 1600Mb 
Hard DriveOptical DriveOSMonitor
Crucial C300 64GB SataIII HP Blue Ray Combo Drive Windows 7 Pro 64 bit Samsung SyncMaster P2250 
PowerCase
XFX Black Edition 850W Coolermaster Storm Sniper 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 930 @ 3.61 ASUS p6x58d-e Palit gtx 465 6GB Corsair Dominator 1600Mb 
Hard DriveOptical DriveOSMonitor
Crucial C300 64GB SataIII HP Blue Ray Combo Drive Windows 7 Pro 64 bit Samsung SyncMaster P2250 
PowerCase
XFX Black Edition 850W Coolermaster Storm Sniper 
  hide details  
Reply
post #19 of 20
Quote:
Originally Posted by mcole254 View Post
I figured it out earlier today, the problem wasn't actually the port (it was forwarded properly the whole time). When I was setting up the config file I put my IP in, when I removed it the server works.
yea you can't edit that in the server file, leave it default
post #20 of 20
Quote:
Originally Posted by mcole254 View Post
I figured it out earlier today, the problem wasn't actually the port (it was forwarded properly the whole time). When I was setting up the config file I put my IP in, when I removed it the server works.
Was about to mention this.

Any time you specify a specific IP and your PC doesn't have that IP allocated, you won't be able to bind the IP->port association and it won't be contactable from anywhere.
Waiting on X399
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II B57 @ X4 3.9 Gigabyte 790FXTA-UD5 Sapphire Radeon 290 8 GB G.Skill 2133 
Hard DriveCoolingOSKeyboard
250 GB 840 EVO Noctua NH-D14 Windows 10 Logitech K350 
PowerCaseMouseMouse Pad
Seasonic x750 Corsair 600T Logitech G100s Razer Goliathus Speed 
Audio
Plantronics Gamecom 788 
  hide details  
Reply
Waiting on X399
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II B57 @ X4 3.9 Gigabyte 790FXTA-UD5 Sapphire Radeon 290 8 GB G.Skill 2133 
Hard DriveCoolingOSKeyboard
250 GB 840 EVO Noctua NH-D14 Windows 10 Logitech K350 
PowerCaseMouseMouse Pad
Seasonic x750 Corsair 600T Logitech G100s Razer Goliathus Speed 
Audio
Plantronics Gamecom 788 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Having trouble setting up MC server (port forward)