Overclock.net › Forums › Industry News › Software News › [CREATIVE] Creative releases beta drivers for X-fi Titanium series
New Posts  All Forums:Forum Nav:

[CREATIVE] Creative releases beta drivers for X-fi Titanium series - Page 3

post #21 of 25
Thread Starter 
Quote:
Originally Posted by Robilar View Post
Any word on what updates it will provide?
No no acutally they have been updating these beta drivers for OEM's and releasing it weekly and every week they are changing the log and not updating from the previous log. The one i downloaded before on 27th May fixes longer shutdown issues after installing service pack 1 which is not mentioned now. Don't know what else they would have fixed. All i can say is my Creative Console launcher is super fast and beta version of that is also available i'll update the post.
Edited by meetajhu - 6/10/11 at 4:21am
post #22 of 25
Quote:
Originally Posted by meetajhu View Post
Disable on-board audio. And in device manager disable high defintion audio. The stable creative drivers has 0 problems. I have seen many people with problem and i have fixed it.
Trying this now with the Beta drivers and console.
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
post #23 of 25
After trying your fix, it worked... for a while. Now I have no audio but everything is installed. The drivers were crashing in Medal of Honor multiplayer so now I need to reinstall them again.
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
Phantom
(25 items)
 
  
CPUMotherboardGraphicsGraphics
AMD FX 8320 Asus Crosshair Formula V EVGA GTX 660 Sig 2 EVGA GTX 660 Sig 2 
RAMHard DriveHard DriveHard Drive
G.Skill 8 GBs DDR3 Seagate Samsung OCZ Solid 3 
Hard DriveOptical DriveCoolingCooling
OCZ Solid 3 Samsung DVD RW with Lightscribe XSPC Dual bay pump/res XSPC Delta V3 CPU Block 
CoolingCoolingCoolingOS
Phobya Compression Fittings Black Ice Xtreme II 240mm Radiator Koolance BKT-HX001 Radiator Mounting Bracket Various versions of Linux 
OSMonitorMonitorKeyboard
Windows of some sort Acer 27" LED LCD  Samsung 19" LCD Saitek Cyborg 
PowerCaseMouseAudio
HEC 1080 800 watt NZXT Phantom Logitech M570 Wireless Trackball Philips AmBX Complete System 
Audio
Creative Omni Sound Blaster USB 
  hide details  
Reply
post #24 of 25
Quote:
Originally Posted by meetajhu View Post
No no acutally they have been updating these beta drivers for OEM's and releasing it weekly and every week they are changing the log and not updating from the previous log. The one i downloaded before on 27th May fixes longer shutdown issues after installing service pack 1 which is not mentioned now. Don't know what else they would have fixed. All i can say is my Creative Console launcher is super fast and beta version of that is also available i'll update the post.
Is THAT what was causing the long shutdown times in sp1? I could not for the life of me figure out what was causing it and ended up doing a fresh install without sp1. Not sure I even care to try SP1 again, even if these do claim to have fixed the issue. Restarting in 20 seconds is nice, I'd rather not give it up
Chunk
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k Gigabyte Z170XP-SLI-CF ASUS ROG Strix 1080OC Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz 
Hard DriveOptical DriveCoolingOS
Sandisk Ultra II 960 lolno Noctua NH-D14 Windows 10 1511 
MonitorMonitorKeyboardPower
Dell 3415W UWQHD Dell U2312HM 23" LED IPS Logitech G710+ Corsair AX-850 
CaseMouseMouse PadAudio
Corsair 650D Logitech Proteus Spectrum SteelSeries QcK Creative Sound Blaster Z 
  hide details  
Reply
Chunk
(16 items)
 
  
CPUMotherboardGraphicsRAM
i5-6600k Gigabyte Z170XP-SLI-CF ASUS ROG Strix 1080OC Vengeance LPX 16GB (2x8GB) DDR4 DRAM 3000MHz 
Hard DriveOptical DriveCoolingOS
Sandisk Ultra II 960 lolno Noctua NH-D14 Windows 10 1511 
MonitorMonitorKeyboardPower
Dell 3415W UWQHD Dell U2312HM 23" LED IPS Logitech G710+ Corsair AX-850 
CaseMouseMouse PadAudio
Corsair 650D Logitech Proteus Spectrum SteelSeries QcK Creative Sound Blaster Z 
  hide details  
Reply
post #25 of 25
Thread Starter 
Quote:
Originally Posted by tout View Post
After trying your fix, it worked... for a while. Now I have no audio but everything is installed. The drivers were crashing in Medal of Honor multiplayer so now I need to reinstall them again.
Stop using Ccleaner and registry cleaners. If your audio goes after few days you have done something wrong nothing to blame drivers.Everything is fine for me and everyone. Have you installed the beta console launcher?
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Software News
Overclock.net › Forums › Industry News › Software News › [CREATIVE] Creative releases beta drivers for X-fi Titanium series