Overclock.net › Forums › Components › Power Supplies › Did my power supply die?
New Posts  All Forums:Forum Nav:

Did my power supply die?

post #1 of 2
Thread Starter 
Hello everyone I am brand new to the forum and need some expert advice. I just built a new computer last night and ran into some unexpected problems. I have built plenty of computers in the past and I am a IT tech guy but have never came across this. When I finished the build last night I went to turn it on and it powered on for less than a half of a second then shut off. I tired to turn it on again but was unresponsive unless I cleared the cmos (I have a button on my motherboard) and did the same thing when I did that. I am guessing my power supply isn't big enough. I tried to do this 8 or 9 times and unplugged some fans for less power consumption but still had no response. Now the computer wont even boot up for a half a second and I think I blew the PSU. All the lights on the board are still lit up when it's plugged in the board and not on which doesn't make sense if the psu is bad. But I tried unplugging everything and used a paper clip method to try to fire up the psu and got no response. Any guesses on what the problem could be??

Specs:
Board: ASUS Crosshair IV Formula AM3 AMD 890FX
Card:SAPPHIRE FleX 100312FLEX Radeon HD 6950 2GB 256-bit
PSU: 750w (couple years old, cant think of the name I'm at work)
Memory: G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600
CPU:AMD Phenom II X6 1100T Black Edition Thuban 3.3GHz
Liquid cooling: ThermalTake Big Water 760i Liquid Cooling System Kit
Peripherals: NZXT Sentry-2 5.25" Touch Screen fan controller, CD-RW.
Fans: Scythe "ULTRA KAZE" 120 x 38 mm Case Fan 120mm, 2x NZXT FN-140RB 140mm Case Fan, XIGMATEK Cooling System XLF 140mm, Thermaltake 230mm fan, another 140mm fan.(I went overkill on the fans)
Case: Thermaltake Armor Full-Tower ATX Case

Thanks for your help!
post #2 of 2
Thread Starter 
I forgot I also have these led's from xoxide.com:
12in Dual Red Cold Cathode Kit
Logisys 15in Cold Cathode w/ Sound Module
LED Acrylic Footstep Mod
Logisys Jumbo UV Lazer LED
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Did my power supply die?