Overclock.net › Forums › Cooling › Water Cooling › H70 Help
New Posts  All Forums:Forum Nav:

H70 Help

post #1 of 3
Thread Starter 
Hi all,
Today sig rig arrived
ITs all great, but the H70 is killing my ears on idle.
What the guys at the shop did is that they plugged the pump into CPU_FAN. They plugged one of the H70 fans unto Chassis Fan, and the other is going to a 12v molex which is fricken killing me. Somehow they connected my top 2 megaflow fans to one header with an adapter. Please help me quiet this beast.
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
post #2 of 3
There is a 2-to-1 adapter in the box, use that and put them both into chassis fan, you can put the pump into the 12v molex though.
Edited by Scrappy - 6/10/11 at 10:48pm
Herp
(1 item)
 
  
Other
Dolla Billz Yall! 
  hide details  
Reply
Herp
(1 item)
 
  
Other
Dolla Billz Yall! 
  hide details  
Reply
post #3 of 3
Thread Starter 
Done. Much quieter now
Thanks all.
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
i7 2600K Stock ASUS Sabertooth P67 B3 ASUS GTX580 DirectCUII G. Skill Ripjaws X 8GB (2x4) 1600MHZ CL9 
Hard DriveOSPowerCase
WD Blue 500GB W7 Corsair TX850w V2 Cooler Master HAF-X 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Water Cooling
Overclock.net › Forums › Cooling › Water Cooling › H70 Help