Overclock.net › Forums › Graphics Cards › Graphics Cards - General › thermal past fry card?
New Posts  All Forums:Forum Nav:

thermal past fry card?

post #1 of 5
Thread Starter 
The bold parts are the important parts

I have a bit of a odd problem.. 18 month old Sapphire 5770 I go to add my danger den maze 4 water block to... I make some custom brackets to mount it. As I take my pc apart, I notice my cpu block has a tiny leak at the o-rings (5-6year old DD RBX)... The video card and mobo are dry, so I think "good caught the leak JUST in time). I remove the video cards heat sink, install water block, cut and angle lines how I need, remove water block, tighten hose clamps, and reinstall water block with the card in the pc...

During this process AS5 gets smeared all over the capacitors/resistors whatever they are around the gpu core. I can't see this however. I try booting the pc, nothing. Just a black screen. No sounds, nothing.

My motherboard is a MSI gd70 790fx, and has a display on it, if I remember right, it displays 2c and that's where its stuck. That code means its loading Video..

I tried clearing cmos, tried booting it like 20 times, nothing. Slap my girlfriends gigabyte 5770 from her pc, and it works fine. So I assume my card died from the water or just from being miss handled in general.

But when I remove the water block I notice thermal paste all over exposed resistors around the core.. So I clean it really good, put new paste on, slap on the stock air cooler, put it in my giirls pc, it boots fine, I think "awesome,its fixed"... errr wrong.. Once it gets passed bios, windows doesn't load... Screen goes black, but windows DOES make the boot up sound, so the system isn't hanging... It's just not displaying anything..

So, can a card be "fried" to the point it'll load bios but not windows?? I haven't put the card back in my pc yet, as its a huge pain with the water cooling in my way, plus my girlfriend is currently buisy in a warcraft raid on my pc... a raid that I'm missing since I have no card

Or do you think there is still hope for my card??
    
CPUMotherboardGraphicsGraphics
AMD phenom II 965be c3 MSI 790FX-GD70 AM3 MSI 6870 MSI 6870 
RAMHard DriveOSMonitor
16GB G.SKILL 1600@8-8-8-24 1TB Seagate Barracuda 7200 Windows 7 22" AOC LED monitor, and a 22" LCD dell.  
Power
OCZ StealthXStream 700w 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
AMD phenom II 965be c3 MSI 790FX-GD70 AM3 MSI 6870 MSI 6870 
RAMHard DriveOSMonitor
16GB G.SKILL 1600@8-8-8-24 1TB Seagate Barracuda 7200 Windows 7 22" AOC LED monitor, and a 22" LCD dell.  
Power
OCZ StealthXStream 700w 
  hide details  
Reply
post #2 of 5
Hmmm, it might actually be your drivers. Sometimes issues can pile on, and for some completely random reason the driver isn't picking it up MAYBE. Do you have an onboard video connector to test windows?

Somebody correct me if im wrong.
post #3 of 5
Thread Starter 
Quote:
Originally Posted by InerTia* View Post
Hmmm, it might actually be your drivers. Sometimes issues can pile on, and for some completely random reason the driver isn't picking it up MAYBE. Do you have an onboard video connector to test windows?

Somebody correct me if im wrong.
On my girls pc I tried uninstalling her 5770 drivers then putting my card in and had the same problem. I however didn't try safe mode, OR installing new drivers.
    
CPUMotherboardGraphicsGraphics
AMD phenom II 965be c3 MSI 790FX-GD70 AM3 MSI 6870 MSI 6870 
RAMHard DriveOSMonitor
16GB G.SKILL 1600@8-8-8-24 1TB Seagate Barracuda 7200 Windows 7 22" AOC LED monitor, and a 22" LCD dell.  
Power
OCZ StealthXStream 700w 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
AMD phenom II 965be c3 MSI 790FX-GD70 AM3 MSI 6870 MSI 6870 
RAMHard DriveOSMonitor
16GB G.SKILL 1600@8-8-8-24 1TB Seagate Barracuda 7200 Windows 7 22" AOC LED monitor, and a 22" LCD dell.  
Power
OCZ StealthXStream 700w 
  hide details  
Reply
post #4 of 5
I would try booting in safe mode because that will run basic display drivers.
post #5 of 5
Thread Starter 
disregard my thread, IT WORKS! wwoot! lol

Time to put my girls pc back together, and get some water on my 5770
    
CPUMotherboardGraphicsGraphics
AMD phenom II 965be c3 MSI 790FX-GD70 AM3 MSI 6870 MSI 6870 
RAMHard DriveOSMonitor
16GB G.SKILL 1600@8-8-8-24 1TB Seagate Barracuda 7200 Windows 7 22" AOC LED monitor, and a 22" LCD dell.  
Power
OCZ StealthXStream 700w 
  hide details  
Reply
    
CPUMotherboardGraphicsGraphics
AMD phenom II 965be c3 MSI 790FX-GD70 AM3 MSI 6870 MSI 6870 
RAMHard DriveOSMonitor
16GB G.SKILL 1600@8-8-8-24 1TB Seagate Barracuda 7200 Windows 7 22" AOC LED monitor, and a 22" LCD dell.  
Power
OCZ StealthXStream 700w 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Graphics Cards - General
Overclock.net › Forums › Graphics Cards › Graphics Cards - General › thermal past fry card?