Overclock.net › Forums › Components › Power Supplies › Corsair TX650W not enough?
New Posts  All Forums:Forum Nav:

Corsair TX650W not enough? - Page 2

post #11 of 13
Thread Starter 
Ok, I think I found what is wrong... One of the cords melted apparently and now I have an exposed copper wire. Funny thing is it's the 4 pins wires and it's not really plugged into anything except that side fan I had, which I unplugged because it's my case cover. It melted through the fishnet wire covering!
http://img89.imageshack.us/img89/3933/dsc0014oa.jpg
Sorry my phone sucks at focusing.
RMA then? I had this PSU for about over a year.

Geez and I thought it was the PSU frying...it was actually the wire melting that was causing so much smoke.
Edited by Kiros - 6/11/11 at 5:06pm
Anatolii
(14 items)
 
Kirovskaya
(8 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6900K@4.4ghz Gigabyte X99 Designare EX EVGA 1080 Ti FE GSkill TridentZ 64GB DDR4 3200mhz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 EVO 500gb Samsung 950 Pro 512GB Samsung 850 EVO 1TB Mushkin Reactor 1TB 
CoolingOSMonitorPower
EK/Bitpower Custom Loop Windows 10 Pro Samsung 55KS8500 4K Seasonic SilentSnow 1050w 
CaseAudio
Caselabs White SMA8 Logitech Z-5500 
CPUMotherboardGraphicsRAM
Intel i5 4690T ASRock Anniversary Z97 EVGA 1070 GTX Superclocked G Skill 16gb 2400mhz 
Hard DriveCoolingOSMonitor
Samsung Evo 250 GB Coolermaster Hyper 212+ Windows 7 Home Premium 64bit Qnix 2710 Multiport 
  hide details  
Reply
Anatolii
(14 items)
 
Kirovskaya
(8 items)
 
 
CPUMotherboardGraphicsRAM
Intel i7 6900K@4.4ghz Gigabyte X99 Designare EX EVGA 1080 Ti FE GSkill TridentZ 64GB DDR4 3200mhz 
Hard DriveHard DriveHard DriveHard Drive
Samsung 840 EVO 500gb Samsung 950 Pro 512GB Samsung 850 EVO 1TB Mushkin Reactor 1TB 
CoolingOSMonitorPower
EK/Bitpower Custom Loop Windows 10 Pro Samsung 55KS8500 4K Seasonic SilentSnow 1050w 
CaseAudio
Caselabs White SMA8 Logitech Z-5500 
CPUMotherboardGraphicsRAM
Intel i5 4690T ASRock Anniversary Z97 EVGA 1070 GTX Superclocked G Skill 16gb 2400mhz 
Hard DriveCoolingOSMonitor
Samsung Evo 250 GB Coolermaster Hyper 212+ Windows 7 Home Premium 64bit Qnix 2710 Multiport 
  hide details  
Reply
post #12 of 13
Defintely RMA.
post #13 of 13
Probably the fan's fault. It may have short circuited, and the TX650's lack of OCP let the wire burn.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Power Supplies
Overclock.net › Forums › Components › Power Supplies › Corsair TX650W not enough?