Overclock.net › Forums › AMD › AMD Motherboards › 6870 crossfire on CH IV Formula board results in blackscreen
New Posts  All Forums:Forum Nav:

6870 crossfire on CH IV Formula board results in blackscreen

post #1 of 8
Thread Starter 
System works fine on each card independent of the other.

As soon as the 2nd card is added, it will make it to desktop once, then blackscreen in a few seconds.. then it blackscreens every restart, usually after the Welcome screen, until the second card is removed. It WILL however still boot to desktop in safe mode. As soon as the 2nd card is removed, it boots up fine.


Is it worth trying an update to the 1902 BIOS for the board?


PSU issues have been suggested, but this happened on a Corsair HX650, and to be extra sure I upgraded to their AX1200 and it's still occurring.

Overheating seems likely to cause things like this but my case is not crowded, and my cards stay cool under load. The case is a Lian Li item with massive airflow so I shouldn't have any worries there.

Single monitor plugged in to a DVI port on the card in slot 1.



Cards are in red slots 1 and 3, where ASUS recommended.


This problem seems to happen a lot, and people have been dancing around solutions all over the internet with no firm results.

If anyone can shed any light on this issue I would be incredibly grateful.

Sam
Edited by savage1987 - 6/11/11 at 5:33pm
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
post #2 of 8
maybe the board cant support 8670s since they dont exist?
GodofDeath
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7 970 Asus Rampage III Formula EVGA GTX 460 1gb SSC+ SLI EVGA GTX 460 1gb SSC+ SLI 
RAMHard DriveHard DriveOptical Drive
Dominators GT Red 3x2gb 7-7-7-20 G.Skill Pheonix Pro 120gb WD1002FAEX 1tb ASUS 
CoolingOSMonitorKeyboard
Thermaltake Venomous X Black Windows 7 Professional Dell U2311H Filco 104 Brown 
PowerCaseMouseMouse Pad
Seasonic X750 Lian Li A05NB Powdercoated/Modded Logitech G500 Razer Sphex 
  hide details  
Reply
GodofDeath
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7 970 Asus Rampage III Formula EVGA GTX 460 1gb SSC+ SLI EVGA GTX 460 1gb SSC+ SLI 
RAMHard DriveHard DriveOptical Drive
Dominators GT Red 3x2gb 7-7-7-20 G.Skill Pheonix Pro 120gb WD1002FAEX 1tb ASUS 
CoolingOSMonitorKeyboard
Thermaltake Venomous X Black Windows 7 Professional Dell U2311H Filco 104 Brown 
PowerCaseMouseMouse Pad
Seasonic X750 Lian Li A05NB Powdercoated/Modded Logitech G500 Razer Sphex 
  hide details  
Reply
post #3 of 8
Try updating to the latest BIOS for your mobo. Driversweep and reinstall Catalyst, then see what happens.

Quote:
Originally Posted by godofdeath View Post
maybe the board cant support 8670s since they dont exist?
Sarcasm? Obviously he means 6870s.
 
ThinkPad W510
(12 items)
 
The Arkbird
(14 items)
 
CPUGraphicsRAMHard Drive
i7 3840QM Quadro K2000M 4x8gb Intel 525 Series 240gb mSATA 
Optical DriveCoolingOSMonitor
Tray-load DVD Factory Windows 7 Pro 1080P "Ultrasharp" panel 
KeyboardPowerCase
Integrated Big 'ol brick M4700 chassis 
CPUMotherboardGraphicsRAM
i7 820QM 4318-CTO Quadro FX 880M 4x4gb 
Hard DriveOptical DriveCoolingOS
X-25M G2 DVD Stock Arch x64 
MonitorKeyboardPowerMouse
1080P touch screen IPS Clicky Brick Adapter UltraNav 
CPUMotherboardGraphicsRAM
4x Xeon E7440s HP DL580 G3 Motherboard Rev. 1.1 ATi Rage XL Samsung ECC DDR2 
Hard DriveOptical DriveCoolingOS
15K HP Ultra320 SCSI DVD Burner Bare Heatsinks + Chassis Airflow The Ever-Changing Distro... 
MonitorPowerCase
Only For Diagnostics.. 2x1300w (Redundant, Delta OEM) HP 4U Rackmount 
  hide details  
Reply
 
ThinkPad W510
(12 items)
 
The Arkbird
(14 items)
 
CPUGraphicsRAMHard Drive
i7 3840QM Quadro K2000M 4x8gb Intel 525 Series 240gb mSATA 
Optical DriveCoolingOSMonitor
Tray-load DVD Factory Windows 7 Pro 1080P "Ultrasharp" panel 
KeyboardPowerCase
Integrated Big 'ol brick M4700 chassis 
CPUMotherboardGraphicsRAM
i7 820QM 4318-CTO Quadro FX 880M 4x4gb 
Hard DriveOptical DriveCoolingOS
X-25M G2 DVD Stock Arch x64 
MonitorKeyboardPowerMouse
1080P touch screen IPS Clicky Brick Adapter UltraNav 
CPUMotherboardGraphicsRAM
4x Xeon E7440s HP DL580 G3 Motherboard Rev. 1.1 ATi Rage XL Samsung ECC DDR2 
Hard DriveOptical DriveCoolingOS
15K HP Ultra320 SCSI DVD Burner Bare Heatsinks + Chassis Airflow The Ever-Changing Distro... 
MonitorPowerCase
Only For Diagnostics.. 2x1300w (Redundant, Delta OEM) HP 4U Rackmount 
  hide details  
Reply
post #4 of 8
Thread Starter 
oops. 6870s is indeed what I meant. I will try the 1902 BIOS, hopefully it doesn't cause dramas by defaulting HDDs to AHCI or anything stupid like that
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
post #5 of 8
Try putting the monitor on the other card.
HTPC
(11 items)
 
  
CPUMotherboardRAMHard Drive
AMD A-3870K AsRock A75 Pro (FM1) HyperX DDR3 1866 8 GB SAMSUNG 830 256gb 
Hard DriveOptical DriveCoolingOS
SAMSUNG EcoGreen F4 2TB Plextor Black Blu-ray Burner Phenom II X4 stock Cooler Windows 10 
MonitorPowerCase
LG M2762D-PM Glossy Black 27" 5ms (1920x1080) Antec HG 900 Gerenic ATX Case 
  hide details  
Reply
HTPC
(11 items)
 
  
CPUMotherboardRAMHard Drive
AMD A-3870K AsRock A75 Pro (FM1) HyperX DDR3 1866 8 GB SAMSUNG 830 256gb 
Hard DriveOptical DriveCoolingOS
SAMSUNG EcoGreen F4 2TB Plextor Black Blu-ray Burner Phenom II X4 stock Cooler Windows 10 
MonitorPowerCase
LG M2762D-PM Glossy Black 27" 5ms (1920x1080) Antec HG 900 Gerenic ATX Case 
  hide details  
Reply
post #6 of 8
Thread Starter 
I will try plugging the monitor into the 2nd card next time I have 2 in the case again. In all 4 ports, for that matter.

I flashed the BIOS to 1902, and it just hangs at the Windows logo screen. I forgot to driver sweep. I'll sweep and reinstall them with one card in, then go back to 2.
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
post #7 of 8
Thread Starter 
got me completely stuffed. Started working fine, booting into Windows with crossfire setup complete.

Just installed a new copy of Windows 7 HomePremium, 64bit this time. Updating it now, hopefully it doesn't kill itself and I can get this system stable and good to go for some overclocking love.
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
post #8 of 8
Thread Starter 
OK I'm getting a feeling it might be a hardware issue with one of the cards.

Reasoning:

Crossfire failed to boot to windows (hung at logo screen).
Tried a single card in slot 3.
Logo screen had weird colours on the right hand half as the logo came together (left side was normal), then blackscreened, then BSOD'd.
Restarted a few times to make doubly sure it was going to stay this way. It did.

Swapped cards, still in slot 3.
Booted to desktop fine.





HOWEVER:

the same sequence of events happened earlier in the day, and upon swapping the cards back again it worked fine.

I don't really want to sit here and swap cards over all night (again..) so I'm going to call it a suspect card and be semi-happy with that diagnosis.

The tragedy of the situation is that I'm not 100% sure where the receipt for all this gear is. I will get in contact with the supplier (online - pccasegear.com) and see if they have it on record and can help me out with a warranty swap.


This is really the only thing I can think of to progress from here. Until then I will just deal with life on a single card, which is a real shame.


If anyone has any other hypotheses, please do share!
Sam
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
AMD gamer
(17 items)
 
  
CPUMotherboardGraphicsRAM
FX-8350 Gigabyte 970A-D3P HIS Radeon HD7970 3GB 12GB Corsair Dominator GT 2000CL9 
Hard DriveHard DriveHard DriveOptical Drive
240GB SanDisk Extreme SSD 1TB WD Caviar Black 2TB WD Green ASUS 24x DVDRW 
CoolingOSMonitorKeyboard
Noctua NH-D14 Windows 7 Home Premium 64bit 27" ASUS VE278H Saitek Eclipse II 
PowerCaseMouseAudio
Corsair HX1050 Lian Li Armoursuit PC-P50R R.A.T.3 Logitech X530 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › 6870 crossfire on CH IV Formula board results in blackscreen