Overclock.net › Forums › Intel › Intel - General › Low FPS in all games
New Posts  All Forums:Forum Nav:

Low FPS in all games

post #1 of 77
Thread Starter 
So after upgrading my sytem from a AMD 955 to a Intel core i7, my FPS have dropped significantly. My system was the same as before and after, except for the screen resolution. Specs Below:

Core i7 950 @ 3GHz
Asus Sabertooth X58 Mobo (The First 3 DIMM slots are dead, so I had to use the secondary ones)
ATI Radeon 5850
6GB of Gskill 1333MHz DDR3 memory
1 TB Western Digital Caviar Black
Tech NPS 750W power supply

The problem is used to, I would get at least 60FPS usually more on pretty much anything short of Crysis. Though it all did run at 1680x1050 where now it runs at 1920x1080. Still, now on pretty much any game, even old ones, I get 20FPS on anything made in the last 2 years at a maximum. And 25-40FPS on anything older at a maximum.

Is it just that the 5850 doesn't have the power to run games at the Res and should I get a new GFX card or is it something else. CPU is not overheating or throttling and neither is the card. The CPU has not been OC'ed very much and I reset it to stock after awhile. The 5850 has been OC'ed to attempt to get more FPS, it doesn't matter. OCing the proc or card gives it maybe 1 or 2 extra FPS. Also when I start the PC I get a no Virtual Disk detected. Any help would be great. Thanks, also examples of games with low FPS are below:

Starcraft II (20ish FPS)
RIFT (20-30FPS)
World of Tanks (20-30FPS)
Napoleon and Shogun 2 Total War (Both get 10-20FPS on the Campaign map)
Company of Heroes (30FPS)
Neverwinter Nights 2 (25FPS)
post #2 of 77
Did you reinstall windows when you swapped?
post #3 of 77
Thread Starter 
Quote:
Originally Posted by SpeedNuggeT;13841031 
Did you reinstall windows when you swapped?

Yes I did
post #4 of 77
Is the card running at 16x, in the top slot?
post #5 of 77
yeah something is limiting the processor or the gpu
take a snapshot of the services
Deep Green
(13 items)
 
  
CPUMotherboardGraphicsRAM
X6 @ 4GHz 990FXA-UD5 6870 Crossfire 2x4GB Corsair Vengeance 1866MHz 
Hard DriveMonitorPowerCase
Agility 2 and 3 3x 22" Eyefinity GX 750w CoolerMaster Sniper (AMD Custom) 
  hide details  
Reply
Deep Green
(13 items)
 
  
CPUMotherboardGraphicsRAM
X6 @ 4GHz 990FXA-UD5 6870 Crossfire 2x4GB Corsair Vengeance 1866MHz 
Hard DriveMonitorPowerCase
Agility 2 and 3 3x 22" Eyefinity GX 750w CoolerMaster Sniper (AMD Custom) 
  hide details  
Reply
post #6 of 77
Thread Starter 
Quote:
Originally Posted by SpeedNuggeT;13841093 
Is the card running at 16x, in the top slot?

Yep
Edited by Raji8 - 6/11/11 at 10:44pm
post #7 of 77
Do you have the latest drivers installed?? , Make sure your connections are correct ( 6 pin pcie is not sticking out half ways ) How are your cpu temps? maybe spyware or your HDD needs to be defrag'd ( im trying to think of anything )
The Beast
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7 5960X 4.4Ghz Asrock Extreme4 x99 EVGA SC Titan X  GTX 780 PhysX 
RAMHard DriveOptical DriveCooling
16 GB DDR4 2x Samsung 840 480gb, Intel 730 480gb and 2TB W... Bluray 12x 3D NH-D15 
OSMonitorKeyboardPower
Windows 7 64 bit Epson 3D 6030D THX Front projector 140" Logitech G710+ Corsair AX1200i 
CaseMouseMouse PadAudio
Custom G600 SteelSeries Custom Speakers 
  hide details  
Reply
The Beast
(16 items)
 
  
CPUMotherboardGraphicsGraphics
i7 5960X 4.4Ghz Asrock Extreme4 x99 EVGA SC Titan X  GTX 780 PhysX 
RAMHard DriveOptical DriveCooling
16 GB DDR4 2x Samsung 840 480gb, Intel 730 480gb and 2TB W... Bluray 12x 3D NH-D15 
OSMonitorKeyboardPower
Windows 7 64 bit Epson 3D 6030D THX Front projector 140" Logitech G710+ Corsair AX1200i 
CaseMouseMouse PadAudio
Custom G600 SteelSeries Custom Speakers 
  hide details  
Reply
post #8 of 77
Thread Starter 
Quote:
Originally Posted by Toology;13841175 
Do you have the latest drivers installed?? , Make sure your connections are correct ( 6 pin pcie is not sticking out half ways ) How are your cpu temps? maybe spyware or your HDD needs to be defrag'd ( im trying to think of anything )

Yeah latest drivers are installed. Everything is correct, HDD has beed Defragged yesterday and no spyware is present
post #9 of 77
Seems to me like your card is stuck in 2D clock mode with games. You might try to check that.
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
    
CPUMotherboardGraphicsRAM
INTEL ASUS XFX  SAMSUNG 
Hard DriveOptical DriveCoolingOS
WD/ST LG KUHLER WINDOWS 
MonitorKeyboardPowerCase
LG/SAMSUNG IBM MODEL M CORSAIR THERMALTAKE 
MouseMouse PadAudio
MS INTELLIMOUSE EXPLORER 3.0 REGULAR LARGE PAD ONBOARD but it USED TO BE A XONAR DG  
  hide details  
Reply
post #10 of 77
Thread Starter 
Quote:
Originally Posted by GanjaSMK;13841324 
Seems to me like your card is stuck in 2D clock mode with games. You might try to check that.

Nope, it kicks over to the 3d clocks when I run a game.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Intel - General
Overclock.net › Forums › Intel › Intel - General › Low FPS in all games