Overclock.net › Forums › Graphics Cards › NVIDIA › SLI and Bad Company 2
New Posts  All Forums:Forum Nav:

SLI and Bad Company 2

post #1 of 8
Thread Starter 
Hi, I upgraded to a 580 SLI setup. I'm very impressed with the performance so far, however I have quite a major problem with BC2.

Some parts of the game do not get rendered properly. Here are the list of symptoms that I'm getting (some of them happen at the same time):

- Enemies are not rendered (I can just see a floating gun walking around)
- Massive black "streaks" or "tears" going across the screen when I zoom in
- Parts of enemies are not rendered, i.e. their head.
- Fences are not rendered (I walk forward only to find I'm bumping in to something invisible)

Some maps seem to show the symptoms much more often than others. Port Valdez seems to be the worst.

I thought that it may be an unstable/faulty new card that I bought, however the SLI setup works absolutely fine in every other game I play. Even Crysis 1, which is the ultimate stability test (for me anyway) does not crash after hours and hours of gameplay. I simply do not believe that the 2nd card is faulty, and there is a bug involving SLI.

I was going to try running the game on the 2nd GPU, however I'm not sure how to do this; I can't remove the 1st card since it's liquid cooled and held securely in place. Would setting the 1st GPU to a dedicated PhysX processor force the system to run all games exclusively on the 2nd GPU?

Any help would be great,

Cheers.
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
post #2 of 8
Run multi GPU furmark just to be sure that there is no hardware level issue.

What drivers are you using?
     
CPUMotherboardGraphicsRAM
Intel Core i5 3570k @ 4.6GHz Asus Sabertooth Z77 MSI GTX970 Corsair Vengeance LP 8GB 
Hard DriveHard DriveCoolingCooling
Samsung SSD 120GB Samsung 2.5" HDD 500GB EK Supremacy Clear CQC w/White LED's 360mm Alphacool Rad 
OSKeyboardPowerCase
Win 10 CM Storm mechanical Antec 620W Corsair Obsidian 450D 
MouseMouse Pad
Corsair M65 RGB Roccat  
CPUGraphicsRAMHard Drive
Intel i5 4210H Nvidia GTX 960M 2GB 8GB  1TB+8GB HDSDD 
OS
Win 10 
  hide details  
Reply
     
CPUMotherboardGraphicsRAM
Intel Core i5 3570k @ 4.6GHz Asus Sabertooth Z77 MSI GTX970 Corsair Vengeance LP 8GB 
Hard DriveHard DriveCoolingCooling
Samsung SSD 120GB Samsung 2.5" HDD 500GB EK Supremacy Clear CQC w/White LED's 360mm Alphacool Rad 
OSKeyboardPowerCase
Win 10 CM Storm mechanical Antec 620W Corsair Obsidian 450D 
MouseMouse Pad
Corsair M65 RGB Roccat  
CPUGraphicsRAMHard Drive
Intel i5 4210H Nvidia GTX 960M 2GB 8GB  1TB+8GB HDSDD 
OS
Win 10 
  hide details  
Reply
post #3 of 8
Thread Starter 
I'm using the 275.33 drivers.
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
post #4 of 8
Have you properly uninstalled your last drivers and reinstall the latest drivers? (even if they are the same its better to do it)
Animal Mother
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 2600k 4.5Ghz 1.368v  Gigabyte Z68X UD3H B3 ver. 1.3 MSI GTX 780 Ti Twin Frozr IV @ 1180Mhz 16GB Kingston Hyperx Savage 1600Mhz 9.9.9.27 1.5v 
Hard DriveCoolingOSMonitor
Kingston UV400 240GB SSD, WD 3x640GB, 1TB & 3TB  Noctua NHU12P SE2 w/ KAZE 1200RPM & 1800RPM Windows 10 x64 Samsung P2450H 24" 
KeyboardPowerCaseMouse
Redragon Karuna Corsair TX750W V2 Cooler Master 690 II Advanced Redragon Pegasus 
Mouse PadAudio
SteelSeries QcK XFi Gamer Fatality Pro + Plantronics Gamecom 777 
  hide details  
Reply
Animal Mother
(14 items)
 
  
CPUMotherboardGraphicsRAM
I7 2600k 4.5Ghz 1.368v  Gigabyte Z68X UD3H B3 ver. 1.3 MSI GTX 780 Ti Twin Frozr IV @ 1180Mhz 16GB Kingston Hyperx Savage 1600Mhz 9.9.9.27 1.5v 
Hard DriveCoolingOSMonitor
Kingston UV400 240GB SSD, WD 3x640GB, 1TB & 3TB  Noctua NHU12P SE2 w/ KAZE 1200RPM & 1800RPM Windows 10 x64 Samsung P2450H 24" 
KeyboardPowerCaseMouse
Redragon Karuna Corsair TX750W V2 Cooler Master 690 II Advanced Redragon Pegasus 
Mouse PadAudio
SteelSeries QcK XFi Gamer Fatality Pro + Plantronics Gamecom 777 
  hide details  
Reply
post #5 of 8
Thread Starter 
Quote:
Originally Posted by Cryptedvick View Post
Have you properly uninstalled your last drivers and reinstall the latest drivers? (even if they are the same its better to do it)
Yes, did the old Uninstall, boot in to safe mode, use driver sweeper e.c.t.
Edited by Outcasst - 6/17/11 at 5:39am
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
My System
(19 items)
 
  
CPUMotherboardGraphicsRAM
Core i7-7700k Asus Maximus IX Hero EVGA GTX 1080 Ti 16GB Corsair Vengeance LED 3200 
Hard DriveHard DriveHard DriveHard Drive
Samsung 960 Evo NVme Corsair Neutron GTX 240GB Mushkin Chronos 480GB Toshiba 1TB 
Hard DriveCoolingOSMonitor
OCZ Vertex 3 120GB NZXT Kraken X62 Windows 10 x64 Pro Dell S2716DG 
KeyboardPowerCaseMouse
Corsair K90 Corsair AX850 NZXT S340 Elite White Steelseries Rival 
Mouse PadAudio
Razer Goliathus Asus Xonar STX 
  hide details  
Reply
post #6 of 8
I never experienced such problems with my sli setup in BFBC2. You should stress-test your setup to see if it's artifacting or something of the sort.
post #7 of 8
are you monitoring the temps while playing? what you described sounds like heat issues.

the black streaks when you zoom are either gpu heat or motherboard heat related. I moved my pc from a case (lian li K62 great air-flow) to a test bench and started getting same thing, black areas when I zoomed. I threw a couple of fans on top of the NB, SB, and VRM's and it's fine now. My gpu temps were fine, it was the mobo that needed air-flow.
Edited by mtbiker033 - 6/17/11 at 6:28am
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
Easy V3
(17 items)
 
12 Pack
(15 items)
 
 
CPUMotherboardGraphicsRAM
i7-4820k Asus Rampage IV BE evga 1080ti FE w/ hybrid kit 16 GB G.Skill Trident X 2400mhz  
Hard DriveHard DriveOptical DriveCooling
Samsung 840 EVO 120gb Samsung 840 EVO 1TB Samsung Blu-ray Corsair H110 
OSMonitorKeyboardPower
windows 10 Asus PG278Q Ducky Shine 3 - blue led - cherry mx browns Seasonic Platinum-1000 
CaseMouseMouse PadAudio
Dimastech Easy V3 Mionix NAOS 8200 Mionix Ensis 320 titanium HD  
Other
audio technica ATH-A900X 
  hide details  
Reply
post #8 of 8
I have a 580 SLI setup and had issues when I used them. I tested each 580 by itself and discovered that one of them was DOA. So I had to RMA a brand new 580. Of course they gave me a brand new one back.
So I suggest testing each one all by itself and see if one is bad and not the other. Cause I have no issues at all with mine and Bad Company 2 is pretty much the only game that I play.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 980X @ 4.1 eVGA X58 Classified eVGA GTX 780 Classified SLI 12 GB DDR 3 GSkill Ripjaws 
Hard DriveOSMonitorKeyboard
Samsung 240GB SSD / 1TB Mushkin SSD Win 8.1 64 Bit Acer XB270HU Logitech G710+ 
PowerCaseMouse
Corsair AX1200 ANTEC 1200 Logitech G700s 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
i7 980X @ 4.1 eVGA X58 Classified eVGA GTX 780 Classified SLI 12 GB DDR 3 GSkill Ripjaws 
Hard DriveOSMonitorKeyboard
Samsung 240GB SSD / 1TB Mushkin SSD Win 8.1 64 Bit Acer XB270HU Logitech G710+ 
PowerCaseMouse
Corsair AX1200 ANTEC 1200 Logitech G700s 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: NVIDIA
Overclock.net › Forums › Graphics Cards › NVIDIA › SLI and Bad Company 2