Overclock.net › Forums › Video Games › PC Gaming › Unnecessary fps drops in Counter Strike Source
New Posts  All Forums:Forum Nav:

Unnecessary fps drops in Counter Strike Source

post #1 of 14
Thread Starter 
Hello Overclockers,

I have been getting strange fps problems in counter strike source with the rig built myself. Large fps drops in smokes and in gunfire. Also, the more the people in the servers, the lower the fps.

Ran Hard Disk Sentinel and my HD health was at 55% and the error specified that there is a motor, bearing or power supply issue.

Fresh install of Windows Ultimate 64 bit

11.6 ATI Catalyst drivers Installed

What I think the issue may be: Either the PSU is not giving sufficient power to the system or the HD is going bad.

Please help me overclocker's community, any feedback will be appreciated.

In game settings:

Resolution: 1920 x 1080

Model Detail:High

Texture Detail:High

Shader Detail:High

Water Detail:Reflect World

Shadow Detail:High

Color Correction: Disabled

Anti-aliasing Mode: None

Filtering Mode: Trilinear

Vertical Sync: Disabled

High Dynamic Range: None

DirectX level +9.0

==============================================================================================

Rig Specifications:

[CPU]--- AMD Phenom II X4 965 @ 3.4 stock http://www.newegg.com/Product/Product.aspx?Item=N82E16819103727&cm_re=phenom_ii_x4-_-19-103-727-_-Product

[GPU]--- HIS HD 5770 http://www.newegg.com/Product/Product.aspx?Item=N82E16814161338&cm_re=his_hd_5770_1gb-_-14-161-338-_-Product

[MOTHERBOARD]--- ASUS M4A88TD-V EVO/USB3 http://www.newegg.com/Product/Product.aspx?Item=N82E16813131646

[PSU]--- Rocketfish 550W

[RAM]--- 2x2Gb (4 gig total) patriot 1333 MHz http://www.directron.com/psd34g1333kh.html

[CPU FAN]--- Xigmatek 120mm http://www.newegg.com/Product/Product.aspx?Item=N82E16835233003&cm_re=xigmatek_120_mm_cooler-_-35-233-003-_-Product

[HARD DRIVE]--- Seagate Barracuda http://www.newegg.com/Product/Product.aspx?Item=N82E16822148699&cm_re=seagate_barracuda-_-22-148-699-_-Product

Thank You,

1cemaN
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
post #2 of 14
It could be your drivers. I've had no end of problems with some games in regards to FPS (especially The Witcher 2) since I updated to the latest.

Try rolling back to 11.5 or before and see if that changes anything.
War Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670k @ 3.4ghz Asus B85M Gamer MSI Twin Frozr V R9 390X 8gb Kingston Hyper X Beast 16gb 
Hard DriveCoolingCoolingOS
HGS 2.5" Sata 1tb Corsair H100i v2 4 x Corsair SP120 Quiet Windows 10 64bit 
MonitorKeyboardPowerCase
Benq RL2455 Microsoft Sidewinder X4 EVGA Supernova G2 750w Corsair Carbide Air 240 
MouseMouse PadAudio
Razer Naga Molten Edition Steel Series Guild Wars 2 Sennheiser HD201 
  hide details  
Reply
War Machine
(15 items)
 
  
CPUMotherboardGraphicsRAM
Intel i5 4670k @ 3.4ghz Asus B85M Gamer MSI Twin Frozr V R9 390X 8gb Kingston Hyper X Beast 16gb 
Hard DriveCoolingCoolingOS
HGS 2.5" Sata 1tb Corsair H100i v2 4 x Corsair SP120 Quiet Windows 10 64bit 
MonitorKeyboardPowerCase
Benq RL2455 Microsoft Sidewinder X4 EVGA Supernova G2 750w Corsair Carbide Air 240 
MouseMouse PadAudio
Razer Naga Molten Edition Steel Series Guild Wars 2 Sennheiser HD201 
  hide details  
Reply
post #3 of 14
Quote:
Originally Posted by 1cemaN;13925737 
Hello Overclockers,

I have been getting strange fps problems in counter strike source with the rig built myself. Large fps drops in smokes and in gunfire. Also, the more the people in the servers, the lower the fps.

Ran Hard Disk Sentinel and my HD health was at 55% and the error specified that there is a motor, bearing or power supply issue.

Fresh install of Windows Ultimate 64 bit

11.6 ATI Catalyst drivers Installed

What I think the issue may be: Either the PSU is not giving sufficient power to the system or the HD is going bad.

Please help me overclocker's community, any feedback will be appreciated.

In game settings:

Resolution: 1920 x 1080

Model Detail:High

Texture Detail:High

Shader Detail:High

Water Detail:Reflect World

Shadow Detail:High

Color Correction: Disabled

Anti-aliasing Mode: None

Filtering Mode: Trilinear

Vertical Sync: Disabled

High Dynamic Range: None

DirectX level +9.0

==============================================================================================

Rig Specifications:

[CPU]--- AMD Phenom II X4 965 @ 3.4 stock http://www.newegg.com/Product/Product.aspx?Item=N82E16819103727&cm_re=phenom_ii_x4-_-19-103-727-_-Product

[GPU]--- HIS HD 5770 http://www.newegg.com/Product/Product.aspx?Item=N82E16814161338&cm_re=his_hd_5770_1gb-_-14-161-338-_-Product

[MOTHERBOARD]--- ASUS M4A88TD-V EVO/USB3 http://www.newegg.com/Product/Product.aspx?Item=N82E16813131646

[PSU]--- Rocketfish 550W

[RAM]--- 2x2Gb (4 gig total) patriot 1333 MHz http://www.directron.com/psd34g1333kh.html

[CPU FAN]--- Xigmatek 120mm http://www.newegg.com/Product/Product.aspx?Item=N82E16835233003&cm_re=xigmatek_120_mm_cooler-_-35-233-003-_-Product

[HARD DRIVE]--- Seagate Barracuda http://www.newegg.com/Product/Product.aspx?Item=N82E16822148699&cm_re=seagate_barracuda-_-22-148-699-_-Product

Thank You,

1cemaN

may i recommended you add your rig specs into your sig Link
Main Rig
(12 items)
 
  
CPUMotherboardGraphicsRAM
R7 1800x ASUS Prime 370 Pro RX 480 Corsair Dominator 
Hard DriveOptical DriveOSMonitor
Samsung 850 Pro  None Windows 10 Pro HP w19e: 1440x900 | Sony KDL40S-5100 1920x1080 
KeyboardPowerCaseMouse
CMStorm Quick Fire. CM 1050w  Cooler Master Cosmos II Roccat Kone XTD (Optical) 
  hide details  
Reply
Main Rig
(12 items)
 
  
CPUMotherboardGraphicsRAM
R7 1800x ASUS Prime 370 Pro RX 480 Corsair Dominator 
Hard DriveOptical DriveOSMonitor
Samsung 850 Pro  None Windows 10 Pro HP w19e: 1440x900 | Sony KDL40S-5100 1920x1080 
KeyboardPowerCaseMouse
CMStorm Quick Fire. CM 1050w  Cooler Master Cosmos II Roccat Kone XTD (Optical) 
  hide details  
Reply
post #4 of 14
Your PSU seems shabby. Could cause it if it aren't the drivers.
The
(17 items)
 
  
Reply
The
(17 items)
 
  
Reply
post #5 of 14
Thread Starter 
@ Lifeshield: I will try doing that, thanks

@ disturbed117: Will do, thanks

@ p4p3r: Yea the PSU can be very much the issue, thanks

Here is what I have done:

http://4.bp.blogspot.com/_Qe5gpCqfcqc/TSOmVIu-u2I/AAAAAAAAAAw/NwW3QqN5JjE/s1600/throttleindex_fixed.jpg

Changed the hexadecimal on the Network ThrottlingIndex

Then I stopped the Windows Event Log in the "Services" tab in msconfig, seems to be more stable.

Thank you all for you feedback.
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
post #6 of 14
What are your AA/AF settings?
My system used to choke and die with AA/AF too high.
Das Rig, Ja?
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 Asus Crosshair VI EVGA 1080Ti SC2 2x16G GSkill RGB 3200 
Hard DriveCoolingOSMonitor
500 GB 960 EVO Enermax T50A-BVT Windows 10 Pro 27" Asus 
KeyboardPowerCaseMouse
Logitech K350 EVGA 1600G2 Fractal Define C Rosewill M55 RGB 
  hide details  
Reply
Das Rig, Ja?
(12 items)
 
  
CPUMotherboardGraphicsRAM
AMD Ryzen 1700 Asus Crosshair VI EVGA 1080Ti SC2 2x16G GSkill RGB 3200 
Hard DriveCoolingOSMonitor
500 GB 960 EVO Enermax T50A-BVT Windows 10 Pro 27" Asus 
KeyboardPowerCaseMouse
Logitech K350 EVGA 1600G2 Fractal Define C Rosewill M55 RGB 
  hide details  
Reply
post #7 of 14
The FPS drops you talk about sound completely normal. More people on a server will put more strain on your system, as will smoke. What kind of FPS are we talking here? If you are getting 30-40 or something then you have a major problem. If you are getting 120-200 then you are probably about where you should be.

Also with a 5770 you should be able to bump up your AA & AF considerably.
post #8 of 14
Thread Starter 
@ beers: No AA, Filtering is set to Trilinear

@ eggs2see: Doesn't seem normal because mouse lags in gunfire
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
post #9 of 14
Thread Starter 
Just changed the PSU, still the same results. Next thing I will change is the Hard Drive
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
AMD Phenom II X4 965 @ 3.4 GHz ASUS M4A88TD-V EVO/USB3 HIS HD 5770 2x2Gb (4 gig total) Patriot 1333 MHz 
Hard DriveOSMonitorKeyboard
300 GB Seagate Barracuda (7200 rpm) Windows 7 - Ultimate 64 bit Acer H243Hbmid 24" Compaq 
PowerCaseMouseMouse Pad
Raidmax Rx-850AE (850 W) Antec 900 Logitech Mx518 Xtrac Ripper 
  hide details  
Reply
post #10 of 14
try pulling out the card and plug it in. check the power connectors to make sure they're snug in place.
btw i think you should at least have 16x anisotropic filtering and 4x AA for a game this old.
Dream PC
(17 items)
 
Surface Pro 3
(9 items)
 
 
CPUMotherboardGraphicsRAM
INTEL Core i7 6700K ASUS Maximus VIII Hero Z170 MSI Geforce GTX 980 Ti Gaming 6G G.SKILL Ripjaws 4 series 16GB DDR4 3000 
Hard DriveHard DriveCoolingOS
SAMSUNG SM951 NVMe 512GB SAMSUNG 850 EVO 1TB COOLER MASTER Nepton 280L MICROSOFT Windows 10 Pro x64 
MonitorMonitorKeyboardPower
BENQ XL2420TE DELL UltraSharp U2415 WASD V2 custom CORSAIR HX850i 
CaseMouseAudioOther
NZXT H440 white CORSAIR Vengeance M95 CREATIVE Sound Blaster Z CPU Delid 
Other
LED Lighting 
CPUMotherboardGraphicsRAM
Intel Core i5 4300U Microsoft Surface Intel HD Graphics 4400 8 GB DDR3L 
Hard DriveOSKeyboardMouse
256 GB SSD Windows 10 Pro x64 Surface Pro 4 Type Cover with Fingerprint ID Microsoft Arc Mouse Surface Edition 
  hide details  
Reply
Dream PC
(17 items)
 
Surface Pro 3
(9 items)
 
 
CPUMotherboardGraphicsRAM
INTEL Core i7 6700K ASUS Maximus VIII Hero Z170 MSI Geforce GTX 980 Ti Gaming 6G G.SKILL Ripjaws 4 series 16GB DDR4 3000 
Hard DriveHard DriveCoolingOS
SAMSUNG SM951 NVMe 512GB SAMSUNG 850 EVO 1TB COOLER MASTER Nepton 280L MICROSOFT Windows 10 Pro x64 
MonitorMonitorKeyboardPower
BENQ XL2420TE DELL UltraSharp U2415 WASD V2 custom CORSAIR HX850i 
CaseMouseAudioOther
NZXT H440 white CORSAIR Vengeance M95 CREATIVE Sound Blaster Z CPU Delid 
Other
LED Lighting 
CPUMotherboardGraphicsRAM
Intel Core i5 4300U Microsoft Surface Intel HD Graphics 4400 8 GB DDR3L 
Hard DriveOSKeyboardMouse
256 GB SSD Windows 10 Pro x64 Surface Pro 4 Type Cover with Fingerprint ID Microsoft Arc Mouse Surface Edition 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: PC Gaming
Overclock.net › Forums › Video Games › PC Gaming › Unnecessary fps drops in Counter Strike Source