Overclock.net › Forums › AMD › AMD Motherboards › The AMD ASRock Extreme Series Motherboard Club
New Posts  All Forums:Forum Nav:

The AMD ASRock Extreme Series Motherboard Club - Page 33

post #321 of 899
Thread Starter 
Okay, cool. Any difference between 1.44 and 1.47? Do they work with the G510 keyboard? Because I'm not updating now to find out I can't use the keyboard... And have to go steal my brothers' one at 3AM redface.gif
post #322 of 899
The keyboard should do fine, only Logitech mouses make some isues. wink.gif
post #323 of 899
Thread Starter 
The reason I'm asking is because my G510 doesn't work on 1.30. With a different keyboard, my G500 mouse works fine once inside the UEFI. So yeah redface.gif
post #324 of 899
My MX518 didn't work with Logitech Wave and Microsoft natural 4000 biggrin.gif

Logitech make the problem, because the Microsoft natural 6000 Wifi mouse work fine.

But who needs the mice? Just use the keyboard biggrin.gif
post #325 of 899
Thread Starter 
I would, but the problem is that the keyboard is not detected during the boot phase and thus I can't enter the UEFI to change the SATA controller for the default IDE to AHCI to prevent a BSOD!

Even after I change the setting, I still need a different keyboard to make sure I can select to boot windows instead of launching startup repair.

So you can see the predicament I'm in. If it doesn't like the keyboard, and I can't get another one to use til later, I ain't got a functioning computer tongue.gif
post #326 of 899
Its not the keyboard, its the USB setting.

Enable USB 2.0 and USB3.0 Legacy support and You are good to go! wink.gif
post #327 of 899
Thread Starter 
It's not that. I had the same issue on my 890GX board as well.

That being that with the newest UEFI, the G510 is the only keyboard I have that won't let me into the UEFI or do anything pre-windows. Even after using a different keyboard to get all my settings right again, the board's UEFI just spits the dummy at the G510. It's the same story for ASRock's Intel boards as well. Something in the latest UEFI is interfering with the G510. It's a real pain too frown.gif
post #328 of 899
Enable USB 2.0 and USB3.0 Legacy support -> have You checked this?

I have following motherboards from ASRock:
990FX Pro
890FX Deluxe4
890GX Extreme3
870 Extreme3 (rev1)
770 Extreme3
M3A770DE
770DE+
A780GXH/128M

They work like a charm, just enable the USB Legacy Support in BIOS/UEFI,
You should be fine then.

And now GO, get the old PS/2 keyboard and enable this.

PS - Use the first two USB's on the TOP of the MBO.
post #329 of 899
Thread Starter 
Yeah I've checked that option multiple times. It's an issue with all ASRock boards and the G510 keyboard on the latest firmwares, settings notwithstanding.


Have a look through here: http://forums.tweaktown.com/asrock/ and see how many posts about not being able to get into the UEFI with the G510 keyboard frown.gif
post #330 of 899
Well then You're fuuucked biggrin.gif

Get a new Keyboard, loose G510 and get some Microsoft keyboard wink.gif
(joking, wait for the Official 1.40 or new BETA)
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: AMD Motherboards
Overclock.net › Forums › AMD › AMD Motherboards › The AMD ASRock Extreme Series Motherboard Club