Overclock.net › Forums › Components › Hard Drives & Storage › Can't set active partition in diskpart.
New Posts  All Forums:Forum Nav:

Can't set active partition in diskpart.

post #1 of 4
Thread Starter 
I've been trying to recreate the boot partition on a cloned hdd all day >_>. Using bootrec /RebuildBcd gives the error "element not found". To fix this error I apparently have to go into diskpart. The following happens.

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> select partition 2

Partition 2 is now the selected partition.

DISKPART> active

Virtual Disk Service error:
The specified partition type is not valid for this operation.


I've also tried bootsect /nt60 ALL but that doesn't work and still gives me the same error, I really need to set C to the active/system partition, it's not already active as typing inactive will tell me it's already inactive ://
Current
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k P8P67 Pro ASUS DirectCU II HD 6950 2x4gb G.Skill RipjawsX 1600mhz 
Hard DriveOptical DriveOSMonitor
Corsair force series 3 60gb & 1.5tb 5400rpm LG dvd rewriter Windows 7 64 BenQ xl2420t 
KeyboardPowerCaseMouse
Razer Blackwidow Expert XFX 550w PRO NZXT Phantom Logitech G500 
Mouse Pad
None 
  hide details  
Reply
Current
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k P8P67 Pro ASUS DirectCU II HD 6950 2x4gb G.Skill RipjawsX 1600mhz 
Hard DriveOptical DriveOSMonitor
Corsair force series 3 60gb & 1.5tb 5400rpm LG dvd rewriter Windows 7 64 BenQ xl2420t 
KeyboardPowerCaseMouse
Razer Blackwidow Expert XFX 550w PRO NZXT Phantom Logitech G500 
Mouse Pad
None 
  hide details  
Reply
post #2 of 4
Quote:
Originally Posted by Lost4468;14158869 
I've been trying to recreate the boot partition on a cloned hdd all day >_>. Using bootrec /RebuildBcd gives the error "element not found". To fix this error I apparently have to go into diskpart. The following happens.

DISKPART> select disk 0

Disk 0 is now the selected disk.

DISKPART> select partition 2

Partition 2 is now the selected partition.

DISKPART> active

Virtual Disk Service error:
The specified partition type is not valid for this operation.


I've also tried bootsect /nt60 ALL but that doesn't work and still gives me the same error, I really need to set C to the active/system partition, it's not already active as typing inactive will tell me it's already inactive ://
Use a different partitioning software other than diskpart. Diskpart causes soooo many problems for everyone all the time.

Easeus partition manager:
http://www.partition-tool.com/download.htm

GParted partition manager:
http://download.cnet.com/GParted-LiveCD/3000-2094_4-10698802.html
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
Synergy
(19 items)
 
Mobile machine
(9 items)
 
 
CPUMotherboardGraphicsRAM
Phenom II X4 955 Black Edition @ 4.3Ghz Asus M5A99X Evo Crossfire XFX 6870's Corsair Vengeance 16GB 1333Mhz 
Hard DriveHard DriveHard DriveOptical Drive
Western Digital caviar blue 1TB 7200RPM Western Digital caviar blue 320GB 7200RPM OCZ Solid series SSD 60GB 6Gb/s Some Sony DVD/CD drive 
CoolingOSOSMonitor
XSPC Rasa 750 RS360 liquid-cooling Windows 7 Ultimate x64 Ubuntu 11.4 Viewsonic 27" 1920x1080 
MonitorKeyboardPowerCase
HP 18.5" 1440x900 Logitech G510 Gaming keyboard CM modular silent pro 1000w Heavily modded Cooler Master HAF 922 
MouseMouse PadAudio
Microsoft Intellipoint ergonomic W.O. mouse my desk Coby 5.1 surround 
CPUMotherboardGraphicsRAM
Intel i5 M480 @ 2.67Ghz Stock Lenovo mobo Integrated Intel HD graphics 4GB 1333Mhz 
Hard DriveOptical DriveCoolingOS
Hitachi 500GB 5400RPM HDD General use DVD/CD drive integrated laptop heatsink Windows 7 Home Premium 
Monitor
15.6 Inch monitor 
  hide details  
Reply
post #3 of 4
Are you sure that partition 2 is a primary partition? What is the output of disk detail?
post #4 of 4
Thread Starter 
Thanks, it's all working now.
Current
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k P8P67 Pro ASUS DirectCU II HD 6950 2x4gb G.Skill RipjawsX 1600mhz 
Hard DriveOptical DriveOSMonitor
Corsair force series 3 60gb & 1.5tb 5400rpm LG dvd rewriter Windows 7 64 BenQ xl2420t 
KeyboardPowerCaseMouse
Razer Blackwidow Expert XFX 550w PRO NZXT Phantom Logitech G500 
Mouse Pad
None 
  hide details  
Reply
Current
(13 items)
 
  
CPUMotherboardGraphicsRAM
i5 2500k P8P67 Pro ASUS DirectCU II HD 6950 2x4gb G.Skill RipjawsX 1600mhz 
Hard DriveOptical DriveOSMonitor
Corsair force series 3 60gb & 1.5tb 5400rpm LG dvd rewriter Windows 7 64 BenQ xl2420t 
KeyboardPowerCaseMouse
Razer Blackwidow Expert XFX 550w PRO NZXT Phantom Logitech G500 
Mouse Pad
None 
  hide details  
Reply
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: Hard Drives & Storage
Overclock.net › Forums › Components › Hard Drives & Storage › Can't set active partition in diskpart.