Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Fix for IRST Lock Ups
New Posts  All Forums:Forum Nav:

Fix for IRST Lock Ups

post #1 of 3
Thread Starter 
I figure I would post this here because I ask more and don't contribute enough! But I in case anyone is have a similar problem as I was having, I found a fix for it.

First off, if you have a motherboard that requires the use of Intel Rapid Storage Technology drivers then this should help you.

The main issue I was having was I would get a 2-3 minute lock up every time I turned my computer or restarted it and this error would be in Event Viewer:
Quote:
The device, \Device\Ide\iaStor0, did not respond within the timeout period.

This is a common problem with people who own SSD's or if your HD's are in a raid. If you are experiencing the same issue with lock ups or the above error then try this fix:
Quote:
Hello to all, @first sorry for my English, I am German! Wer den Text lieber in Deutsch lesen möchte, kann auch hier die Problemlösung nachlesen.



I want to tell all the people in this community who also have freeze-ups with the great C300 Crucial SSD and Windows 7, for me i have found a solution that works!



Two month of waiting for an new Rapid Storage from Intel or a new Firmware from Crucial, i found the solution by myself. At first i want to say, please forgive me Crucial, it is a shame for Crucial, that it comes no solution from the SSD Maker himself in the other big thread called "C300 Disk Freeze-ups in Windows 7”"since six month! It is a shame!



So, my problem was, since I use the P67 Chipset, the hole System hangs from time to time very long when I use the Rapid Storage from Intel, the entry in the Event Viewer is: Event ID:9 - The device, \Device\Ide\iaStor0, did not respond within the timeout period.



The solution is easy! The problem is, that the C300 SSD cannot handle the LPM-Feature from the Rapid Storage from Intel. Crucial, please check the firmware from the C300 about LPM and test it in your labs! Since Version 10 of the Rapid Storage LPM is enabled by default, when you make a clean new installation from the RST and that was the problem on my system. I deactivate LPM on all ports by modify the Registry and the problem was solved directly, the freeze-ups are gone – so easy is it! Also the speed from the SSD goes dramatically up!



The needed Reg-File to disable LPM on all Intel Ports it is easy to create. Create a new Text-File, copy and paste the following text and then name it for example “LPM.reg”. When you have save the file double click on the file, restart your System and that’s it. On the next boot up LPM is disabled. You can also disable only one or two ports and so on. Then you must delete the line from that port, who you don’t want to disable LPM.


Copy start at the next line:
Windows Registry Editor Version 5.00


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor\Parameters\Port0]

"LPM"=dword:00000000
"LPMDSTATE"=dword:00000000
"DIPM"=dword:00000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor\Parameters\Port1]

"LPM"=dword:00000000
"LPMDSTATE"=dword:00000000
"DIPM"=dword:00000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor\Parameters\Port2]

"LPM"=dword:00000000
"LPMDSTATE"=dword:00000000
"DIPM"=dword:00000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor\Parameters\Port3]

"LPM"=dword:00000000
"LPMDSTATE"=dword:00000000
"DIPM"=dword:00000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor\Parameters\Port4]

"LPM"=dword:00000000
"LPMDSTATE"=dword:00000000
"DIPM"=dword:00000000


[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor\Parameters\Port5]

"LPM"=dword:00000000
"LPMDSTATE"=dword:00000000
"DIPM"=dword:00000000
Copy end up over this line:





Also you can do it by hand, thanks to Ady:



If there are no "Ports" under the iaStorV/iaStor Parameters, you will need to Manually Creating the Registry Location and Keys:

1. Go to Start-> Run..

2. Type in RegEdit and hit the Enter Key..

3. Go to the following Key location to insert or configure the registry keys for LPM:

Code:



HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStor\Parameters\





4a. Right click "Parameters" select "New" then name it "Port0".

4b. Left click "Port0" to open and in the pane with Name/Type/Data, Right click select "New" then "DWORD" and name the new value "LPM".

4c. Repeat 4a/4b "LPMDSTATE" and "DIPM".



5. When you want to ad the other Ports also to registry, then repeat the steps from 4a to 4c and name it Port1, Port2, Port3, Port4 and Port5.



So, give it a try, i hope it works also at your side, not only just for me! I am disable LPM from now directly on any new installation!



Kind Regards
Zoorki


At the end - here are the text what Intel says about LMP in the Rapid Storage since Version 10:



Link Power Management with Intel® Rapid Storage Technology

Intel® Rapid Storage Technology implements the Link power management (LPM) feature described by the Serial ATA specification to overcome the power demand of a high-speed serial interface, SATA and providing the capability of SATA at the minimum power cost. LPM, when used in conjunction with a SATA hard drive that supports this feature, enables lower power consumption. LPM was initially enabled by default on mobile platforms starting with ICH6M with Intel® Matrix Storage Manager. Starting with ICH9R this feature has also been supported on desktop platforms with Intel® Matrix Storage Manager 7.5 release but not enabled by default. Beginning with the Intel® Rapid Storage Technology 10.0 release, LPM support is enabled by default on both mobile and desktop platforms. OEM’s who wish to modify the default settings for LPM on their platforms can follow the instructions in the following section(s).

Instructions to disable/enable LPM

After system is setup with OS and Intel® Rapid Storage Technology installed, follow the below instructions to modify the default LPM support.

NOTE: Beginning with the Intel® Rapid Storage Technology 10.0 release, the registry keys are no longer populated in the Windows registry by default. The RST driver does not require the registry keys to be present to support the default settings.

1. Go to Start->Run
2. Type in RegEdit and hit the Enter Key.
3. Go to the below mentioned location to insert or configure the registry keys for LPM
NOTE: OEM’s need to configure the LPM settings by port. Ports are numbered starting with zero (please refer the desired platform EDS for the number of ports supported on that platform)

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\iaStor\Parame
ters\Port0\
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\iaStor\Parame
ters\Port1\

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Servic es\iaStor\Parame
ters\Port5\

4. Now add the following registry keys under the registry location mentioned in step3, if they are not available (These registry keys are not available by default, they can be added by using utomated scripts, .reg files, executable utilities, etc). If you find the below registry keys already available, you can modify the values for desired support. Values are modified on a port by port basis so modify all ports that you wish the changes to be supported on. **

“LPM”=dword: 00000001 {dword: 00000000->Disable; dword: 00000001->Enable} [default = Enabled]
“LPMSTATE”=dword: 00000000 {dword: 00000000->Partial; dword: 00000001->Slumber} [default = Disabled] (Note: the driver ignores this key when the LPM key’svalue is not set to 1. So when LPM value is 0, this value is N/A.)
“LPMDSTATE”=dword: 00000001 {dword: 00000000->Partial; dword: 00000001->Slumber} [default = Enabled]
“DIPM”=dword: 00000001 {dword: 00000000->Disable; dword: 00000001->Enable} [default = Enabled]

**Warning: If you edit the registry incorrectly, you can cause serious problems that may require you to reinstall your operating system. Intel does not guarantee that problems that are caused by editing the Registry incorrectly can be resolved.
(Original Source)

Basically with the newest IRST drivers it auto has on the LPM, which causes the lock ups, and if you follow the first part where you create a registry file, it will create the registry values and disable the LPM. After having to deal with this issue for a month this finally worked for me. Hope this helps anyone else out! drunken.gif
post #2 of 3
Just wondering......... have you updated your BIOS to 1850?
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E6600 (LL629A) DFI BLOOD IRON P35-T2RL Diamond HD3870 GSkill ( 2x1G) DDR2-800 HZ's 
OSMonitorKeyboardCase
Windows XP Home (OEM) Sceptre 22" + Sceptre 20" Logitech G15 XG VIPER ( hey, it was free.) 
Mouse
LOGITECH MX518 
  hide details  
Reply
My System
(13 items)
 
  
CPUMotherboardGraphicsRAM
Intel E6600 (LL629A) DFI BLOOD IRON P35-T2RL Diamond HD3870 GSkill ( 2x1G) DDR2-800 HZ's 
OSMonitorKeyboardCase
Windows XP Home (OEM) Sceptre 22" + Sceptre 20" Logitech G15 XG VIPER ( hey, it was free.) 
Mouse
LOGITECH MX518 
  hide details  
Reply
post #3 of 3
Thread Starter 
I did update my bios to 1850 and immediately after that it still locked upon next reboot.
New Posts  All Forums:Forum Nav:
  Return Home
  Back to Forum: SSD
Overclock.net › Forums › Components › Hard Drives & Storage › SSD › Fix for IRST Lock Ups